Loading ...
Sorry, an error occurred while loading the content.

vnc, webmin freelink

Expand Messages
  • michael_harper75
    I just got freelink installed, and am able to boot, I can telnet in, and ssh, but when i try to start the vncserver, i get vncserver: couldn t find xauth on
    Message 1 of 4 , Dec 26, 2005
    • 0 Attachment
      I just got freelink installed, and am able to boot, I can telnet in,
      and ssh, but when i try to start the vncserver, i get "vncserver:
      couldn't find "xauth" on your PATH.", I have installed all the
      componenets via apt, and I was able to start the vncserver when i was
      still in the chroot enviornment. Has anyone had a smiliar problem?

      also, webmin gives me "error-access denied" and i have set the
      allow=myip option in the config file
    • lalunas10
      ... I doubt you installed all the components :) # apt-cache search xauth # apt-get install xbase-clients ... Can t help you with that, sorry. -Andre
      Message 2 of 4 , Dec 27, 2005
      • 0 Attachment
        --- In LinkStation_General@yahoogroups.com, "michael_harper75" <cain171562@g...>
        wrote:
        >
        > I just got freelink installed, and am able to boot, I can telnet in,
        > and ssh, but when i try to start the vncserver, i get "vncserver:
        > couldn't find "xauth" on your PATH.", I have installed all the
        > componenets via apt, and I was able to start the vncserver when i was
        > still in the chroot enviornment. Has anyone had a smiliar problem?

        I doubt you installed "all the components" :)

        # apt-cache search xauth
        # apt-get install xbase-clients

        > also, webmin gives me "error-access denied" and i have set the
        > allow=myip option in the config file

        Can't help you with that, sorry.

        -Andre
      • jon_edney
        I had exactly the same problem. Firstly, make sure you are logged in as root (if your not prompted for a login, you should be ok), otherwise type su and
        Message 3 of 4 , Dec 27, 2005
        • 0 Attachment
          I had exactly the same problem. Firstly, make sure you are logged in
          as root (if your not prompted for a login, you should be ok),
          otherwise type "su" and enter the root password.

          Type:

          cd /usr/bin/X11
          vncserver -name BuffaloVNC -depth 16 -geometry 800x600

          Alternativly swap the top line with:

          set PATH=$PATH:/usr/bin/X11

          This will add the correct directory to the search path, but I don't
          know how to save this so you will have to do it each time.

          I have created a script called "vnc" in /bin with the two lines at
          the top of this message so I can just type "vnc" to start the server.

          Hope this helps.
          Jon.
        • michael_harper75
          ... Hey jon, thanks that did the trick, vnc works now, and the resolutionis better i guess it was the -geometry tag
          Message 4 of 4 , Dec 27, 2005
          • 0 Attachment
            --- In LinkStation_General@yahoogroups.com, "jon_edney" <yahoo@e...>
            wrote:
            >
            > I had exactly the same problem. Firstly, make sure you are logged in
            > as root (if your not prompted for a login, you should be ok),
            > otherwise type "su" and enter the root password.
            >
            > Type:
            >
            > cd /usr/bin/X11
            > vncserver -name BuffaloVNC -depth 16 -geometry 800x600
            >
            > Alternativly swap the top line with:
            >
            > set PATH=$PATH:/usr/bin/X11
            >
            > This will add the correct directory to the search path, but I don't
            > know how to save this so you will have to do it each time.
            >
            > I have created a script called "vnc" in /bin with the two lines at
            > the top of this message so I can just type "vnc" to start the server.
            >
            > Hope this helps.
            > Jon.
            >
            Hey jon, thanks that did the trick, vnc works now, and the
            resolutionis better i guess it was the -geometry tag
          Your message has been successfully submitted and would be delivered to recipients shortly.