Loading ...
Sorry, an error occurred while loading the content.
 

Re: getting mpd running

Expand Messages
  • lalunas10
    ... Interesting, thanks! ... echo audio /etc/modules (You need to do that only once, the module should load automatically in the boot process from now on
    Message 1 of 3 , Dec 18, 2005
      --- In LinkStation_General@yahoogroups.com, "Bob Jageman" <rcalinjageman@y...>
      wrote:
      >
      > Got a reply from the mpd boards that fixed my problem.
      >
      > It seems I hadn't properly defined 'localhost', thus making it
      > impossible for clients to connect to mpc when configured with 'localhost.
      >
      > In hosts, I had
      >
      > 127.0.0.1 myls
      >
      > I changed this to
      >
      > 127.0.0.1 localhost myls
      >
      > Viola--mpd running on my ls and output via usb sound.

      Interesting, thanks!

      > Unfortunately, I still have to manually start the audio module with
      > modprobe. If I try insmod audio as root, I get:
      > LinkStation:/home/rcalinjageman# insmod audio
      > Using /lib/modules/2.4.17_mvl21-sandpoint/kernel/drivers/usb/audio.o
      > /lib/modules/2.4.17_mvl21-sandpoint/kernel/drivers/usb/audio.o:
      > /lib/modules/2.4.17_mvl21-sandpoint/kernel/drivers/usb/audio.o:
      > unresolved symbol unregister_sound_dsp
      > /lib/modules/2.4.17_mvl21-sandpoint/kernel/drivers/usb/audio.o:
      > /lib/modules/2.4.17_mvl21-sandpoint/kernel/drivers/usb/audio.o:
      > unresolved symbol register_sound_dsp
      > /lib/modules/2.4.17_mvl21-sandpoint/kernel/drivers/usb/audio.o:
      > /lib/modules/2.4.17_mvl21-sandpoint/kernel/drivers/usb/audio.o:
      > unresolved symbol register_sound_mixer
      > /lib/modules/2.4.17_mvl21-sandpoint/kernel/drivers/usb/audio.o:
      > /lib/modules/2.4.17_mvl21-sandpoint/kernel/drivers/usb/audio.o:
      > unresolved symbol unregister_sound_mixer
      >
      >
      > any suggestions?

      echo "audio" >> /etc/modules

      (You need to do that only once, the module should load automatically in the boot process
      from now on -- so you need to reboot to see the effect)

      Another, less canonical way if the above shouldn't work:

      echo "modprobe audio" >> /etc/init.d/bootmisc.sh

      (see above)

      -Andre
    Your message has been successfully submitted and would be delivered to recipients shortly.