Loading ...
Sorry, an error occurred while loading the content.

RE: [LinkStation_General] Re: usb sound

Expand Messages
  • lists
    Bob, James, I was the one James helped out ... I had already documented my steps in a new Forum thread but my internet connection died before sending it out.
    Message 1 of 11 , Dec 15, 2005
    • 0 Attachment
      Bob, James,

      I was the one James helped out ...

      I had already documented my steps in a new Forum thread but my internet
      connection died before sending it out. Afterwards I just forgot it.

      The setup was quite simple after figuring out that the kernel caused the
      trouble. Afterall it was just:

      Install freelink 1.11
      Install usbutils & hotplug
      Replace the kernel with the one James' provided me with (the fl1 image)
      Chmod for /dev/mixer
      Reboot

      Sound is starting up automatically on boot and works without problems.

      I use mpd to play music and can control it remotely in a couple of ways:
      From my PC using a small Java-app called Jamming, from my Palm using NeoMPC
      (installed on my public internet server) and from my Mobile using MpdRemote
      (also installed on my external server).


      My USB sound device is a C-Media that I bought brandnew via eBay for 0.99
      EUR + S&H (actually 10 EUR as it's shipped from Hongkong).
      If someone wants to buy the same USB device, it's listed dotzens of times in
      eBay for less than $1:
      http://cgi.ebay.com/USB-2-channels-Audio-Controller-Adatper-Lead-Tide_W0QQit
      emZ6831220367QQcategoryZ74957QQssPageNameZWDVWQQrdZ1QQcmdZViewItem
      http://cgi.ebay.com/USB-2-channel-Audio-Controller-Adatper-Lead-Tide-AD63_W0
      QQitemZ5842537684QQcategoryZ41993QQssPageNameZWDVWQQrdZ1QQcmdZViewItem
      http://cgi.ebay.com/Brand-New-USB-5-1-3D-External-USB-Sound-Card-s07_W0QQite
      mZ6831652152QQcategoryZ3701QQrdZ1QQcmdZViewItem
      http://cgi.ebay.com/PC-V5-1ch-USB-KEY-SIZE-AUDIO-SOUND-CARD-MIC-ADAPTOR_W0QQ
      itemZ6831205131QQcategoryZ3701QQrdZ1QQcmdZViewItem

      Regards
      Rainer

      -----Original Message-----
      From: LinkStation_General@yahoogroups.com
      [mailto:LinkStation_General@yahoogroups.com] On Behalf Of James Stewart
      Sent: Dienstag, 13. Dezember 2005 23:01
      To: LinkStation_General@yahoogroups.com
      Subject: [LinkStation_General] Re: usb sound

      Exactly what kernel do you have?

      Do a "uname -v" at a shell prompt. I get:

      #990 2004 5 21 13:39:00 JST

      I was helping someone get USB sound working who had a #997 kernel and it
      wouldn't work. I had him grab a copy of my #990 kernel and everything
      worked.

      My image of /dev/fl1 (where the kernel is) is at:

      ftp://wartstew.homelinux.net/fl1-image.gz

      (My ftp server loads on demand from inetd so you might have to hit "refresh"
      once if your browser times out.)

      I have USB sound working using a cheap/surplus little C-Media based dongle
      that I payed $15 for some time ago, and the thing works great and sounds
      real good too (real clean, no noise & good fidelity) using just the old OSS
      sound driver (soundcore.o) and the "audio.o" usb driver module.


      --- In LinkStation_General@yahoogroups.com, "Bob Jageman"
      <rcalinjageman@y...> wrote:
      >
      > I've got a debianized linkstation (hdhlan) with samba, vnc, etc.
      >
      > My dream, however, is to get usb audio out my linkstation. I've read
      > through this forum, that yahoo group, and some of the kuro box
      forums.
      > It seems that several users have succeeded with usb audio, but the
      > details have been sketchy, and I haven't been able to get things to
      > work yet.
      >
      > I have a Creative SB Live External 24 bit. I would happily purchase
      a
      > different usb sound to make this work.
      >
      > Upon plugin, I see the device in USBviewer from a vnc connection. I
      get:
      > SB Live! 24-bit External
      > Manufacturer: Creative Technology
      > Speed: 12Mb/s (full)
      > USB Version: 1.10
      > Device Class: 00(>ifc )
      > Device Subclass: 00
      > Device Protocol: 00
      > Maximum Default Endpoint Size: 8
      > Number of Configurations: 1
      > Vendor Id: 041e
      > Product Id: 3040
      > Revision Number: 1.00
      >
      > Following this thread
      > (http://linkstationwiki.org/forum/index.php?
      action=vthread&forum=2&topic=244&page=0#2)
      > I have tried to get the OSS driver to work for this card. From what
      > I've read, OSS will support this sound card, though not to record.
      >
      > I started by doing the manual 'modprobe audio'. It does load the
      > module, but it doesn't seem to fully set up the device, as at the
      end
      > of dmesg I get:
      > and at the end of dmesg is:
      > usb.c: registered new driver hub
      > usb.c: registered new driver audio
      > audio.c: v1.0.0:USB Audio Class driver
      >
      > instead of
      > > usb.c: registered new driver audio
      > > usbaudio: device 2 audiocontrol interface 0 has 1 input and 1
      output
      > AudioStreaming interfaces
      > reported here:
      > (http://linkstationwiki.org/forum/index.php?
      action=vthread&forum=2&topic=244&page=0#2)
      >
      > to be honest, though, I'm not entirely sure how to test the setup.
      > When connected via VNC, I've installed XMMS. For outputs, it has OSS
      > driver, but it has merely 'default' device, and won't play. It seems
      > maybe I should configure this to point to the sound blaster, but I'm
      > too novice to know where to point it.
      >
      > Also, there seems to have been an issue with different module
      versions
      > (http://linkstationwiki.org/forum/index.php?
      action=vthread&forum=3&topic=287&page=0#1),
      > which seems to be resolved, but I don't understand what action was
      > actually taken (how to check which module versions I have loaded,
      how
      > to install a newer version, etc).
      >
      > I've also tried doing the ALSA compile, but the threads on that (in
      > kurobox forum and elsewhere) are even more cryptic and daunting, and
      > I've never been able to get them to compile.
      >
      > Any help would be appreciated.
      >
      > Thanks,
      >
      > Bob
      >
      > btw, here is my lsmod as well:
      > Module Size Used by Not tainted
      > audio 42016 0 (unused)
      > usbcore 66604 0 [audio]
      > soundcore 4728 1 [audio]
      >






      ------------------------ Yahoo! Groups Sponsor --------------------~--> Fair
      play? Video games influencing politics. Click and talk back!
      http://us.click.yahoo.com/2jUsvC/tzNLAA/TtwFAA/O7EolB/TM
      --------------------------------------------------------------------~->


      Yahoo! Groups Links
    Your message has been successfully submitted and would be delivered to recipients shortly.