Loading ...
Sorry, an error occurred while loading the content.

Re: Setting up LinkStation FTP Access

Expand Messages
  • prezet2005
    You ll be able to ftp to the box from a computer on the network with the the internal ip address 192.186...etc, but to test the external IP you ll need to use
    Message 1 of 7 , Nov 22, 2005
    View Source
    • 0 Attachment
      You'll be able to ftp to the box from a computer on the network with the the internal ip
      address 192.186...etc, but to test the external IP you'll need to use a connection outside of
      your local lan.

      If you install openlink and tools, you will be able to hack around a few scripts to allow you
      to make additional ftp configuration settings. But this cannot be done on a stock
      machine.


      --- In LinkStation_General@yahoogroups.com, "wedes7711" <chris@a...> wrote:
      >
      > I turned the FTP client (CuteFTP) to PORT mode and still get the same
      > result as before:
      >
      > STATUS:> Getting listing ""...
      > STATUS:> Connecting to FTP server 72.x.x.x:21 (ip = 72.x.x.x)...
      > STATUS:> Socket connected. Waiting for welcome message...
      > ERROR:> Control connection closed.
      >
      > My assumption in reading your note was the the port forwarding on the
      > router was 'correct', and the beyond turning FTP 'on' on the
      > LInkStation, there are no other settings available. Is this true?
      >
      > --- In LinkStation_General@yahoogroups.com, "prezet2005"
      > <powell.lee.imac@g...> wrote:
      > >
      > > From the sounds of things the external client is trying to connect
      > passively to your ftp.
      > > The stock ftp doesn't support passive connections, and hence this is
      > why you're getting
      > > this 'non-connection'
      > >
      > > Passive FTP requires a random port to be allocated by the FTP
      > server. The stock FTP server
      > > included on the LinkStations doesn't specify which port range this
      > port should be taken
      > > from, hence it probably picks a port that is blocked by your firewall.
      > >
      > > I found this to be a very helpful article:
      > > http://www.castaglia.org/proftpd/doc/contrib/ProFTPD-mini-HOWTO-NAT.html
      > >
      > > Try to connect to the FTP server with passive connection turned OFF.
      > >
      > > If you can connect then this is the problem. Let me know how you
      > get on, if this is the
      > > problem I'll guide you through how to edit the proftpd.conf file (as
      > this file is rewritten
      > > everytime the box is booted'.
      > >
      > >
      > > --- In LinkStation_General@yahoogroups.com, "wedes7711" <chris@a...>
      > wrote:
      > > >
      > > > I have the 'starting address' for DHCP set to 192.168.1.100, and
      > the static IP for the
      > > Linkstation set to 192.168.1.3, so I'm thinking I should be OK on
      > this point...
      > > >
      > > >
      > > > --- In LinkStation_General@yahoogroups.com, "gouldyis"
      > <gouldyis@y...> wrote:
      > > > >
      > > > > --- In LinkStation_General@yahoogroups.com, "wedes7711" chris@a...
      > > > > wrote:
      > > > > >
      > > > > > I know that setting up my LinkStation 250 FTP server flor external
      > > > > > access is possible, however I'm having a hair-tearing time trying
      > > > > to
      > > > > > get the external access part working. I've done all the 'normal'
      > > > > things:
      > > > > >
      > > > > > LinkStation:
      > > > > > 1) activated annon FTP access to a read/write unrestricted folder
      > > > > > 2) assigned a static IP (192.168.1.3)to the LinkStation
      > > > > > 3) entered the default gateway address of the router (192.168.1.1)
      > > > > > into the IP setup
      > > > > >
      > > > > > Linksys WRT54GX router:
      > > > > > 1) Forward port 21 to the LinkStation IP
      > > > > > 2) Forwarded additional TCP ports (5000-5124) to the LS IP
      > > > > >
      > > > > > Results:
      > > > > > 1) From inside my network, FTP access works fine
      > > > > > 2) Using the external WAN IP, accessing FTP from outside tries
      > very
      > > > > > hard to work with the following results in the FTP client:
      > > > > > "Connecting to 72.140.xxx.157"
      > > > > > "Connected with 72.140.xxx.157. Waiting for welcome message"
      > > > > > (long pause)
      > > > > > "Disconnected from server. Unable to connect."
      > > > > >
      > > > > > I know that others have actually gotten this working, so does
      > > > > anyone
      > > > > > have any ideas as to what I'm missing here??
      > > > >
      > > > > I could never test or contact mine from 'inside' my network. You
      > > > > have to try to contact it from outside the network, and are you
      > sure
      > > > > that your static IP is not within the range set for DHCP by your
      > > > > router?
      > > > > >
      > > > >
      > > >
      > >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.