Loading ...
Sorry, an error occurred while loading the content.

Re: [LinkStation_General] Re: dumb question

Expand Messages
  • Matt Grimes
    Hey cool man, thanks for the help. Basically the only reason i havent installed openlink yet is that i have a Hdhg-300. I have been reading on the
    Message 1 of 3 , Nov 19, 2005
    • 0 Attachment
      Hey cool man, thanks for the help. Basically the only reason i havent installed openlink yet is that i have  a Hdhg-300. I have been reading on the linkstationwiki that right now there is a problem with the firmware updater and that even trying to update from firmware 1.34 to 1.45 of the original firmware will brick the drive. Linkstation has even taken all the firmwares off their site for the these drives. One guy on the wiki said he as been in contact with linkstation and that they are aware of the problem. They said they should have it fixed in a week or so. Im going to wait until they at least have the updater problem fixed before i try installing openlink.

      Ian White <iandavidwhite@...> wrote:
      > Message: 11       
      >    Date: Sat, 19 Nov 2005 06:18:30 -0000
      >    From: "johnslayer1981" <johnslayer1981@...>
      > Subject: dumb question
      >
      > ok this is a dumb question but................
      > I finally got my linkstation. Im waiting on puttin in openlink till
      > they get the bricking problem sorted. Anyway i want to have some
      > folders that some users can have only read access to and that some
      > users can have full write access. Same folder just diff permissions
      > for each user. Actually i want to be the only person who can write.
      > Does that mean i have to go to the web interface every time and enable
      > write when i want to write something? It would seem logical
      > that "root" login would have unlimited read/write permissions. When i
      > go to my network places though if i have enabled access protection for
      > some reason i cant log in with "root" as user and my admin pass that i
      > set up. Any ideas?

      Hi John,

      It is not such a dumb question

      I have exactly this set up

      I used the web interface to set up the users, groups and shares

      But then I logged-in to fix/sort out the nonsense file permissions
      that the web interface had applied to the shares
      using "chmod" and "chown" etc.
      so that the permissions worked correctly

      Unfortunately this implies that you are able to telnet/SSH in as "root"
      which probably means that you can only do it *after* installing "openlink"
      (or manually following the hacking-in process which implies f/w 1.45.13 or earlier
      and a PPC-based LinkStation)

      The shares are never available to "root",
      only to the users that you set up on the web interface
      (however there is nothing to stop you setting up a user in the web interface
      that you subsequently modify to have user ID 0, but this again requires
      telnet/SSH access which implies openlink

      Cheers
      Ian W.

      P.S. I bricked my HG400 initially
      but with help from the LinkStation wiki
      I successfully installed a version of openlink


      Yahoo! FareChase - Search multiple travel sites in one click.
    Your message has been successfully submitted and would be delivered to recipients shortly.