Loading ...
Sorry, an error occurred while loading the content.

Re: Help with Slimserver 6 Insatallation LS1 Linux newbee

Expand Messages
  • enjoygo
    John, What do you mean by 5.8.5 perl release ? Do you mean OpenLink-5.1b in obsolete_builds directory? Your help is appreciated. Ken
    Message 1 of 8 , Nov 10, 2005
    • 0 Attachment
      John,

      What do you mean by "5.8.5 perl release"? Do you mean OpenLink-5.1b
      in obsolete_builds directory? Your help is appreciated.

      Ken

      --- In LinkStation_General@yahoogroups.com, "john_p_daniels"
      <john_p_daniels@y...> wrote:
      >
      > --- In LinkStation_General@yahoogroups.com, "john_p_daniels"
      > <john_p_daniels@y...> wrote:
      > >
      > > --- In LinkStation_General@yahoogroups.com, "Marc D. Field"
      > > <yahoo@f...> wrote:
      > > >
      > > > On 09/11/2005 05:39 AM, jwepugh wrote:
      > > > > The following modules failed to load DBD: :SQLite XML: :Parser
      > > HTML:
      > > > > Parser Compress: :Zlib
      > > > >
      > > >
      > > > Hi Eddie,
      > > >
      > > > The release version of SlimServer does not yet have the binaries
      > > of
      > > > those modules for the MIPS LinkStation. If you delete your
      > > SlimServer
      > > > installation directory (rm -rf /mnt/slimserver) and then install
      > > the
      > > > latest nightly SlimServer 6.2 build
      > > > (http://slimdevices.com/downloads/nightly/latest/6.2/), things
      > > should
      > > > work for you.
      > > >
      > > > Marc
      > > >
      > > Hi. I have the exact same problem. I even tried the latest and
      > > greatest nightly version:
      > >
      > > http://slimdevices.com/downloads/nightly/latest/6.5/
      > >
      > > I try and go thru the manual install of the packages as suggested,
      > > and only encounter tons of problem as I only have gcc and not cc!
      > > Lots of cryptic error messages when i have the Makefile to
      > > temporarily get around the problem.
      > >
      > > ./slimserver.pl --daemon --prefsfile /mnt/slim-
      > data/slimserver.pref -
      > > -cachedir /mnt/slim-data
      > > The following modules failed to load: DBD::SQLite XML::Parser
      > > HTML::Parser Compress::Zlib
      > >
      > > To download and compile them, please run: /mnt/SlimServer_v2005-11-
      > > 08/Bin/build-perl-modules.pl
      > >
      > > Has someone compiled these for a LS1 already, or am I going to
      > have
      > > to go thru this process manually? Thanks!
      > >
      > I thought I would go ahead and answer my own questions, so as to
      > perhaps help someone who might have the same problem! My
      > installation from the Openlink-5.2b obtained from the linkwiki site
      > contained Perl 5.8.7. When I back this off to the 5.8.5 perl release
      > from the same site, I no longer have any install problems w/
      > slimserver (ie. the above errors go away). Go figure. I now have my
      > slimserver running just fine, and its talking with my squeezebox2!
      >
    • john_p_daniels
      ... XML: :Parser ... binaries ... install ... things ... suggested, ... cc! ... run: /mnt/SlimServer_v2005-11- ... site ... release ... my ... squeezebox2! ...
      Message 2 of 8 , Nov 11, 2005
      • 0 Attachment
        > --- In LinkStation_General@yahoogroups.com, "john_p_daniels"
        > <john_p_daniels@y...> wrote:
        > >
        > > --- In LinkStation_General@yahoogroups.com, "john_p_daniels"
        > > <john_p_daniels@y...> wrote:
        > > >
        > > > --- In LinkStation_General@yahoogroups.com, "Marc D. Field"
        > > > <yahoo@f...> wrote:
        > > > >
        > > > > On 09/11/2005 05:39 AM, jwepugh wrote:
        > > > > > The following modules failed to load DBD: :SQLite
        XML: :Parser
        > > > HTML:
        > > > > > Parser Compress: :Zlib
        > > > > >
        > > > >
        > > > > Hi Eddie,
        > > > >
        > > > > The release version of SlimServer does not yet have the
        binaries
        > > > of
        > > > > those modules for the MIPS LinkStation. If you delete your
        > > > SlimServer
        > > > > installation directory (rm -rf /mnt/slimserver) and then
        install
        > > > the
        > > > > latest nightly SlimServer 6.2 build
        > > > > (http://slimdevices.com/downloads/nightly/latest/6.2/),
        things
        > > > should
        > > > > work for you.
        > > > >
        > > > > Marc
        > > > >
        > > > Hi. I have the exact same problem. I even tried the latest and
        > > > greatest nightly version:
        > > >
        > > > http://slimdevices.com/downloads/nightly/latest/6.5/
        > > >
        > > > I try and go thru the manual install of the packages as
        suggested,
        > > > and only encounter tons of problem as I only have gcc and not
        cc!
        > > > Lots of cryptic error messages when i have the Makefile to
        > > > temporarily get around the problem.
        > > >
        > > > ./slimserver.pl --daemon --prefsfile /mnt/slim-
        > > data/slimserver.pref -
        > > > -cachedir /mnt/slim-data
        > > > The following modules failed to load: DBD::SQLite XML::Parser
        > > > HTML::Parser Compress::Zlib
        > > >
        > > > To download and compile them, please
        run: /mnt/SlimServer_v2005-11-
        > > > 08/Bin/build-perl-modules.pl
        > > >
        > > > Has someone compiled these for a LS1 already, or am I going to
        > > have
        > > > to go thru this process manually? Thanks!
        > > >
        > > I thought I would go ahead and answer my own questions, so as to
        > > perhaps help someone who might have the same problem! My
        > > installation from the Openlink-5.2b obtained from the linkwiki
        site
        > > contained Perl 5.8.7. When I back this off to the 5.8.5 perl
        release
        > > from the same site, I no longer have any install problems w/
        > > slimserver (ie. the above errors go away). Go figure. I now have
        my
        > > slimserver running just fine, and its talking with my
        squeezebox2!
        > >
        >
        --- In LinkStation_General@yahoogroups.com, "enjoygo" <enjoygo@y...>
        wrote:
        >
        > John,
        >
        > What do you mean by "5.8.5 perl release"? Do you mean OpenLink-
        5.1b
        > in obsolete_builds directory? Your help is appreciated.
        >
        > Ken
        >
        Sorry, I should have been more clear. I initially only knew of the
        linkstationwiki site, so all my early installs were exclusively
        utilizing downloads from that site:

        http://linkstationwiki.org/Projects/OpenLink

        I updated my LS1 with the ppc-openlink-0.52b firmware, which
        included Perl 5.8.7. When attempting to install the slimvserver
        software, i encountered lots of problems like highlighted above. I
        read "somewhere" (but I forget where!!), that people were having
        problems w/ Perl 5.8.7, and no problems w/ Perl 5.8.5 (incidently,
        slimserver utilizes perl). So, i went to the excellent fieldnetworks
        site which not only has kick-a** install instructions for getting
        slimserver up and runing, but he also hosted perl 5.8.5:

        http://fieldnetworks.com/slim/perl-5.8.5-linkstation.tar.gz

        I moved perl 5.8.7 out of the way, then installed this version of
        5.8.5. At this point, I did a fresh install of the latest slimserver
        software

        http://slimdevices.com/downloads/nightly/latest/6.2.1

        I was good to go after that. So, the bottom line is that the
        slimserver software has some sort of compatibility problem with
        either Perl 5.8.7 (does not support it?), or the version that came
        with the ppc-openlink-0.52b has issues. I am not experienced enough
        to debug it, so am just happy that I have a workaround to get my
        slimserver running.
      • Kenneth Cho
        John, Thank you so much for your help. Over the weekend, I was able to host the slimserver on the Linkstation. Now I have playlists, internet radio
        Message 3 of 8 , Nov 14, 2005
        • 0 Attachment
          John,
           
          Thank you so much for your help.  Over the weekend, I was able to host the slimserver on the Linkstation.   Now I have playlists, internet radio (including LastFM), RSS News Tickers, and local weather on the Squeezebox!  Thanks again for making all this possible.
           
          Best Regards,
           
          Ken

          john_p_daniels <john_p_daniels@...> wrote:
          > --- In LinkStation_General@yahoogroups.com, "john_p_daniels"
          > <john_p_daniels@y...> wrote:
          > >
          > > --- In LinkStation_General@yahoogroups.com, "john_p_daniels"
          > > <john_p_daniels@y...> wrote:
          > > >
          > > > --- In LinkStation_General@yahoogroups.com, "Marc D. Field"
          > > > <yahoo@f...> wrote:
          > > > >
          > > > > On 09/11/2005 05:39 AM, jwepugh wrote:
          > > > > > The following modules failed to load DBD: :SQLite
          XML: :Parser
          > > > HTML:
          > > > > > Parser Compress: :Zlib
          > > > > >
          > > > >
          > > > > Hi Eddie,
          > > > >
          > > > > The release version of SlimServer does not yet have the
          binaries
          > > > of
          > > > > those modules for the MIPS LinkStation.  If you delete your
          > > > SlimServer
          > > > > installation directory (rm -rf /mnt/slimserver) and then
          install
          > > > the
          > > > > latest nightly SlimServer 6.2 build
          > > > > (http://slimdevices.com/downloads/nightly/latest/6.2/),
          things
          > > > should
          > > > > work for you.
          > > > >
          > > > > Marc
          > > > >
          > > > Hi. I have the exact same problem. I even tried the latest and
          > > > greatest nightly version:
          > > >
          > > > http://slimdevices.com/downloads/nightly/latest/6.5/
          > > >
          > > > I try and go thru the manual install of the packages as
          suggested,
          > > > and only encounter tons of problem as I only have gcc and not
          cc!
          > > > Lots of cryptic error messages when i have the Makefile to
          > > > temporarily get around the problem.
          > > >
          > > > ./slimserver.pl --daemon --prefsfile /mnt/slim-
          > > data/slimserver.pref -
          > > > -cachedir /mnt/slim-data
          > > > The following modules failed to load: DBD::SQLite XML::Parser
          > > > HTML::Parser Compress::Zlib
          > > >
          > > > To download and compile them, please
          run: /mnt/SlimServer_v2005-11-
          > > > 08/Bin/build-perl-modules.pl
          > > >
          > > > Has someone compiled these for a LS1 already, or am I going to
          > > have
          > > > to go thru this process manually? Thanks!
          > > >
          > > I thought I would go ahead and answer my own questions, so as to
          > > perhaps help someone who might have the same problem! My
          > > installation from the Openlink-5.2b obtained from the linkwiki
          site
          > > contained Perl 5.8.7. When I back this off to the 5.8.5 perl
          release
          > > from the same site, I no longer have any install problems w/
          > > slimserver (ie. the above errors go away). Go figure. I now have
          my
          > > slimserver running just fine, and its talking with my
          squeezebox2!
          > >
          >
          --- In LinkStation_General@yahoogroups.com, "enjoygo" <enjoygo@y...>
          wrote:
          >
          > John,
          >
          > What do you mean by "5.8.5 perl release"?  Do you mean OpenLink-
          5.1b
          > in obsolete_builds directory?  Your help is appreciated.
          >
          > Ken
          >
          Sorry, I should have been more clear. I initially only knew of the
          linkstationwiki site, so all my early installs were exclusively
          utilizing downloads from that site:

          http://linkstationwiki.org/Projects/OpenLink

          I updated my LS1 with the ppc-openlink-0.52b firmware, which
          included Perl 5.8.7. When attempting to install the slimvserver
          software, i encountered lots of problems like highlighted above. I
          read "somewhere" (but I forget where!!), that people were having
          problems w/ Perl 5.8.7, and no problems w/ Perl 5.8.5 (incidently,
          slimserver utilizes perl). So, i went to the excellent fieldnetworks
          site which not only has kick-a** install instructions for getting
          slimserver up and runing, but he also hosted perl 5.8.5:

          http://fieldnetworks.com/slim/perl-5.8.5-linkstation.tar.gz

          I moved perl 5.8.7 out of the way, then installed this version of
          5.8.5. At this point, I did a fresh install of the latest slimserver
          software

          http://slimdevices.com/downloads/nightly/latest/6.2.1

          I was good to go after that. So, the bottom line is that the
          slimserver software has some sort of compatibility problem with
          either Perl 5.8.7 (does not support it?), or the version that came
          with the ppc-openlink-0.52b has issues. I am not experienced enough
          to debug it, so am just happy that I have a workaround to get my
          slimserver running.




        Your message has been successfully submitted and would be delivered to recipients shortly.