Loading ...
Sorry, an error occurred while loading the content.

[Kuro box HG] jochang's loader broke everything

Expand Messages
  • magictom86
    Hello everybody I bought a Kuro box HG a few days ago. Today I have tried to update its kernel (to have PPP and Wireless support). I followed this guide:
    Message 1 of 3 , Oct 30, 2005
    • 0 Attachment
      Hello everybody

      I bought a Kuro box HG a few days ago. Today I have tried to update
      its kernel (to have PPP and Wireless support).
      I followed this guide:
      http://f1.grp.yahoofs.com/v1/cFBlQ_KG6g3S1Ts49SIx1R2diGhaKtN8Qmspa8jk_CgeLKBXGEU9aiEhdX4S5TapOgodv3MM5j4l-AVV4Tw1rgd25bfD_xsUBA/kernel%20build%20thread%20from%20Revogear.rtf
      but without creatint firmimg.bin because I didn't want to overwrite
      the boot flash but rather to use jochang's loader.

      The kernel compilation went fine, everything was ok, so I loaded the
      new kernel:
      insmod loader.o kernel=/root/new_kernel/vmlinux
      It stopped responding for about a minute, then I could telnet it
      again. uname -a indicated that it was running my new kernel. But it
      halted 3-4 minutes later with the Diag LED blinking 5 times: problem
      in the flash memory...

      I managed to reboot in EM mode and to telnet the box. But instead of
      booting from flash (with data in /dev/ram0), it boots from the hard
      disk with the old kernel:

      root@KURO-BOX:~# df
      Filesystem 1k-blocks Used Available Use% Mounted on
      /dev/hda1 7566400 729036 6453012 11% /
      /dev/hda3 31300924 1744260 27966632 6% /mnt
      root@KURO-BOX:~# uname -a
      Linux KURO-BOX 2.4.17_mvl21 #24 2004ǯ 10·î 19Æü ²ÐÍËÆü 17:17:03 JST
      ppc unknown

      It simply seems that the flash memory has been erased: /dev/fl0 and
      /dev/fl3 are full of ÿÿÿÿÿÿÿÿÿÿÿÿ, I don't know whether the 2 other
      ones are good or not.

      I think I will have to re-write flash with the right data.
      Could someone with a Kuro Box HG dump his /dev/fl* (cat /dev/flx >
      flashx) and mail them at thomas.jost (at) gmail.com please? I don't
      want my brand new Kuro box to turn into a brick :'-(
    • magictom86
      ... Oops, I m a newbie. It s not EM mode, it s just that christmas tree mode (pressing the red button during boot,
      Message 2 of 3 , Oct 30, 2005
      • 0 Attachment
        --- In LinkStation_General@yahoogroups.com, "magictom86"
        <magic_tom86@h...> wrote:
        > I managed to reboot in EM mode and to telnet the box. But instead of
        > booting from flash (with data in /dev/ram0), it boots from the hard
        > disk with the old kernel:

        Oops, I'm a newbie. It's not EM mode, it's just that "christmas tree"
        mode (pressing the red button during boot,
        http://www.kurobox.com/online/tiki-view_faq.php?faqId=1#q5).
        But this doesn't change my problem: can't boot without pressing the
        red button, no more flash, etc. And can't boot in EM mode: write_ng is
        ok, but it does not reboot, I have to press the power button. And then
        it does not switch to EM mode. *Sigh*
      • magictom86
        ... Solved it. Unplugged the box before going to bed, and this morning it worked fine. No problem with the flash memory, everything is OK :-) Now I ll try to
        Message 3 of 3 , Oct 31, 2005
        • 0 Attachment
          --- In LinkStation_General@yahoogroups.com, "magictom86"
          <magic_tom86@h...> wrote:
          >
          > Oops, I'm a newbie.
          >

          Solved it. Unplugged the box before going to bed, and this morning it
          worked fine. No problem with the flash memory, everything is OK :-)
          Now I'll try to install a 2.4.20 kernel ;o)
        Your message has been successfully submitted and would be delivered to recipients shortly.