Loading ...
Sorry, an error occurred while loading the content.

Re: Mapping my Linkstation in Windows XP as a Network Drive

Expand Messages
  • lalunas10
    ... [...] ... So it doesn t run. ... Edit /usr/local/etc/ssh/sshd_config, change #Port 22 (or so) to Port 22222 ; then restart ssh and see what happens. ...
    Message 1 of 14 , Oct 25, 2005
    • 0 Attachment
      --- In LinkStation_General@yahoogroups.com, "john_p_daniels" <john_p_daniels@y...>
      wrote:
      >
      > --- In LinkStation_General@yahoogroups.com, "lalunas10" >
      > > If this doesn't work, how about disabling privilege separation for
      > now?
      > >
      > > UsePrivilegeSeparation no
      [...]
      > > DON'T DISABLE DROPBEAR FOR NOW, you might lock yourself out. Run
      > openssh on a
      > > different port instead (i.e., not port 22).
      > >
      > Thanks again for responding! I went ahead and tried updating
      > my /etc/passwd and associated /home/sshd stuff like you suggested,
      > but with still no success. :-( Things "work" the exact same way. I
      > enter '/etc/init.d/ssh start', and I get no error messages (ie. the
      > privelidge separation error went away). However, no sshd processes
      > are created. Is there somewhere else I need to look for a log file?
      > I see from the /etc/init.d/sshd file that a pidfile
      > called /var/run/sshd.pid should be created. Well it isn't. Also,

      So it doesn't run.

      > what should I do to create this alternate port.

      Edit /usr/local/etc/ssh/sshd_config, change "#Port 22" (or so) to "Port 22222"; then
      restart ssh and see what happens.

      > I have port 22 being
      > used, but perhaps this is dropbear using this?

      That's what I've been trying to tell you :)

      > I am getting into my
      > linkstation via putty, via port 22 (I am guessing, since I can't get
      > in from outside when i turn port forwarding off on my router).

      Run openssh on the command line (manually) to see what's going on:

      sshd -f /usr/local/etc/ssh/sshd_config

      or even

      sshd -d -f /usr/local/etc/ssh/sshd_config

      -Andre
    • john_p_daniels
      ... ... for ... Run ... suggested, ... I ... the ... processes ... file? ... to Port 22222 ; then ... get ... Okay, some success! The
      Message 2 of 14 , Oct 25, 2005
      • 0 Attachment
        --- In LinkStation_General@yahoogroups.com, "lalunas10"
        <lalunas10@y...> wrote:
        >
        > --- In LinkStation_General@yahoogroups.com, "john_p_daniels"
        <john_p_daniels@y...>
        > wrote:
        > >
        > > --- In LinkStation_General@yahoogroups.com, "lalunas10" >
        > > > If this doesn't work, how about disabling privilege separation
        for
        > > now?
        > > >
        > > > UsePrivilegeSeparation no
        > [...]
        > > > DON'T DISABLE DROPBEAR FOR NOW, you might lock yourself out.
        Run
        > > openssh on a
        > > > different port instead (i.e., not port 22).
        > > >
        > > Thanks again for responding! I went ahead and tried updating
        > > my /etc/passwd and associated /home/sshd stuff like you
        suggested,
        > > but with still no success. :-( Things "work" the exact same way.
        I
        > > enter '/etc/init.d/ssh start', and I get no error messages (ie.
        the
        > > privelidge separation error went away). However, no sshd
        processes
        > > are created. Is there somewhere else I need to look for a log
        file?
        > > I see from the /etc/init.d/sshd file that a pidfile
        > > called /var/run/sshd.pid should be created. Well it isn't. Also,
        >
        > So it doesn't run.
        >
        > > what should I do to create this alternate port.
        >
        > Edit /usr/local/etc/ssh/sshd_config, change "#Port 22" (or so)
        to "Port 22222"; then
        > restart ssh and see what happens.
        >
        > > I have port 22 being
        > > used, but perhaps this is dropbear using this?
        >
        > That's what I've been trying to tell you :)
        >
        > > I am getting into my
        > > linkstation via putty, via port 22 (I am guessing, since I can't
        get
        > > in from outside when i turn port forwarding off on my router).
        >
        > Run openssh on the command line (manually) to see what's going on:
        >
        > sshd -f /usr/local/etc/ssh/sshd_config
        >
        > or even
        >
        > sshd -d -f /usr/local/etc/ssh/sshd_config
        >
        > -Andre
        >
        Okay, some success! The last command above was very helpful. The -d
        option was a debug mode (but you knew that! ;-)), so it showed what
        was going on. It errored saying that directory /var/empty did not
        exist. So, I created this manually, then tried the command again.
        This time it worked! I did change that port to 22222, then did port
        forwarding on my router as well. I then updated the /etc/init.d/ssh
        startup script by forcing the creation of the /var/empty directory.
        I killed the sshd process, then did a reboot. The sshd process was
        started this time (!!), but I did not see the /var/run/sshd.pid file
        that should have been created. Any ideas? Is this important? I was
        able to verify that sftp now worked! Okay, now my question is when I
        am outside of my home network, and want to get in, what is the
        significance of this new Port 22222? I set up a forward on my router
        from this port to the ip address of my buffalo. However, when I turn
        off port 22 (what dropbear was using, I imagine), I cannot get in
        via sftp anymore. It errors out, as it expects Port 22. Is there
        something I need to do to tell sftp to use this port? Or do I now
        disable dropbear and use port 22 for that? Thanks again, for all
        your help for this newbie! :-)
      • lalunas10
        ... Well, I told you ;) ... Way to go, John! ... It s not important, IMHO. ... It s an unprivileged (user assigned) port, so you can run two different services
        Message 3 of 14 , Oct 26, 2005
        • 0 Attachment
          --- In LinkStation_General@yahoogroups.com, "john_p_daniels" <john_p_daniels@y...>
          wrote:

          > > sshd -d -f /usr/local/etc/ssh/sshd_config

          > Okay, some success! The last command above was very helpful. The -d
          > option was a debug mode (but you knew that! ;-)), so it showed what
          > was going on. It errored saying that directory /var/empty did not
          > exist.

          Well, I told you ;)

          > So, I created this manually, then tried the command again.
          > This time it worked! I did change that port to 22222, then did port
          > forwarding on my router as well. I then updated the /etc/init.d/ssh
          > startup script by forcing the creation of the /var/empty directory.

          Way to go, John!

          > I killed the sshd process, then did a reboot. The sshd process was
          > started this time (!!), but I did not see the /var/run/sshd.pid file
          > that should have been created. Any ideas? Is this important?

          It's not important, IMHO.

          > I was
          > able to verify that sftp now worked! Okay, now my question is when I
          > am outside of my home network, and want to get in, what is the
          > significance of this new Port 22222?

          It's an unprivileged (user assigned) port, so you can run two different services of the same
          kind at at time. SSH's standard port is 22. Such things are specified in /etc/services.

          > I set up a forward on my router
          > from this port to the ip address of my buffalo. However, when I turn
          > off port 22 (what dropbear was using, I imagine), I cannot get in
          > via sftp anymore. It errors out, as it expects Port 22.

          Nope. I bet dropbear isn't compiled with SSH support, you're experiencing some kind of
          fallback mechanism to SCP (in WinSCP, you need to change the defaults to use SFTP at all).
          You need to open/forward port 115 on your router as well, else your're problably using
          dropbear scp on port 22 -- if it's running.

          > Is there
          > something I need to do to tell sftp to use this port? Or do I now
          > disable dropbear and use port 22 for that? Thanks again, for all
          > your help for this newbie! :-)

          I guess it's clearer now. You could choose to use port 22 in sshd_config and 22222
          (actually, anything above 1024) for dropbear, or disable dropbear altogether. WARNING,
          make sure you don't lock yourself out. Believe me, I know what I'm talking about ;(

          Take care, glad you made it,

          -Andre
        • john_p_daniels
          ... Buffalo Share ... to ... router s port ... netowork into ... am ... Does ... back as ... sshd_config (add a line ... restart your ssh that s ... to do
          Message 4 of 14 , Oct 30, 2005
          • 0 Attachment
            > >
            > > Hi. I am a newbie to this all. I am trying to mount my
            Buffalo "Share"
            > > folder to a windows xp explorer drive-letter. I use gotdns.com
            to
            > > forward my cable-modem's ip address, then use my linksys
            router's port
            > > forwarding to send stuff to the local ip address of my buffalo
            > > linkstation I. I am able to scp & ssh from outside of my
            netowork into
            > > my buffalo (via port 22). So far have not gotten sftp to work. I
            am
            > > using the openlink & openssh from the linkstationwiki folks.
            Does
            > > anybody have any suggestions how I can do this? I have tried
            > > \\IP_ADDRESS\share, entered my login & password, but it comes
            back as
            > > failed.
            >
            > sftp is an ssh subsystem on port 115, you can enable it in your
            sshd_config (add a line
            > "Subsystem sftp /usr/libexec/sftp-server" w/o the quotes, then
            restart your ssh that's
            > hopefully compiled with sftp support). It has absolutely nothing
            to do with Windows shares
            > and "\\IP_ADDRESS\share" syntax, but you can use it with GUI
            like the excellent WinSCP/
            > Putty combo. WinSCP looks much like WinFTP, if you have ever used
            it.
            >
            > You might connect to Windows shares via an SSH tunnel; the GUIs
            mentioned could do this
            > for you.
            >
            > Windows shares themselves dwell on the NetBIOS ports, roughly
            speaking, 135, 137-179,
            > 445 (see <http://ntsecurity.nu/papers/port445/> for details).
            Drive letters can be
            > assigned with "net use" on the Windows system (see
            <http://www.microsoft.com/
            > resources/documentation/windows/xp/all/proddocs/en-
            us/net_use.mspx>).
            >
            > -Andre
            >
            Hi Adre! Thanks again for all the help getting sftp/scp/ssh working
            via openssh on port 22 of my linstation 250! I still have dropbear
            working on that port 22222, and ssh/sftp on port 22. Now I am going
            back to my original question! I was looking at this winscp program,
            and it seems pretty cool. However, while at work (or on the road),
            what I would like to do is have access (read/write/modify) to a
            files on my linkstation at home. For instance, could I play MP3s
            streamed from my linkstation while on the road? Or can I open my
            quicken financial database on the road? I don't want to copy the file
            (s) over, modify them, then copy them back (for my quicken example),
            I'd like to work w/ them interactively. I thought of using windows
            share folders for this, but I am having problems like mentioned
            above. I also poked around w/ the winscp, and don't see such a
            capability. Would you (or anyone else) have any suggestions? I first
            want to look at doing it non-securly (ie. no VPN), then if I get
            that working, look at a more secure option. I use gotdns.org to map
            my ip address to my local router, then use port forwarding on my
            router to get to the buffalo. This is how I have been doing
            ssh/sftp. But when I try to map a network drive, I enter:
            \\URL.com\share ('share' is the name that I use on my buffalo, the
            default share directory) and my login name/password, but it times
            out. Any suggestions??!! Thanks!!
          • lalunas10
            ... wrote: [...] ... Ouch, typo: not 137-179,445 but 137-139,445 ... [...] ... You need stremaing software for that, like mt-daapd. Or mount your shares
            Message 5 of 14 , Oct 30, 2005
            • 0 Attachment
              --- In LinkStation_General@yahoogroups.com, "john_p_daniels" <john_p_daniels@y...>
              wrote:

              [...]
              > > Windows shares themselves dwell on the NetBIOS ports, roughly
              > speaking, 135, 137-179, 445 (see <http://ntsecurity.nu/papers/port445/> for details).

              Ouch, typo: not 137-179,445 but 137-139,445

              > Drive letters can be
              > > assigned with "net use" on the Windows system (see
              > <http://www.microsoft.com/
              > > resources/documentation/windows/xp/all/proddocs/en-
              > us/net_use.mspx>).
              [...]

              > while at work (or on the road),
              > what I would like to do is have access (read/write/modify) to a
              > files on my linkstation at home. For instance, could I play MP3s
              > streamed from my linkstation while on the road?

              You need stremaing software for that, like mt-daapd. Or mount your shares remotely,
              then tell your player to use them as its data source.

              > Or can I open my
              > quicken financial database on the road? I don't want to copy the file
              > (s) over, modify them, then copy them back (for my quicken example),
              > I'd like to work w/ them interactively. I thought of using windows
              > share folders for this, but I am having problems like mentioned
              > above.

              Make sure your shares are password protected. Open the NETBIOS ports mentioned above
              on your router, forward them ("NAT").

              > I also poked around w/ the winscp, and don't see such a
              > capability.

              Correct.

              > Would you (or anyone else) have any suggestions? I first
              > want to look at doing it non-securly (ie. no VPN), then if I get
              > that working, look at a more secure option.

              You could use an SSH tunnel once you got it going. Here's an example from my notes on
              how to create an SSH tunnel for a different service, VNC (port 5901). Add a grain of salt,
              and don't forget NAT of the ports you're using:

              <quote>If you want more security, because you will be working over the public
              internet, you can avoid opening up port 5901 in your firewall and/or
              router, and instead use ssh (port 22). Then from your Solaris system,
              use ssh and specify a tunnel for port 5901 that will then allow your
              Solaris VNC client to use the secure ssh tunnel.

              ssh -f -C -N -L 5901:127.0.0.1:5901 username@...
              for the forwarding host you need to use the internal

              If you use the external IP then SSH tries to talk to your firewall.

              ssh 151.199.60.120 -l username -C -L 5902:192.168.1.100:5901
              </quote>

              > I use gotdns.org to map
              > my ip address to my local router, then use port forwarding on my
              > router to get to the buffalo.

              What ports? See the NETBIOS notes above

              > This is how I have been doing
              > ssh/sftp. But when I try to map a network drive, I enter:
              > \\URL.com\share ('share' is the name that I use on my buffalo, the
              > default share directory) and my login name/password, but it times
              > out. Any suggestions??!! Thanks!!

              You might need to add the workgroup to your \\ thing; but I'm only an occasional
              windows user :) The URLs mentioned earlier should prove helpful.

              -Andre
            Your message has been successfully submitted and would be delivered to recipients shortly.