Loading ...
Sorry, an error occurred while loading the content.

Re: Need help for usb automount with Murakasi

Expand Messages
  • johnnykwc
    Can you post your image here? I cannot get it from kurobox.com. BTW I have the KuroBox HG. Maybe the image is different. Thanks! Johnny ... given ... to make
    Message 1 of 18 , Oct 11, 2005
    • 0 Attachment
      Can you post your image here?
      I cannot get it from kurobox.com.
      BTW I have the KuroBox HG. Maybe the image is different.

      Thanks!

      Johnny

      --- In LinkStation_General@yahoogroups.com, "snatcher93"
      <snatcher93@r...> wrote:
      >
      > On my kurobox, i do have a file called
      > /lib/modules/2.4.17_mvl21/modules.dep ! Do you use your original
      > murasaki script, or the one from my kurobox ? (it may be a bad idea to
      > use my scripts, it should be better to start using the original
      > scripts first !)
      > You should check /var/log/messages file, it may contain usefull
      > informations on what's happening !
      > Good luck,
      >
      > Sylver
      >
      > --- In LinkStation_General@yahoogroups.com, "johnnykwc"
      > <johnnykwc@y...> wrote:
      > > I followed the same instructions to change the path and recompiled.
      > > But when I ran "/etc/init.d/murasaki start" I got an error:
      > >
      > > root@KURO_FS250:/etc/init.d# /etc/init.d/murasaki start
      > > modprobe: Can't open dependencies file
      > > /lib/modules/2.4.17_mvl21/modules.dep (No such file or directory)
      > > mv: cannot stat `/etc/fstab.murasaki_save': No such file or directory
      > >
      > >
      > > Any ideas?
      > >
      > > Thanks!
      > >
      > > Johnny
      > >
      > > --- In LinkStation_General@yahoogroups.com, "snatcher93"
      > > <snatcher93@r...> wrote:
      > > > Well, I was able to make this works well ! For this i had to :
      > > > - correct the startup script error (space missed) => it won't run
      > > > murasaki if you don't correct that !
      > > > - recompile murasaki telling him that the scripts were in
      > > > /etc/murasaki/bin
      > > > - replace the murasaki.usbmap file by the one with the source (very
      > > > important !) and update the .call file to match the device type
      given
      > > > in the .usbmap
      > > >
      > > > Now it's perfect : when i switch on/off my usb drive, it mounts
      > > > it/unmount it and update samba/appletalk sharing ! I just have
      to make
      > > > this works with usb flash storage now ;)
      > > >
      > > > I hope i'll help people that would like to do the same ;)
      > > > If you want to pick up some files, you can get my system image
      here :
      > > > http://www.kurobox.com/forums/viewtopic.php?t=708
      > > >
      > > > C U
      > > >
      > > > Sylver
      > > > --- In LinkStation_General@yahoogroups.com, "downlalaway"
      > > > <downlalaway@y...> wrote:
      > > > > Hi Sylver,
      > > > >
      > > > > I have an LS1 running Debian, and get pretty good connection to
      > a usb
      > > > > hard drive (and most other devices) using usb 2 -as in
      > > > > http://linkstationwiki.org/Articles/DebianUSBDevices . I
      didn't use
      > > > > the LS OS for more than a few days.
      > > > >
      > > > > To be honest never tried to get automount operating since very
      > rarely
      > > > > use it. The debian I have has no /etc/murasaki just a
      usb-storage.o
      > > > > driver under
      > > > > /lib/modules/2.4.17_mvl21-sandpoint/kernel/drivers/usb/storage
      > > > > These modules have been fudged in using a mix of ls and kuro-box
      > > > > drivers, autofs and hotplug installed through apt-get.
      > > > > kuro-box.com still seems to be down -I take it you've looked at
      > > > > linkstationwiki?
      > > > > I know little about the drivers or how to build a set but
      others do
      > > > > and would like to build a better one - as in
      > > > > http://linkstationwiki.org/forum/2_198_0.html
      > > > >
      > > > > I'm also told that hotplug doesn't work well on 2.4.17 (until
      > 2.6) so
      > > > > that's the reason a reboot often makes it work. In which case
      > > > > automounting may be unreliable in practice. Also mine mounts
      > only with
      > > > > mount -t vfat /dev/sda /mnt/mntpoint whereas most would suggest
      > > > > /dev/sda1 would be more suitable. Whether this is a bug or just a
      > > > > strangeness of the modules mix?
      > > > >
      > > > >
      > > > > --- In LinkStation_General@yahoogroups.com, "snatcher93"
      > > > > <snatcher93@r...> wrote:
      > > > > > I installed latest murasaki stable version (0.8.11), but the
      > mount
      > > > > > script is still not running when inserting an usb drive :(
      > > > > > But i was able to make the 'samba/appletalk sharing updating'
      > > enabled
      > > > > > by replacing my '/bin/mkcode' by the one in the linkstation :)
      > > > > >
      > > > > > I think that i'll ask some help from the author of murasaki, if
      > > i got
      > > > > > the clue of the problem, i'll tell you as there is a similar
      > > problem
      > > > > > on the linkstation ;)
      > > > > >
      > > > > > Sylver
      > > > > >
      > > > > > --- In LinkStation_General@yahoogroups.com, "snatcher93"
      > > > > > <snatcher93@r...> wrote:
      > > > > > > Then, this is obviously a bug, as all is present to allow
      > > automount
      > > > > > > (kernel compiled with good options, murasaki catching hotplug
      > > > > > events
      > > > > > > (connect/disconnect), mount script that got some specific
      > > parts to
      > > > > > > handle a call from the startup script or from murasaki
      handler,
      > > > > > dynamic
      > > > > > > samba/netatalk sharing update ...
      > > > > > > But if it's not working on a linkstation, it won't work on my
      > > > > > > kurobox ... So, i have to found what the problem is ;)
      > > > > > >
      > > > > > > Thanks,
      > > > > > >
      > > > > > > Sylver
      > > > > > > --- In LinkStation_General@yahoogroups.com, "Bertram
      Doerfler"
      > > > > > > <ernie73@g...> wrote:
      > > > > > > > As far as I remember, there was a restart necessary when I
      > > > > > plugged in
      > > > > > > a usb
      > > > > > > > drive. No automated mounting. I converted to debian and
      > haven't
      > > > > > tried
      > > > > > > a
      > > > > > > > hotplug since.
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.