Loading ...
Sorry, an error occurred while loading the content.

Help with LS2 HTTP server

Expand Messages
  • Nick Pappas
    Hello all. This is actually a little off topic, but hopefully someone can help. I have a LS2 with the telnet enabled firmware installed, and have installed
    Message 1 of 7 , Oct 6, 2005
    • 0 Attachment
      Hello all.

      This is actually a little off topic, but hopefully someone can help.
      I have a LS2 with the telnet enabled firmware installed, and have
      installed lighttpd and subversion (amoung a few other things).

      I can access my HTTP server via my internal IP address (though port
      81) and, if I have port 81 forwarded on my router, I can type in my
      dyndns.org address and get my page. But, as soon as I attempt to
      access the page from outside my home network it fails. If the port is
      closed, the connection is outright refused. If it is open, the
      connection times out -- which makes me think that the problem is
      actually in the LinkStation.

      Anyone have any suggestions on why my LS2 might be refusing traffic
      coming from outside my internal network and how I can fix it?

      Thanks!

      --
      Whatever you do - don't congratulate yourself too much, or berate
      yourself either.
      Your choices are half chance, and so are everybody else's.
    • yanfrikin
      I would rather say that the problem is in your network. does you LS have a dhcp or static IP? Check your default gateway settings on the LS and router
      Message 2 of 7 , Oct 7, 2005
      • 0 Attachment
        I would rather say that the problem is in your network.
        does you LS have a dhcp or static IP? Check your default gateway
        settings on the LS and router configuration.

        other reason can be that your external IP has been changed in between
        and dyndns record was not yet updated.



        --- In LinkStation_General@yahoogroups.com, Nick Pappas
        <nwpappas@g...> wrote:
        >
        > Hello all.
        >
        > This is actually a little off topic, but hopefully someone can help.
        > I have a LS2 with the telnet enabled firmware installed, and have
        > installed lighttpd and subversion (amoung a few other things).
        >
        > I can access my HTTP server via my internal IP address (though port
        > 81) and, if I have port 81 forwarded on my router, I can type in my
        > dyndns.org address and get my page. But, as soon as I attempt to
        > access the page from outside my home network it fails. If the port is
        > closed, the connection is outright refused. If it is open, the
        > connection times out -- which makes me think that the problem is
        > actually in the LinkStation.
        >
        > Anyone have any suggestions on why my LS2 might be refusing traffic
        > coming from outside my internal network and how I can fix it?
        >
        > Thanks!
        >
        > --
        > Whatever you do - don't congratulate yourself too much, or berate
        > yourself either.
        > Your choices are half chance, and so are everybody else's.
        >
      • James Ronald
        Take a look to see if you have a /etc/hosts.deny and /etc/hosts.allow. If so they may need to be updated. ... From: Nick Pappas To:
        Message 3 of 7 , Oct 7, 2005
        • 0 Attachment
          Take a look to see if you have a /etc/hosts.deny and /etc/hosts.allow. If so
          they may need to be updated.

          ----- Original Message -----
          From: "Nick Pappas" <nwpappas@...>
          To: <LinkStation_General@yahoogroups.com>
          Sent: Friday, October 07, 2005 1:33 AM
          Subject: [LinkStation_General] Help with LS2 HTTP server


          > Hello all.
          >
          > This is actually a little off topic, but hopefully someone can help.
          > I have a LS2 with the telnet enabled firmware installed, and have
          > installed lighttpd and subversion (amoung a few other things).
          >
          > I can access my HTTP server via my internal IP address (though port
          > 81) and, if I have port 81 forwarded on my router, I can type in my
          > dyndns.org address and get my page. But, as soon as I attempt to
          > access the page from outside my home network it fails. If the port is
          > closed, the connection is outright refused. If it is open, the
          > connection times out -- which makes me think that the problem is
          > actually in the LinkStation.
          >
          > Anyone have any suggestions on why my LS2 might be refusing traffic
          > coming from outside my internal network and how I can fix it?
          >
          > Thanks!
          >
          > --
          > Whatever you do - don't congratulate yourself too much, or berate
          > yourself either.
          > Your choices are half chance, and so are everybody else's.
          >
          >
          >
          >
          > Yahoo! Groups Links
          >
          >
          >
          >
          >
          >
          >
        • Nick Pappas
          Thanks. I ll check into those when I get back home this evening. I didn t set up any specific .deny or .allow files, but perhaps the defaults are causing
          Message 4 of 7 , Oct 7, 2005
          • 0 Attachment
            Thanks. I'll check into those when I get back home this evening.

            I didn't set up any specific .deny or .allow files, but perhaps the
            defaults are causing trouble -- or maybe adding a .allow will help.
            Checked the router settings a hundred times though... hit it about a
            hundred more times too. :) I'll double check the gateway setting but
            I'm almost positive it is set, but it has been so long it may have
            mystically removed itself (stranger things have happened).

            --
            Whatever you do - don't congratulate yourself too much, or berate
            yourself either.
            Your choices are half chance, and so are everybody else's.
          • Nick Pappas
            Thanks. I ll check into those when I get back home this evening. I didn t set up any specific .deny or .allow files, but perhaps the defaults are causing
            Message 5 of 7 , Oct 7, 2005
            • 0 Attachment
              Thanks. I'll check into those when I get back home this evening.

              I didn't set up any specific .deny or .allow files, but perhaps the
              defaults are causing trouble -- or maybe adding a .allow will help.
              Checked the router settings a hundred times though... hit it about a
              hundred more times too. :) I'll double check the gateway setting but
              I'm almost positive it is set, but it has been so long it may have
              mystically removed itself (stranger things have happened).
            • lalunas10
              ... You need the following for a web server, accessible from the web, on port 81, AFAIK: - an ISP not blocking the port - a router w/ NAT setup, directing
              Message 6 of 7 , Oct 7, 2005
              • 0 Attachment
                --- In LinkStation_General@yahoogroups.com, Nick Pappas <nwpappas@g...> wrote:

                You need the following for a web server, accessible from the web, on port 81, AFAIK:

                - an ISP not blocking the port
                - a router w/ NAT setup, directing port 81 to your server's IP address
                - the router's firewall must not be blocking port 81/tcp incoming/outgoing
                - the web interface of the router must not be using port 81
                - your /etc/host.{allow,deny} must open enough (or just deleted)
                - the web server serving on port 81
                - probably also add port 81 to /etc/services and reboot

                and last not least, a router firmware w/o bugs. Spent hours and hours w/ a correctly set up
                Zyxel Prestige 660HW-67 until I finally upgraded the firmware... :(

                -Andre
              • Nick Pappas
                Thanks Andre. I m pretty sure it s something creeping around in my LS2, since I had a working server on my old (big, clunky, ugly, load) server and it worked
                Message 7 of 7 , Oct 7, 2005
                • 0 Attachment
                  Thanks Andre.

                  I'm pretty sure it's something creeping around in my LS2, since I had
                  a working server on my old (big, clunky, ugly, load) server and it
                  worked fine. I'll check the file .allow/.deny and services files when
                  I get home tonight!

                  On 10/7/05, lalunas10 <lalunas10@...> wrote:
                  > --- In LinkStation_General@yahoogroups.com, Nick Pappas <nwpappas@g...> wrote:
                  >
                  > You need the following for a web server, accessible from the web, on port 81, AFAIK:
                  >
                  > - an ISP not blocking the port
                  > - a router w/ NAT setup, directing port 81 to your server's IP address
                  > - the router's firewall must not be blocking port 81/tcp incoming/outgoing
                  > - the web interface of the router must not be using port 81
                  > - your /etc/host.{allow,deny} must open enough (or just deleted)
                  > - the web server serving on port 81
                  > - probably also add port 81 to /etc/services and reboot
                  >
                  > and last not least, a router firmware w/o bugs. Spent hours and hours w/ a correctly set up
                  > Zyxel Prestige 660HW-67 until I finally upgraded the firmware... :(
                  >
                  > -Andre
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  > Yahoo! Groups Links
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >


                  --
                  Whatever you do - don't congratulate yourself too much, or berate
                  yourself either.
                  Your choices are half chance, and so are everybody else's.
                Your message has been successfully submitted and would be delivered to recipients shortly.