Loading ...
Sorry, an error occurred while loading the content.

Re: Problem with CGI perl scripts and second copy of thttpd

Expand Messages
  • lalunas10
    ... From the man page: Restricting CGI programs to a single directory lets the site administrator review them for security holes, and is strongly
    Message 1 of 2 , Sep 18 8:45 PM
    • 0 Attachment
      --- In LinkStation_General@yahoogroups.com, "Andrew" <andrew@k...> wrote:
      > Hi,
      > Just getting to grips with LS hacking.. I have an LS 1 and have got
      > root access ok, then followed the details over at
      > http://linkstationwiki.org/Articles/GeneralThttpd on how to create
      > another web server.
      >
      > The problem I have is running cgi scripts, I've modified the
      > thttpd2.conf file to allow **.cgi (cgi can run from anywhere) but

      From the man page: "Restricting CGI programs to a single directory lets the site
      administrator review them for security holes, and is strongly recommended."

      > whenever I try to access a cgi page I get the following;
      > 500 Internal Error
      > There was an unusual problem serving the requested
      > URL '/ffileman.cgi'.

      Are you connecting on port 81?

      > thttpd/2.25b 29dec2003
      >
      > tried with different cgi files and they're all the same, I've made
      > sure permissions are set to 755 .. so must be something I'm missing.

      Again, I would opt for another cgi directiry, like /www/cgi-bin3 (on LS1)

      -Andre
    Your message has been successfully submitted and would be delivered to recipients shortly.