Loading ...
Sorry, an error occurred while loading the content.
 

wget: linkstationwiki.org: Host name lookup failure

Expand Messages
  • schwab_one
    I ll appreciate any suggestions as to what needs to be done to correct the HOST NAME LOOKUP FAILURE I m receiving while using wget to download software from
    Message 1 of 6 , Aug 24, 2005
      I'll appreciate any suggestions as to what needs to be done to
      correct
      the HOST NAME LOOKUP FAILURE I'm receiving while using wget to
      download
      software from linkstationwiki.org which I wish to upload to my
      Linkstation I (PPC)

      I have tried using PUTTY and NUTTY on my PC

      I have tried using the Terminal in OSX

      All programs return the same error below

      root@SCHWABNETHD:~# wget
      http://linkstationwiki.org/downloads/development_t
      ools/ppc-tools-2.tgz
      wget: linkstationwiki.org: Host name lookup failure

      Any ideas?

      Thanks
    • prb0x
      You need to tell your LS what nameserver to use. What does: cat /etc/resolv.conf ...tell you? If it s empty then go to the network setup page of you LS (
      Message 2 of 6 , Aug 24, 2005
        You need to tell your LS what nameserver to use.

        What does:

        cat /etc/resolv.conf

        ...tell you?

        If it's empty then go to the network setup page of you LS (
        http://YourLS-IP-Address/cgi-bin/setup-ip.cgi ) and enter in an IP
        address for the gateway - this will be your router/modem. However
        it's assumed your gateway has 1) DNS relaying, 2) the correct DNS
        servers off the net.

        If that does not work - check /etc/resolv.conf again. Then:

        echo "nameserver 10.10.10.10" > /etc/resolv.conf

        ..replacing 10.10.10.10 with the IP of one of your ISPs DNS servers.

        note this will erase the contents of resolv.conf and replace it with
        what is in the quotes. You could change the > to >> and it will
        append the line to the end of the file.

        If you don't know it the DNS IP then you can usually find this info
        from the details section in your network settings (sorry I don't know
        the equ. for OSX). I guess with OSX you can "cat /etc/resolv.conf" in
        a terminal window (it's linuxish isn't it?)

        Failing that you could use this DNS server in the UK (most DNS servers
        allow access outside of their client network):

        212.159.13.50

        ..until you find the right server.
        Hope that helps.

        Al
        --- In LinkStation_General@yahoogroups.com, "schwab_one"
        <schwab.thomas@m...> wrote:
        > I'll appreciate any suggestions as to what needs to be done to
        > correct
        > the HOST NAME LOOKUP FAILURE I'm receiving while using wget to
        > download
        > software from linkstationwiki.org which I wish to upload to my
        > Linkstation I (PPC)
        >
        > I have tried using PUTTY and NUTTY on my PC
        >
        > I have tried using the Terminal in OSX
        >
        > All programs return the same error below
        >
        > root@SCHWABNETHD:~# wget
        > http://linkstationwiki.org/downloads/development_t
        > ools/ppc-tools-2.tgz
        > wget: linkstationwiki.org: Host name lookup failure
        >
        > Any ideas?
        >
        > Thanks
      • schwab_one
        Thank you, Al. Here s my results. What do you get from a cat /etc/resolv.conf ? It s empty? See result- - root@SCHWABNETHD:~# cat /etc/resolv.conf # #
        Message 3 of 6 , Aug 25, 2005
          Thank you, Al.

          Here's my results.

          What do you get from a 'cat /etc/resolv.conf'? It's empty? See result-
          ->
          root@SCHWABNETHD:~# cat /etc/resolv.conf
          #
          # resolv.conf This file is the resolver configuration file
          # See resolver(5).

          If it's empty then go to the network setup page of you LS (
          http://YourLS-IP-Address/cgi-bin/setup-ip.cgi ) and enter in an IP
          address for the gateway - this will be your router/modem. However
          it's assumed your gateway has 1) DNS relaying, 2) the correct DNS
          servers off the net.

          I did this without any change--entered my Linksys BEFSR41 router IP
          192.168.1.1

          I did not go to your next step yet... If that does not work -
          check /etc/resolv.conf again. Then:

          echo "nameserver 10.10.10.10" > /etc/resolv.conf

          ..replacing 10.10.10.10 with the IP of one of your ISPs DNS servers.

          BTW I have so additional information posted on the
          linkstationwiki.org forum here which may help troubleshoot my
          inability to connect using wget. See my answer to ultravelours.

          Here is that link:
          http://linkstationwiki.org/forum/2_147_0.html

          Thanks for your time and consideration in getting my setup going.

          Tom


          --- In LinkStation_General@yahoogroups.com, "prb0x" <al@t...> wrote:
          > You need to tell your LS what nameserver to use.
          >
          > What does:
          >
          > cat /etc/resolv.conf
          >
          > ...tell you?
          >
          > If it's empty then go to the network setup page of you LS (
          > http://YourLS-IP-Address/cgi-bin/setup-ip.cgi ) and enter in an IP
          > address for the gateway - this will be your router/modem. However
          > it's assumed your gateway has 1) DNS relaying, 2) the correct DNS
          > servers off the net.
          >
          > If that does not work - check /etc/resolv.conf again. Then:
          >
          > echo "nameserver 10.10.10.10" > /etc/resolv.conf
          >
          > ..replacing 10.10.10.10 with the IP of one of your ISPs DNS servers.
          >
          > note this will erase the contents of resolv.conf and replace it with
          > what is in the quotes. You could change the > to >> and it will
          > append the line to the end of the file.
          >
          > If you don't know it the DNS IP then you can usually find this info
          > from the details section in your network settings (sorry I don't
          know
          > the equ. for OSX). I guess with OSX you can "cat /etc/resolv.conf"
          in
          > a terminal window (it's linuxish isn't it?)
          >
          > Failing that you could use this DNS server in the UK (most DNS
          servers
          > allow access outside of their client network):
          >
          > 212.159.13.50
          >
          > ..until you find the right server.
          > Hope that helps.
          >
          > Al
          > --- In LinkStation_General@yahoogroups.com, "schwab_one"
          > <schwab.thomas@m...> wrote:
          > > I'll appreciate any suggestions as to what needs to be done to
          > > correct
          > > the HOST NAME LOOKUP FAILURE I'm receiving while using wget to
          > > download
          > > software from linkstationwiki.org which I wish to upload to my
          > > Linkstation I (PPC)
          > >
          > > I have tried using PUTTY and NUTTY on my PC
          > >
          > > I have tried using the Terminal in OSX
          > >
          > > All programs return the same error below
          > >
          > > root@SCHWABNETHD:~# wget
          > > http://linkstationwiki.org/downloads/development_t
          > > ools/ppc-tools-2.tgz
          > > wget: linkstationwiki.org: Host name lookup failure
          > >
          > > Any ideas?
          > >
          > > Thanks
        • prb0x
          Carry on with the steps until it works. Cheers, Al
          Message 4 of 6 , Aug 25, 2005
            Carry on with the steps until it works.

            Cheers,
            Al

            --- In LinkStation_General@yahoogroups.com, "schwab_one"
            <schwab.thomas@m...> wrote:
            > Thank you, Al.
            >
            > Here's my results.
            >
            > What do you get from a 'cat /etc/resolv.conf'? It's empty? See result-
            > ->
            > root@SCHWABNETHD:~# cat /etc/resolv.conf
            > #
            > # resolv.conf This file is the resolver configuration file
            > # See resolver(5).
            >
            > If it's empty then go to the network setup page of you LS (
            > http://YourLS-IP-Address/cgi-bin/setup-ip.cgi ) and enter in an IP
            > address for the gateway - this will be your router/modem. However
            > it's assumed your gateway has 1) DNS relaying, 2) the correct DNS
            > servers off the net.
            >
            > I did this without any change--entered my Linksys BEFSR41 router IP
            > 192.168.1.1
            >
            > I did not go to your next step yet... If that does not work -
            > check /etc/resolv.conf again. Then:
            >
            > echo "nameserver 10.10.10.10" > /etc/resolv.conf
            >
            > ..replacing 10.10.10.10 with the IP of one of your ISPs DNS servers.
            >
            > BTW I have so additional information posted on the
            > linkstationwiki.org forum here which may help troubleshoot my
            > inability to connect using wget. See my answer to ultravelours.
            >
            > Here is that link:
            > http://linkstationwiki.org/forum/2_147_0.html
            >
            > Thanks for your time and consideration in getting my setup going.
            >
            > Tom
            >
            >
            > --- In LinkStation_General@yahoogroups.com, "prb0x" <al@t...> wrote:
            > > You need to tell your LS what nameserver to use.
            > >
            > > What does:
            > >
            > > cat /etc/resolv.conf
            > >
            > > ...tell you?
            > >
            > > If it's empty then go to the network setup page of you LS (
            > > http://YourLS-IP-Address/cgi-bin/setup-ip.cgi ) and enter in an IP
            > > address for the gateway - this will be your router/modem. However
            > > it's assumed your gateway has 1) DNS relaying, 2) the correct DNS
            > > servers off the net.
            > >
            > > If that does not work - check /etc/resolv.conf again. Then:
            > >
            > > echo "nameserver 10.10.10.10" > /etc/resolv.conf
            > >
            > > ..replacing 10.10.10.10 with the IP of one of your ISPs DNS servers.
            > >
            > > note this will erase the contents of resolv.conf and replace it with
            > > what is in the quotes. You could change the > to >> and it will
            > > append the line to the end of the file.
            > >
            > > If you don't know it the DNS IP then you can usually find this info
            > > from the details section in your network settings (sorry I don't
            > know
            > > the equ. for OSX). I guess with OSX you can "cat /etc/resolv.conf"
            > in
            > > a terminal window (it's linuxish isn't it?)
            > >
            > > Failing that you could use this DNS server in the UK (most DNS
            > servers
            > > allow access outside of their client network):
            > >
            > > 212.159.13.50
            > >
            > > ..until you find the right server.
            > > Hope that helps.
            > >
            > > Al
            > > --- In LinkStation_General@yahoogroups.com, "schwab_one"
            > > <schwab.thomas@m...> wrote:
            > > > I'll appreciate any suggestions as to what needs to be done to
            > > > correct
            > > > the HOST NAME LOOKUP FAILURE I'm receiving while using wget to
            > > > download
            > > > software from linkstationwiki.org which I wish to upload to my
            > > > Linkstation I (PPC)
            > > >
            > > > I have tried using PUTTY and NUTTY on my PC
            > > >
            > > > I have tried using the Terminal in OSX
            > > >
            > > > All programs return the same error below
            > > >
            > > > root@SCHWABNETHD:~# wget
            > > > http://linkstationwiki.org/downloads/development_t
            > > > ools/ppc-tools-2.tgz
            > > > wget: linkstationwiki.org: Host name lookup failure
            > > >
            > > > Any ideas?
            > > >
            > > > Thanks
          • schwab_one
            Thanks All :-) After entering my router s IP in this line all is well echo nameserver 10.10.10.10 /etc/resolv.conf I also downloaded mt-daapd but after
            Message 5 of 6 , Aug 25, 2005
              Thanks All :-)

              After entering my router's IP in this line all is well

              echo "nameserver 10.10.10.10" > /etc/resolv.conf

              I also downloaded mt-daapd but after unpacking receive this message:


              root@SCHWABNETHD:~# ./install.sh
              You must execute this script from the filesystem root [/]. Exiting.


              Thanks for the tutoring...HELP PLEASE

              Tom

              --- In LinkStation_General@yahoogroups.com, "prb0x" <al@t...> wrote:
              > Carry on with the steps until it works.
              >
              > Cheers,
              > Al
              >
              > --- In LinkStation_General@yahoogroups.com, "schwab_one"
              > <schwab.thomas@m...> wrote:
              > > Thank you, Al.
              > >
              > > Here's my results.
              > >
              > > What do you get from a 'cat /etc/resolv.conf'? It's empty? See
              result-
              > > ->
              > > root@SCHWABNETHD:~# cat /etc/resolv.conf
              > > #
              > > # resolv.conf This file is the resolver configuration file
              > > # See resolver(5).
              > >
              > > If it's empty then go to the network setup page of you LS (
              > > http://YourLS-IP-Address/cgi-bin/setup-ip.cgi ) and enter in an IP
              > > address for the gateway - this will be your router/modem. However
              > > it's assumed your gateway has 1) DNS relaying, 2) the correct DNS
              > > servers off the net.
              > >
              > > I did this without any change--entered my Linksys BEFSR41 router
              IP
              > > 192.168.1.1
              > >
              > > I did not go to your next step yet... If that does not work -
              > > check /etc/resolv.conf again. Then:
              > >
              > > echo "nameserver 10.10.10.10" > /etc/resolv.conf
              > >
              > > ..replacing 10.10.10.10 with the IP of one of your ISPs DNS
              servers.
              > >
              > > BTW I have so additional information posted on the
              > > linkstationwiki.org forum here which may help troubleshoot my
              > > inability to connect using wget. See my answer to ultravelours.
              > >
              > > Here is that link:
              > > http://linkstationwiki.org/forum/2_147_0.html
              > >
              > > Thanks for your time and consideration in getting my setup going.
              > >
              > > Tom
              > >
              > >
              > > --- In LinkStation_General@yahoogroups.com, "prb0x" <al@t...>
              wrote:
              > > > You need to tell your LS what nameserver to use.
              > > >
              > > > What does:
              > > >
              > > > cat /etc/resolv.conf
              > > >
              > > > ...tell you?
              > > >
              > > > If it's empty then go to the network setup page of you LS (
              > > > http://YourLS-IP-Address/cgi-bin/setup-ip.cgi ) and enter in an
              IP
              > > > address for the gateway - this will be your router/modem.
              However
              > > > it's assumed your gateway has 1) DNS relaying, 2) the correct
              DNS
              > > > servers off the net.
              > > >
              > > > If that does not work - check /etc/resolv.conf again. Then:
              > > >
              > > > echo "nameserver 10.10.10.10" > /etc/resolv.conf
              > > >
              > > > ..replacing 10.10.10.10 with the IP of one of your ISPs DNS
              servers.
              > > >
              > > > note this will erase the contents of resolv.conf and replace it
              with
              > > > what is in the quotes. You could change the > to >> and it will
              > > > append the line to the end of the file.
              > > >
              > > > If you don't know it the DNS IP then you can usually find this
              info
              > > > from the details section in your network settings (sorry I
              don't
              > > know
              > > > the equ. for OSX). I guess with OSX you can "cat
              /etc/resolv.conf"
              > > in
              > > > a terminal window (it's linuxish isn't it?)
              > > >
              > > > Failing that you could use this DNS server in the UK (most DNS
              > > servers
              > > > allow access outside of their client network):
              > > >
              > > > 212.159.13.50
              > > >
              > > > ..until you find the right server.
              > > > Hope that helps.
              > > >
              > > > Al
              > > > --- In LinkStation_General@yahoogroups.com, "schwab_one"
              > > > <schwab.thomas@m...> wrote:
              > > > > I'll appreciate any suggestions as to what needs to be done to
              > > > > correct
              > > > > the HOST NAME LOOKUP FAILURE I'm receiving while using wget to
              > > > > download
              > > > > software from linkstationwiki.org which I wish to upload to
              my
              > > > > Linkstation I (PPC)
              > > > >
              > > > > I have tried using PUTTY and NUTTY on my PC
              > > > >
              > > > > I have tried using the Terminal in OSX
              > > > >
              > > > > All programs return the same error below
              > > > >
              > > > > root@SCHWABNETHD:~# wget
              > > > > http://linkstationwiki.org/downloads/development_t
              > > > > ools/ppc-tools-2.tgz
              > > > > wget: linkstationwiki.org: Host name lookup failure
              > > > >
              > > > > Any ideas?
              > > > >
              > > > > Thanks
            • schwab_one
              Problem Solved /install.sh did the trick...
              Message 6 of 6 , Aug 25, 2005
                Problem Solved

                /install.sh did the trick...

                --- In LinkStation_General@yahoogroups.com, "schwab_one" <schwab.thomas@m...>
                wrote:
                > Thanks All :-)
                >
                > After entering my router's IP in this line all is well
                >
                > echo "nameserver 10.10.10.10" > /etc/resolv.conf
                >
                > I also downloaded mt-daapd but after unpacking receive this message:
                >
                >
                > root@SCHWABNETHD:~# ./install.sh
                > You must execute this script from the filesystem root [/]. Exiting.
                >
                >
                > Thanks for the tutoring...HELP PLEASE
                >
                > Tom
                >
                > --- In LinkStation_General@yahoogroups.com, "prb0x" <al@t...> wrote:
                > > Carry on with the steps until it works.
                > >
                > > Cheers,
                > > Al
                > >
                > > --- In LinkStation_General@yahoogroups.com, "schwab_one"
                > > <schwab.thomas@m...> wrote:
                > > > Thank you, Al.
                > > >
                > > > Here's my results.
                > > >
                > > > What do you get from a 'cat /etc/resolv.conf'? It's empty? See
                > result-
                > > > ->
                > > > root@SCHWABNETHD:~# cat /etc/resolv.conf
                > > > #
                > > > # resolv.conf This file is the resolver configuration file
                > > > # See resolver(5).
                > > >
                > > > If it's empty then go to the network setup page of you LS (
                > > > http://YourLS-IP-Address/cgi-bin/setup-ip.cgi ) and enter in an IP
                > > > address for the gateway - this will be your router/modem. However
                > > > it's assumed your gateway has 1) DNS relaying, 2) the correct DNS
                > > > servers off the net.
                > > >
                > > > I did this without any change--entered my Linksys BEFSR41 router
                > IP
                > > > 192.168.1.1
                > > >
                > > > I did not go to your next step yet... If that does not work -
                > > > check /etc/resolv.conf again. Then:
                > > >
                > > > echo "nameserver 10.10.10.10" > /etc/resolv.conf
                > > >
                > > > ..replacing 10.10.10.10 with the IP of one of your ISPs DNS
                > servers.
                > > >
                > > > BTW I have so additional information posted on the
                > > > linkstationwiki.org forum here which may help troubleshoot my
                > > > inability to connect using wget. See my answer to ultravelours.
                > > >
                > > > Here is that link:
                > > > http://linkstationwiki.org/forum/2_147_0.html
                > > >
                > > > Thanks for your time and consideration in getting my setup going.
                > > >
                > > > Tom
                > > >
                > > >
                > > > --- In LinkStation_General@yahoogroups.com, "prb0x" <al@t...>
                > wrote:
                > > > > You need to tell your LS what nameserver to use.
                > > > >
                > > > > What does:
                > > > >
                > > > > cat /etc/resolv.conf
                > > > >
                > > > > ...tell you?
                > > > >
                > > > > If it's empty then go to the network setup page of you LS (
                > > > > http://YourLS-IP-Address/cgi-bin/setup-ip.cgi ) and enter in an
                > IP
                > > > > address for the gateway - this will be your router/modem.
                > However
                > > > > it's assumed your gateway has 1) DNS relaying, 2) the correct
                > DNS
                > > > > servers off the net.
                > > > >
                > > > > If that does not work - check /etc/resolv.conf again. Then:
                > > > >
                > > > > echo "nameserver 10.10.10.10" > /etc/resolv.conf
                > > > >
                > > > > ..replacing 10.10.10.10 with the IP of one of your ISPs DNS
                > servers.
                > > > >
                > > > > note this will erase the contents of resolv.conf and replace it
                > with
                > > > > what is in the quotes. You could change the > to >> and it will
                > > > > append the line to the end of the file.
                > > > >
                > > > > If you don't know it the DNS IP then you can usually find this
                > info
                > > > > from the details section in your network settings (sorry I
                > don't
                > > > know
                > > > > the equ. for OSX). I guess with OSX you can "cat
                > /etc/resolv.conf"
                > > > in
                > > > > a terminal window (it's linuxish isn't it?)
                > > > >
                > > > > Failing that you could use this DNS server in the UK (most DNS
                > > > servers
                > > > > allow access outside of their client network):
                > > > >
                > > > > 212.159.13.50
                > > > >
                > > > > ..until you find the right server.
                > > > > Hope that helps.
                > > > >
                > > > > Al
                > > > > --- In LinkStation_General@yahoogroups.com, "schwab_one"
                > > > > <schwab.thomas@m...> wrote:
                > > > > > I'll appreciate any suggestions as to what needs to be done to
                > > > > > correct
                > > > > > the HOST NAME LOOKUP FAILURE I'm receiving while using wget to
                > > > > > download
                > > > > > software from linkstationwiki.org which I wish to upload to
                > my
                > > > > > Linkstation I (PPC)
                > > > > >
                > > > > > I have tried using PUTTY and NUTTY on my PC
                > > > > >
                > > > > > I have tried using the Terminal in OSX
                > > > > >
                > > > > > All programs return the same error below
                > > > > >
                > > > > > root@SCHWABNETHD:~# wget
                > > > > > http://linkstationwiki.org/downloads/development_t
                > > > > > ools/ppc-tools-2.tgz
                > > > > > wget: linkstationwiki.org: Host name lookup failure
                > > > > >
                > > > > > Any ideas?
                > > > > >
                > > > > > Thanks
              Your message has been successfully submitted and would be delivered to recipients shortly.