Loading ...
Sorry, an error occurred while loading the content.

Re: LinkStation HD-HG400LAN Firmware Version "1.34" -> "hg-openlink-05b" firmware update not completing

Expand Messages
  • Ian White
    ... No problem. I knew the risk I was taking. I was just mightily impressed by your efforts with the wiki and hacked firmwares and so trusted you implicitly
    Message 1 of 1 , Aug 15, 2005
    • 0 Attachment
      > From: "wedgemusic" <wedgemusic@...>
      > Subject: Re: LinkStation HD-HG400LAN Firmware Version "1.34" ->
      > "hg-openlink-05b" gone badly wrong
      >
      > It seems I messed up something with this release. I will be posting a
      > new build soon (probably sometime Monday afternoon). Sorry for the
      > trouble!

      No problem.
      I knew the risk I was taking.
      I was just mightily impressed by your efforts with the wiki and hacked firmwares
      and so trusted you implicitly ;-)

      Just in case it is of any more help/use to you
      here's some more info on the state of my "hg-openlink..." progress:

      Ok I have tried the 2 Japanese firmwares (1.44 and 1.45b)
      and they both work:

      1.44 successfully updated from Emergency-Mode
      and then 1.45b updated, replacing 1.44

      Emergency Mode was achieved by deleting all 4 partitions
      from the hard disk and then re-creating 4 partitions
      (with my choice of partition sizes!) and "mkfs -t ext3" filesystems
      in partitions 1, 3 and 4
      and "mkswap" on 2 (probably not strictly necessary
      but what the heck, it was quick enough to do)

      I then tried re-installing "hg-openlink-05b"
      and it failed exactly like before.

      Having now attempted several firmware updates
      I have observed some similarities in the success and failure "paths"
      through the process:

      1) When you boot up with an essentially blank disk
      (either un-partitioned or partitioned with ext3 filesystems in place)
      the LinkStation tries to load from the h/d and fails
      which seems to set something so that the next boot is done from flash memory
      (i.e. "Emergency Mode")

      2) The firmware upgrade process starts by trying to find the LinkStation on the
      "network"

      It then transfers the image.dat, which it appears to successfully unpack in
      all 3 cases
      ("1.44-japanese", "1.45b-japanese" and "hg-openlink-05b")
      because a "tmpimage.tgz" appears in partition 3

      3) The tmpimage.tgz is unpacked (presumably into partition 1)
      which is then somehow marked as no-longer being "ext3"
      but is instead a valid "/" (root) partition.

      4) Then finally the LinkStation automatically reboots

      5) While (or in between) the transfer, unpack and install steps
      I guess some kind of signal is sent back to the firmware updater to indicate
      progress

      But then when the final automatic reboot takes place
      the firmware simply watches for the LinkStation to finish the reboot
      and begin responding in some way
      (not sure what that is yet. It may be a response on port 80 perhaps?)

      For "1.44-japanese" and "1.45b-japanese" the reboot is successful
      so the "HD-HGLANFWUpdate.exe" reports success

      For "hg-openlink-05b" the automatic reboot never completes
      so the "HD-HGLANFWUpdate.exe" reports failure

      This failure report occurs long before the LinkStation itself gives up on
      the boot process
      and during this time it is still responding to "telnet" (on port 23), but no
      response on port 80
      and no response to "ftp" (port 21)

      So I really do think that there is a specific problem with "hg-openlink-05b"

      So eagerly await another release (I'll be your alpha tester ...)

      But in the meantime I will play with hacking "1.45b-japanese"
      to see if I can *just* a) convert to English web-pages and b) add "telnet"
      access

      Cheers
      Ian W.

      > --- In LinkStation_General@yahoogroups.com, "Ian White"
      > <iandavidwhite@h...> wrote:
      > > Well after I had figured out what the Japanese "HD-HGLANFWUpdate.exe" does
      > > I tried installing/flashing "hg-openlink-05b[.zip]" onto my HG400
      > > The transfer of the firmware appeared to succeed
      > > as did the writing to the flash (red "Disk" and "Diag" LEDs flashing")
      > >
      > > I was concerned that something might have gone awry because I got a warning
      > > dialog up from
      > > the "HD-HGLAN FWUpdate.exe" but I can't decode the japanese/hieroglyphics to
      > > know what it says
      > > but as the LinkStation still seemed to be doing something so I left it alone
      > > overnight
      > >
      > > When I returned in the morning the red "Diag" LED was repeatedly flashing
      > > in blocks of 6 flashes
      > >
      > > I powered off and then on again and it seemed to be booting up
      > > (green power light flashing and network light first green then blue)
      > >
      > > During this time I could "ping" its DHCP-allocated IP address
      > > and get to a telnet login prompt (so things had changed, because I could not
      > > get to a telnet prompt under version 1.34)
      > > but I do not know a valid login
      > >
      > > Eventually the power and network lights go out and revert to diag LED
      > > flashing 6 times
      > > (and I can nolonger ping or telnet)
      > >
      > > I was then in a dilemma: Did I open the box up?
      > > I did open it up and upon connecting the disk to a linux PC
      > > I found that it had *4* partitions
      > >
      > > Partition Starting Cylinder Ending Cylinder Partition Type
      > >
      > > /dev/hdb1 1 48 83
      > > linux
      > > /dev/hdb2 49 114 82
      > > linux swap
      > > /dev/hdb3 115 48633 83 linux
      > > /dev/hdb4 48633 48641 83 linux
      > >
      > > 3 and 4 fsck'd ok, but partition 1 was flagged as corrupt
      > >
      > > At this point I think I may have done a silly thing:
      > > I backed up the contents of partition 3. Partition 4 was empty
      > > But partition 1, being "corrupt", I could not backup
      > >
      > > I then made a new ext3 file system on partition 1 and re-inserted it
      back into the LinkStation
      > > which starts to boot up but almost immediately reverts to dig-6-flashes
      > > I reboot and this time it appears to boot up ok:
      > >
      > > 1) I can ping the LinkStation on its DHCP-allocated IP address
      > >
      > > 2) The "HD-HGLAN FWUpdate.exe" finds the Linkstation
      > > but its name has changed to "HD-HGLAN-EM"
      > >
      > > 3) I cannot "telnet"
      > >
      > > 4) I can get to an "ftp" login prompt
      > > (but dispite several login details permutations, I cannot login)
      > >
      > > 5) I can use the Buffalo "IP Setup" utility to change the IP address
      > >
      > > So I tried the firmware flash again ... Same end result diag-6-flashes
      > >
      > > I have subsequently tried several permutations of partition combinations
      > > and/or empty partition table and presses of the red "reset" button on the
      > > back
      > > and repeated attempts to re-flash "hg-openlink-05b"
      > >
      > > And everytime I get back to the diag-6-flashes state
      > > (and partition 1 is corrupt, according to "fsck" on a linux PC)
      > >
      > > And everytime I delete the partition table and/or set up my own partitions
      > > formated as ext3 I can get back to the "Emergency Mode"
      > > (which is where I am at now)
      > >
      > > So I guess that I now just need a valid f/w other than the
      > > "hg-openlink-05b[.zip]"
      > > or instructions on how to recover from this repeated failure to flash
      > > (and yes, before you ask, I have turned off the Windows XP firewall
      > > and I have even used a direct PC-to-LinkStation cable (i.e. not via a
      > > hub/switch)
      > > all with the same result)
    Your message has been successfully submitted and would be delivered to recipients shortly.