Loading ...
Sorry, an error occurred while loading the content.

Re: LinkStation HD-HG400LAN Firmware Version "1.34" -> "hg-openlink-05b" gone ba

Expand Messages
  • wedgemusic
    It seems I messed up something with this release. I will be posting a new build soon (probably sometime Monday afternoon). Sorry for the trouble! ...
    Message 1 of 4 , Aug 14, 2005
    • 0 Attachment
      It seems I messed up something with this release. I will be posting a
      new build soon (probably sometime Monday afternoon). Sorry for the
      trouble!

      --- In LinkStation_General@yahoogroups.com, "Ian White"
      <iandavidwhite@h...> wrote:
      > Well after I had figured out what the Japanese "HD-HGLAN
      FWUpdate.exe" does
      > I tried installing/flashing "hg-openlink-05b[.zip]" onto my HG400
      > The transfer of the firmware appeared to succeed
      > as did the writing to the flash (red "Disk" and "Diag" LEDs flashing")
      >
      > I was concerned that something might have gone awry because I got a
      warning dialog up from
      > the "HD-HGLAN FWUpdate.exe" but I can't decode the
      japanese/hieroglyphics to know what it says
      > but as the LinkStation still seemed to be doing something so I left
      it alone overnight
      >
      > When I returned in the morning the red "Diag" LED was repeatedly
      flashing
      > in blocks of 6 flashes
      >
      > I powered off and then on again and it seemed to be booting up
      > (green power light flashing and network light first green then blue)
      >
      > During this time I could "ping" its DHCP-allocated IP address
      > and get to a telnet login prompt (so things had changed, because I
      could not get to a telnet prompt under version 1.34)
      > but I do not know a valid login
      >
      > Eventually the power and network lights go out and revert to diag
      LED flashing 6 times
      > (and I can nolonger ping or telnet)
      >
      > I was then in a dilemma: Did I open the box up?
      > I did open it up and upon connecting the disk to a linux PC
      > I found that it had *4* partitions
      >
      > Partition Starting Cylinder Ending Cylinder Partition Type
      >
      > /dev/hdb1 1 48
      83 linux
      > /dev/hdb2 49 114 82
      linux swap
      > /dev/hdb3 115 48633 83
      linux
      > /dev/hdb4 48633 48641 83 linux
      >
      > 3 and 4 fsck'd ok, but partition 1 was flagged as corrupt
      >
      > At this point I think I may have done a silly thing:
      > I backed up the contents of partition 3. Partition 4 was empty
      > But partition 1, being "corrupt", I could not backup
      >
      > I then made a new ext3 file system on partition 1 and re-inserted it
      back into the LinkStation
      > which starts to boot up but almost immediately reverts to dig-6-flashes
      > I reboot and this time it appears to boot up ok:
      >
      > 1) I can ping the LinkStation on its DHCP-allocated IP address
      >
      > 2) The "HD-HGLAN FWUpdate.exe" finds the Linkstation
      > but its name has changed to "HD-HG400-EM"
      >
      > 3) I cannot "telnet"
      >
      > 4) I can get to an "ftp" login prompt
      > (but dispite several login details permutations, I cannot login)
      >
      > 5) I can use the Buffalo "IP Setup" utility to change the IP address
      >
      > So I tried the firmware flash again ... Same end result diag-6-flashes
      >
      > I have subsequently tried several permutations of partition combinations
      > and/or empty partition table and presses of the red "reset" button
      on the back
      > and repeated attempts to re-flash "hg-openlink-05b"
      >
      > And everytime I get back to the diag-6-flashes state
      > (and partition 1 is corrupt, according to "fsck" on a linux PC)
      >
      > And everytime I delete the partition table and/or set up my own
      partitions
      > formated as ext3 I can get back to the "Emergency Mode"
      > (which is where I am at now)
      >
      > So I guess that I now just need a valid f/w other than the
      "hg-openlink-05b[.zip]"
      > or instructions on how to recover from this repeated failure to flash
      > (and yes, before you ask, I have turned off the Windows XP firewall
      > and I have even used a direct PC-to-LinkStation cable (i.e. not via
      a hub/switch)
      > all with the same result)
      >
      > Boo hoo
      > Ian W.
      >
      > > Message: 2
      > > Date: Thu, 11 Aug 2005 15:51:52 +0100
      > > From: "Ian White" <iandavidwhite@h...>
      > > Subject: Re: LinkStation HD-HG400LAN Firmware Version "1.34"
      > >
      > > irvine_stock" <r_obermeyer@p...> wrote:
      > >
      > > > 4) zip the file back with same password
      > > > Update your HG with Firmware updater and get root access and
      the latest
      > > firmware
      > > > Very low risk since you can always revert back to older
      firmware.
      > >
      > > Err where can I get such an "older firmware" from?
      > > (Ideally 1.34 as per pre-installed version)?
      > >
      > > "wedgemusic" <wedgemusic@y...> wrote:
      > >
      > > > There is now an OpenLink firmware for the HG LinkStation.
      > > > See http://linkstationwiki.org for more information.
      > >
      > > Now that seems a much more promising route.
      > > I'll give it a try and there will be a donation on the way if it works
      > > (and lots of questions if it doesn't ;-)
    Your message has been successfully submitted and would be delivered to recipients shortly.