Loading ...
Sorry, an error occurred while loading the content.

Slimserver with Linkstation II

Expand Messages
  • KerLet
    I have posted about this but the subject mentioned perl 5.6.1...so I wanted to post again with the real subject in case someone out there can help. I am trying
    Message 1 of 1 , Jul 17 4:50 PM
    • 0 Attachment
      I have posted about this but the subject mentioned perl 5.6.1...so I
      wanted to post again with the real subject in case someone out there
      can help.

      I am trying to run slimserver on a Linkstation II.

      I have not yet been successful, although a lot of people have tried
      to help...which I very much appreciate.

      Has anyone gotten this working?

      It seems like every time I try another method, I find I am missing
      something else on the Linkstation. (Ie. various programs, compilers,
      etc...)

      Marc Field has been very helpful, and this is what he said about my
      latest stumbling block:

      These messages mean that there are a few Perl modules not found in a
      standard Perl build that are required for SlimServer. (Sorry I
      completely forgot to mention this issue in our e-mail discussion!)
      These must be built for each platform on which SlimServer runs.

      The SlimServer software includes modules for common platforms,
      including the PPC LinkStation (I had to build and provide them to
      Slim Devices). The same will have to be done for the MIPS
      LinkStation.

      Is there someone with a MIPS LinkStation and a development
      environment who is willing to build the modules? The modules can be
      found here: http://svn.slimdevices.com/vendor/src/ (I don't think sox
      is required; I don't remember building that one).

      I'm happy to open a bug at SlimDevices and attach the modules once
      they
      are built, and then they will be included in the various SlimServer
      downloads (and then people won't have to deal with this issue at all).
      This was the process used for the PPC modules (see
      http://bugs.slimdevices.com/show_bug.cgi?id=1012).


      The modules in question are DBD::SQLite XML::Parser HTML::Parser
      Compress::Zlib

      Is there anyone out there that can compile them for an LS II?

      Thanks!!
    Your message has been successfully submitted and would be delivered to recipients shortly.