Loading ...
Sorry, an error occurred while loading the content.

Help with OpenVPN

Expand Messages
  • lalunas10
    Hi all, so I ve copied /dev/net/tun from my Mom s Woody/PC box the my LS1, loaded the Kurobox tun module by force, compiled lzo and openvpn 2.0. Using an
    Message 1 of 1 , Jul 3, 2005
    View Source
    • 0 Attachment
      Hi all,

      so I've copied /dev/net/tun from my Mom's Woody/PC box the my LS1, loaded the
      Kurobox tun module by force, compiled lzo and openvpn 2.0. Using an adjusted setup,
      which is working elsewhere, I get:

      # cat /etc/openvpn/192-168-1-7.conf
      remote 192.168.1.7
      dev tun
      port 1194
      ifconfig 192.168.9.5 192.168.9.7
      comp-lzo
      mute 1
      secret /etc/openvpn/shared.key
      up-restart

      # openvpn --config /etc/openvpn/192-168-1-7.conf
      Sat Jul 2 21:24:29 2005 OpenVPN 2.0 powerpc-unknown-linux [SSL] [LZO] built on Jul 2
      2005
      Sat Jul 2 21:24:29 2005 LZO compression initialized
      Sat Jul 2 21:24:29 2005 TUN/TAP device tun0 opened
      Sat Jul 2 21:24:29 2005 ip link set dev tun0 up mtu 1500
      sh: ip: command not found
      Sat Jul 2 21:24:29 2005 Linux ip link set failed: could not execute shell command
      Sat Jul 2 21:24:29 2005 Exiting

      and here I'm stuck. Neither the Debian box nor my Mac OS X laptop would provide an
      extra "ip" command, so I don't know what to do. What shell other command is it missing?
      All bin and sbin directories are in $PATH?

      Thanks in advance,

      -Andre
    Your message has been successfully submitted and would be delivered to recipients shortly.