Loading ...
Sorry, an error occurred while loading the content.

Re: problems on the first steps to Debian

Expand Messages
  • James Stewart
    ... Thanks for the feedback. Perhaps Wedgemusic can edit the instructions so to avoid confusion like this in the future. ... Yes, without editing them you get
    Message 1 of 12 , Jul 2, 2005
    • 0 Attachment
      --- In LinkStation_General@yahoogroups.com, "mikynog" <mikynog@y...>
      wrote:

      > Thank you both for your replies. I think it was a combination of
      > putting the "./" in front and referring to "hda1" that allowed me
      > to get past that point.

      Thanks for the feedback. Perhaps Wedgemusic can edit the
      instructions so to avoid confusion like this in the future.

      > I think I've gotten to the point where I need to telnet into the
      > Linkstation but I don't see it on my network. I didn't know what
      > to put in the series of configuration files in the /ext/ folder so
      > I left those alone. How should I edit these? My guess is this is
      > the part I'm missing.

      Yes, without editing them you get a network settings that might not
      be compatible with your network. I can't remember what they are,
      but they are listed in the original docs that the wiki docs were
      made from that can be found in the "files" section of this Yahoo
      group.

      I guess instructions for "how to edit" the settings need to be added
      too.
    • wedgemusic
      ... Done :) ... This is already noted in the Debian conversion instructions. The wiki states: 15. Correct the networking files so you can connect to the
      Message 2 of 12 , Jul 2, 2005
      • 0 Attachment
        > Thanks for the feedback. Perhaps Wedgemusic can edit the
        > instructions so to avoid confusion like this in the future.

        Done :)

        > > I think I've gotten to the point where I need to telnet into the
        > > Linkstation but I don't see it on my network. I didn't know what
        > > to put in the series of configuration files in the /ext/ folder so
        > > I left those alone. How should I edit these? My guess is this is
        > > the part I'm missing.
        >
        > Yes, without editing them you get a network settings that might not
        > be compatible with your network. I can't remember what they are,
        > but they are listed in the original docs that the wiki docs were
        > made from that can be found in the "files" section of this Yahoo
        > group.
        >
        > I guess instructions for "how to edit" the settings need to be added
        > too.

        This is already noted in the Debian conversion instructions. The wiki
        states:

        "15. Correct the networking files so you can connect to the
        Linkstation. Edit /etc/network/interfaces, /etc/resolv.conf,
        /etc/hosts, /etc/hosts.allow, and /etc/hosts.deny to your network
        settings. It is recommended to change /etc/hosts.deny to ALL : PARANOID."

        I can't tell people exactly what to put because of variations in
        peoples' network settings. If you want to post your network
        information I can suggest what to put.
      • mikynog
        I m not sure to what detail you need my network configuration but basically I have a firewall/router/switch that sits between the cable modem and the network.
        Message 3 of 12 , Jul 2, 2005
        • 0 Attachment
          I'm not sure to what detail you need my network configuration but
          basically I have a firewall/router/switch that sits between the cable
          modem and the network. The switch doles out IP addresses (DHCP).

          The thing that was odd was that the LS wasn't showing up as a device
          on the switch, which I saw to mean that the LS didn't get an IP
          address. Is this remedied by editing these files? Or did I miss
          something?

          I don't know how you stay on top of these posts and keep your day jobs
          but much thanks :).




          --- In LinkStation_General@yahoogroups.com, "wedgemusic"
          <wedgemusic@y...> wrote:
          > > Thanks for the feedback. Perhaps Wedgemusic can edit the
          > > instructions so to avoid confusion like this in the future.
          >
          > Done :)
          >
          > > > I think I've gotten to the point where I need to telnet into the
          > > > Linkstation but I don't see it on my network. I didn't know what
          > > > to put in the series of configuration files in the /ext/ folder so
          > > > I left those alone. How should I edit these? My guess is this is
          > > > the part I'm missing.
          > >
          > > Yes, without editing them you get a network settings that might not
          > > be compatible with your network. I can't remember what they are,
          > > but they are listed in the original docs that the wiki docs were
          > > made from that can be found in the "files" section of this Yahoo
          > > group.
          > >
          > > I guess instructions for "how to edit" the settings need to be added
          > > too.
          >
          > This is already noted in the Debian conversion instructions. The wiki
          > states:
          >
          > "15. Correct the networking files so you can connect to the
          > Linkstation. Edit /etc/network/interfaces, /etc/resolv.conf,
          > /etc/hosts, /etc/hosts.allow, and /etc/hosts.deny to your network
          > settings. It is recommended to change /etc/hosts.deny to ALL :
          PARANOID."
          >
          > I can't tell people exactly what to put because of variations in
          > peoples' network settings. If you want to post your network
          > information I can suggest what to put.
        • James Ronald
          If you didn t change the IP address like the how-to states then IP address should be set to 192.168.0.100. So long as your DHCP server is serving up IPs on
          Message 4 of 12 , Jul 2, 2005
          • 0 Attachment
            If you didn't change the IP address like the how-to states then IP address
            should be set to 192.168.0.100. So long as your DHCP server is serving up
            IPs on the 192.168.0 network you should be fine so long as 192.168.0.100 is
            not already being assigned to another IP device. If your network is not set
            to 192.168.0 you can ether remove the drive and change it per the how-to or
            change a workstation on your network to 192.168.0.10, telnet into the LS @
            192.168.0.100 and then change the LS IP per the how-to.

            ---- Original Message -----
            From: "mikynog" <mikynog@...>
            To: <LinkStation_General@yahoogroups.com>
            Sent: Saturday, July 02, 2005 9:01 PM
            Subject: [LinkStation_General] Re: problems on the first steps to Debian


            >
            > I'm not sure to what detail you need my network configuration but
            > basically I have a firewall/router/switch that sits between the cable
            > modem and the network. The switch doles out IP addresses (DHCP).
            >
            > The thing that was odd was that the LS wasn't showing up as a device
            > on the switch, which I saw to mean that the LS didn't get an IP
            > address. Is this remedied by editing these files? Or did I miss
            > something?
            >
            > I don't know how you stay on top of these posts and keep your day jobs
            > but much thanks :).
            > --- In LinkStation_General@yahoogroups.com, "wedgemusic"
            > <wedgemusic@y...> wrote:
            >> > Thanks for the feedback. Perhaps Wedgemusic can edit the
            >> > instructions so to avoid confusion like this in the future.
            >>
            >> Done :)
            >>
            >> > > I think I've gotten to the point where I need to telnet into the
            >> > > Linkstation but I don't see it on my network. I didn't know what
            >> > > to put in the series of configuration files in the /ext/ folder so
            >> > > I left those alone. How should I edit these? My guess is this is
            >> > > the part I'm missing.
            >> >
            >> > Yes, without editing them you get a network settings that might not
            >> > be compatible with your network. I can't remember what they are,
            >> > but they are listed in the original docs that the wiki docs were
            >> > made from that can be found in the "files" section of this Yahoo
            >> > group.
            >> >
            >> > I guess instructions for "how to edit" the settings need to be added
            >> > too.
            >>
            >> This is already noted in the Debian conversion instructions. The wiki
            >> states:
            >>
            >> "15. Correct the networking files so you can connect to the
            >> Linkstation. Edit /etc/network/interfaces, /etc/resolv.conf,
            >> /etc/hosts, /etc/hosts.allow, and /etc/hosts.deny to your network
            >> settings. It is recommended to change /etc/hosts.deny to ALL :
            > PARANOID."
            >>
            >> I can't tell people exactly what to put because of variations in
            >> peoples' network settings. If you want to post your network
            >> information I can suggest what to put.
          • James Stewart
            ... Yes, the default network config on that Debian system (unless someone has changed it) are these static IP settings: IP address: 192.168.0.100 Gateway:
            Message 5 of 12 , Jul 2, 2005
            • 0 Attachment
              --- In LinkStation_General@yahoogroups.com, "mikynog" <mikynog@y...>
              wrote:

              > The switch doles out IP addresses (DHCP). The thing that was odd
              > was that the LS wasn't showing up as a device on the switch, which
              > I saw to mean that the LS didn't get an IP address. Is this
              > remedied by editing these files? Or did I miss something?

              Yes, the default network config on that Debian system (unless
              someone has changed it) are these static IP settings:

              IP address: 192.168.0.100
              Gateway: 192.168.0.1
              DNS: 192.168.0.1

              Your DHCP server didn't register anything because the LS never asked
              the DHCP server for anything.

              I don't think that a DHCP client works on this system because of an
              imcompatibility with the options compiled into the kernel. At least
              I can't get it to work on mine. I never tried other DHCP clients
              like "pump" however.

              So to change the network config of the LS you have to
              edit /etc/network/interfaces. You will also need to
              edit /etc/resolve (for DNS settings), and /etc/hosts.allow
              & /etc/hosts.deny to allow you to log into it.

              > I don't know how you stay on top of these posts and keep your day
              > jobs but much thanks :).

              Well, work is a little slow right now, so you are in luck.

              > I guess instructions for "how to edit" the settings need to be
              > added too.

              That depends on what you used to put the Debian on the LS in the
              first place. If it was a Linux/Unix type system, use what ever
              plain text editor that might be on it that you know how to use.
              They all usually at least have "vi", but it isn't at all new-user
              friendly. If you used something full featured like a Knoppix CDROM,
              then you can use "kwrite", "kate", "kedit", "gedit", etc. If you
              can get into your LS by changing network settings on a computer to
              be compatible with it, you can edit them from within you LS, it only
              has "vi" but you can then ftp the "nano" editor that I put in the
              "files" section of this group if you need something easier to figure
              out.

              Now you know why I am very excited about the install procedure that
              balimbabullabe is working on. It should be much less convoluted if
              he ever gets the thing to boot.

              How did you get Debian on your LS? I guess I (or someone)
              could/should do a revised procedure for the LS-1 that does it using
              balimbabullabe's partition swapper program, but not debootstrap
              (like his installer will use) that still uses the Japanese Debian
              instead. With this procedure, you would copy the Japanese tarball
              over to the share directory using the Windows sharing-server
              function of the LS, then telnet into it and unpack it to the root
              of /mnt. Then copy over the /lib/modules directory to /mnt, then
              fix up your network setting, and host.allow stuff, then run the
              partition swapper program and reboot. (Notice the drive never left
              the LS!), I was just hoping we would have balimbabullabe's version
              by now because the Japanese Debian uses the ancient "Woody" Debian,
              which you then normally would want to upgrade to "Sarge" (which can
              be done with a simple "apt-get dist-upgrade"), which will pretty
              much replace the whole system with the current Debian.
            • mikynog
              Thanks to all your help I ve passed the Debian installation! Answering your questions: - I followed the Wiki as best as I could, including the opening up the
              Message 6 of 12 , Jul 2, 2005
              • 0 Attachment
                Thanks to all your help I've passed the Debian installation!
                Answering your questions:

                - I followed the Wiki as best as I could, including the opening up
                the case steps
                - I did a static IP assignment as you suggested and this worked
                - For editing I used emacs which comes on Knoppix (invoked from
                command line)

                A couple of notes on the Wiki steps:

                1. after the reboot one has to "su" back in to do a "deluser"
                2. it looks like the command should be "passwd <username>" instead of
                "passwd <yournewpassword>"

                Now on to the rest of the steps. Is a 2G main partition enough for
                the OS?

                Thanks again!



                --- In LinkStation_General@yahoogroups.com, "James Stewart"
                <wartstew@y...> wrote:
                > --- In LinkStation_General@yahoogroups.com, "mikynog" <mikynog@y...>
                > wrote:
                >
                > > The switch doles out IP addresses (DHCP). The thing that was odd
                > > was that the LS wasn't showing up as a device on the switch, which
                > > I saw to mean that the LS didn't get an IP address. Is this
                > > remedied by editing these files? Or did I miss something?
                >
                > Yes, the default network config on that Debian system (unless
                > someone has changed it) are these static IP settings:
                >
                > IP address: 192.168.0.100
                > Gateway: 192.168.0.1
                > DNS: 192.168.0.1
                >
                > Your DHCP server didn't register anything because the LS never asked
                > the DHCP server for anything.
                >
                > I don't think that a DHCP client works on this system because of an
                > imcompatibility with the options compiled into the kernel. At least
                > I can't get it to work on mine. I never tried other DHCP clients
                > like "pump" however.
                >
                > So to change the network config of the LS you have to
                > edit /etc/network/interfaces. You will also need to
                > edit /etc/resolve (for DNS settings), and /etc/hosts.allow
                > & /etc/hosts.deny to allow you to log into it.
                >
                > > I don't know how you stay on top of these posts and keep your day
                > > jobs but much thanks :).
                >
                > Well, work is a little slow right now, so you are in luck.
                >
                > > I guess instructions for "how to edit" the settings need to be
                > > added too.
                >
                > That depends on what you used to put the Debian on the LS in the
                > first place. If it was a Linux/Unix type system, use what ever
                > plain text editor that might be on it that you know how to use.
                > They all usually at least have "vi", but it isn't at all new-user
                > friendly. If you used something full featured like a Knoppix CDROM,
                > then you can use "kwrite", "kate", "kedit", "gedit", etc. If you
                > can get into your LS by changing network settings on a computer to
                > be compatible with it, you can edit them from within you LS, it only
                > has "vi" but you can then ftp the "nano" editor that I put in the
                > "files" section of this group if you need something easier to figure
                > out.
                >
                > Now you know why I am very excited about the install procedure that
                > balimbabullabe is working on. It should be much less convoluted if
                > he ever gets the thing to boot.
                >
                > How did you get Debian on your LS? I guess I (or someone)
                > could/should do a revised procedure for the LS-1 that does it using
                > balimbabullabe's partition swapper program, but not debootstrap
                > (like his installer will use) that still uses the Japanese Debian
                > instead. With this procedure, you would copy the Japanese tarball
                > over to the share directory using the Windows sharing-server
                > function of the LS, then telnet into it and unpack it to the root
                > of /mnt. Then copy over the /lib/modules directory to /mnt, then
                > fix up your network setting, and host.allow stuff, then run the
                > partition swapper program and reboot. (Notice the drive never left
                > the LS!), I was just hoping we would have balimbabullabe's version
                > by now because the Japanese Debian uses the ancient "Woody" Debian,
                > which you then normally would want to upgrade to "Sarge" (which can
                > be done with a simple "apt-get dist-upgrade"), which will pretty
                > much replace the whole system with the current Debian.
              • James Stewart
                ... Good. There are probaby 2 dozen editors on Knoppix that would work. I just get the new Knoppix bootable DVD via bittorrent on my LS. (I haven t burned it
                Message 7 of 12 , Jul 3, 2005
                • 0 Attachment
                  --- In LinkStation_General@yahoogroups.com, "mikynog" <mikynog@y...>
                  wrote:
                  >
                  > Thanks to all your help I've passed the Debian installation!
                  > Answering your questions:
                  >
                  > - I followed the Wiki as best as I could, including the opening
                  > up the case steps
                  > - I did a static IP assignment as you suggested and this worked
                  > - For editing I used emacs which comes on Knoppix (invoked from
                  > command line)

                  Good. There are probaby 2 dozen editors on Knoppix that would work.
                  I just get the new Knoppix bootable DVD via bittorrent on my LS. (I
                  haven't burned it yet) I claims to have about 15,000 installed
                  applications on it! (if I read the claims correctly). Imagine how
                  populated the WM menus must be?

                  > A couple of notes on the Wiki steps:
                  >
                  > 1. after the reboot one has to "su" back in to do a "deluser"
                  > 2. it looks like the command should be "passwd <username>" instead
                  > of "passwd <yournewpassword>"

                  Hopefully Wedgemusic can make these corrections.


                  > Now on to the rest of the steps. Is a 2G main partition enough
                  > for the OS?

                  I have lots of stuff installed on mine and yet I've only used 884
                  Megs. I do make extensive use of /dev/hda3 for bulk storage of
                  things (like my Knoppix DVD image, various LS OS images, Web page
                  contents, public FTP area, etc.)

                  > Thanks again!

                  Good to see yet another join the ranks of having a real "manageable"
                  OS installed on their Linkstation.
                • downlalaway
                  I also went through them when I did it -must have missed a few typos too! I ve too got unfeasible amounts of stuff on /dev/hda1 including mailservers, webmail,
                  Message 8 of 12 , Jul 3, 2005
                  • 0 Attachment
                    I also went through them when I did it -must have missed a few typos too!
                    I've too got unfeasible amounts of stuff on /dev/hda1 including
                    mailservers, webmail, printer drivers, logging/graphing stuff
                    (cacti/rrdtool) and haven't got to 1Gb.
                    So guessing that 2G will be all you ever need (unless you wanted to
                    run KDE/gnome -which might be a bit slow...)

                    --- In LinkStation_General@yahoogroups.com, "James Stewart"
                    <wartstew@y...> wrote:
                    > --- In LinkStation_General@yahoogroups.com, "mikynog" <mikynog@y...>
                    > wrote:
                    > >
                    > > Thanks to all your help I've passed the Debian installation!
                    > > Answering your questions:
                    > >
                    > > - I followed the Wiki as best as I could, including the opening
                    > > up the case steps
                    > > - I did a static IP assignment as you suggested and this worked
                    > > - For editing I used emacs which comes on Knoppix (invoked from
                    > > command line)
                    >
                    > Good. There are probaby 2 dozen editors on Knoppix that would work.
                    > I just get the new Knoppix bootable DVD via bittorrent on my LS. (I
                    > haven't burned it yet) I claims to have about 15,000 installed
                    > applications on it! (if I read the claims correctly). Imagine how
                    > populated the WM menus must be?
                    >
                    > > A couple of notes on the Wiki steps:
                    > >
                    > > 1. after the reboot one has to "su" back in to do a "deluser"
                    > > 2. it looks like the command should be "passwd <username>" instead
                    > > of "passwd <yournewpassword>"
                    >
                    > Hopefully Wedgemusic can make these corrections.
                    >
                    >
                    > > Now on to the rest of the steps. Is a 2G main partition enough
                    > > for the OS?
                    >
                    > I have lots of stuff installed on mine and yet I've only used 884
                    > Megs. I do make extensive use of /dev/hda3 for bulk storage of
                    > things (like my Knoppix DVD image, various LS OS images, Web page
                    > contents, public FTP area, etc.)
                    >
                    > > Thanks again!
                    >
                    > Good to see yet another join the ranks of having a real "manageable"
                    > OS installed on their Linkstation.
                  Your message has been successfully submitted and would be delivered to recipients shortly.