Loading ...
Sorry, an error occurred while loading the content.

Re: Cool'n Quiet on LS2 MIPS : query CPU & Test /dev/ttyS0

Expand Messages
  • gouldyis
    uname -n displays: root@LINKSTATION2:~# uname -m mips the other cmd did not flash my led ... ╢Γ═╦╞ⁿ 13:39:00 JST ... I ... model...
    Message 1 of 13 , Jul 2, 2005
    • 0 Attachment
      uname -n displays:

      root@LINKSTATION2:~# uname -m
      mips

      the other cmd did not flash my led



      --- In LinkStation_General@yahoogroups.com, "Frenchy "
      <glasseron@y...> wrote:
      > Outstanding, yes uname does it! Txs for the tip.
      >
      > That is where we get the infamous Linkstation welcome:
      > #990 2004╟» 5╖ε 21╞ⁿ
      ╢Γ═╦╞ⁿ 13:39:00 JST
      >
      >
      > 1- Can someone with a LS2 MIPS run this cmd: uname -m
      > and paste the answer?
      > Is the answer string: "mips"?
      >
      > 2- In anycase on LS1 it is returns "ppc" so I have a way to set my
      > script to be handle LS2.
      >
      > 2- Can someone test this on a LS2: echo -n 'YYYY' >/dev/ttyS0
      > Does this blink your red LED?
      > If so this will stop the blinking: echo -n 'XXXX' >/dev/ttyS0
      > Report back.
      > If nothing happens above, there will be not AutoFan for LS2 unless
      > we find out what serial port the UART is hooked up to.
      > -Sam.
      >
      > --- In LinkStation_General@yahoogroups.com, "prb0x" <al@t...>
      wrote:
      > > --- In LinkStation_General@yahoogroups.com, "Frenchy "
      > > > Do you know the Shell cmd to tell what CPU is on the platform?
      I
      > > > could make the CPU changes automatic by querying the CPU
      model...
      > > >
      > >
      > > Try uname -m
      > >
      > > mips on the LSII (2.05 firmware with busybox)
      > > ppc on the LSI (though that is under gentoo but should be the
      > same as
      > > it's reported from the kernel)
      > >
      > > bash-2.05a# uname -?
      > > #BusyBox v0.60.5 (2004.05.17-01:23+0000) multi-call binary
      > >
      > > Usage: uname [OPTION]...
      > >
      > > Print certain system information. With no OPTION, same as -s.
      > >
      > > Options:
      > > -a print all information
      > > -m the machine (hardware) type
      > > -n print the machine's network node hostname
      > > -r print the operating system release
      > > -s print the operating system name
      > > -p print the host processor type
      > > -v print the operating system version
    • prb0x
      ... Erm that s what I posted before - but I see another users gets it too which is good. ... It works for me. The Disk Full Light (RED) flashes on and off
      Message 2 of 13 , Jul 2, 2005
      • 0 Attachment
        > 1- Can someone with a LS2 MIPS run this cmd: uname -m
        > and paste the answer?
        > Is the answer string: "mips"?
        >

        Erm that's what I posted before - but I see another users gets it too
        which is good.

        > 2- In anycase on LS1 it is returns "ppc" so I have a way to set my
        > script to be handle LS2.
        >
        > 2- Can someone test this on a LS2: echo -n 'YYYY' >/dev/ttyS0
        > Does this blink your red LED?
        > If so this will stop the blinking: echo -n 'XXXX' >/dev/ttyS0
        > Report back.
        > If nothing happens above, there will be not AutoFan for LS2 unless
        > we find out what serial port the UART is hooked up to.

        It works for me. The Disk Full Light (RED) flashes on and off then
        the next command turns it off totally.

        bash-2.05a# uname -a
        Linux LINKY 2.4.20_mipsel_linkstation #79 2004û 8À¯ 16ã³ À¯═╦ã³
        12:56:10 JST mips unknown

        Cheers,
        Al
      • Frenchy
        By the time we get to the bottom of this message we should have the solution for LS2 mips... echo -n YYYY /dev/ttyS0 is case sensitive and spelled with a
        Message 3 of 13 , Jul 2, 2005
        • 0 Attachment
          By the time we get to the bottom of this message we should have the
          solution for LS2 mips...

          echo -n "YYYY" > /dev/ttyS0
          is case sensitive and spelled with a ZERO at the end not letter O.
          Is that what you entered?

          let's take a look at LS2/mips to figure the specific UART port:
          cat /www/script/melsub_init.sh

          Near the top of the above file, LS1/ppc shows:
          ### AVR ###
          echo -n "SSSS" > /dev/ttyS1

          WHAT DO YOU HAVE on LS2/mips after the ">" /???/?????

          AutoFan script update is ready to work on either cpu. Just need the
          correct UART string from LS2 user!
          -Sam.


          --- In LinkStation_General@yahoogroups.com, "gouldyis"
          <gouldyis@y...> wrote:
          > uname -n displays:
          >
          > root@LINKSTATION2:~# uname -m
          > mips
          >
          > the other cmd did not flash my led
          >
          >
          >
          > --- In LinkStation_General@yahoogroups.com, "Frenchy "
          > <glasseron@y...> wrote:
          > > Outstanding, yes uname does it! Txs for the tip.
          > >
          > > That is where we get the infamous Linkstation welcome:
          > > #990 2004╟» 5╖ε 21╞ⁿ
          > ╢Γ═╦╞ⁿ 13:39:00 JST
          > >
          > >
          > > 1- Can someone with a LS2 MIPS run this cmd: uname -m
          > > and paste the answer?
          > > Is the answer string: "mips"?
          > >
          > > 2- In anycase on LS1 it is returns "ppc" so I have a way to set
          my
          > > script to be handle LS2.
          > >
          > > 2- Can someone test this on a LS2: echo -n 'YYYY' >/dev/ttyS0
          > > Does this blink your red LED?
          > > If so this will stop the blinking: echo -n 'XXXX' >/dev/ttyS0
          > > Report back.
          > > If nothing happens above, there will be not AutoFan for LS2
          unless
          > > we find out what serial port the UART is hooked up to.
          > > -Sam.
          > >
          > > --- In LinkStation_General@yahoogroups.com, "prb0x" <al@t...>
          > wrote:
          > > > --- In LinkStation_General@yahoogroups.com, "Frenchy "
          > > > > Do you know the Shell cmd to tell what CPU is on the
          platform?
          > I
          > > > > could make the CPU changes automatic by querying the CPU
          > model...
          > > > >
          > > >
          > > > Try uname -m
          > > >
          > > > mips on the LSII (2.05 firmware with busybox)
          > > > ppc on the LSI (though that is under gentoo but should be the
          > > same as
          > > > it's reported from the kernel)
          > > >
          > > > bash-2.05a# uname -?
          > > > #BusyBox v0.60.5 (2004.05.17-01:23+0000) multi-call binary
          > > >
          > > > Usage: uname [OPTION]...
          > > >
          > > > Print certain system information. With no OPTION, same as -s.
          > > >
          > > > Options:
          > > > -a print all information
          > > > -m the machine (hardware) type
          > > > -n print the machine's network node hostname
          > > > -r print the operating system release
          > > > -s print the operating system name
          > > > -p print the host processor type
          > > > -v print the operating system version
        • Frenchy
          Great so we know we have it. I made the script retrieves the cpu type and sets ittself accordingly. The compatible LS2+LS1 AutoFan version is Rel.3.x.x because
          Message 4 of 13 , Jul 2, 2005
          • 0 Attachment
            Great so we know we have it. I made the script retrieves the cpu
            type and sets ittself accordingly.

            The compatible LS2+LS1 AutoFan version is Rel.3.x.x because 2+1=3!!
            Let me know how that runs for you. Start with the test mode to speed
            things up. Make sure you don't have too many aditional processes
            waking up your disk or it won't stay off during testing or else.
            -Sam.
            --- In LinkStation_General@yahoogroups.com, "prb0x" <al@t...> wrote:
            >
            > > 1- Can someone with a LS2 MIPS run this cmd: uname -m
            > > and paste the answer?
            > > Is the answer string: "mips"?
            > >
            >
            > Erm that's what I posted before - but I see another users gets it
            too
            > which is good.
            >
            > > 2- In anycase on LS1 it is returns "ppc" so I have a way to set
            my
            > > script to be handle LS2.
            > >
            > > 2- Can someone test this on a LS2: echo -n 'YYYY' >/dev/ttyS0
            > > Does this blink your red LED?
            > > If so this will stop the blinking: echo -n 'XXXX' >/dev/ttyS0
            > > Report back.
            > > If nothing happens above, there will be not AutoFan for LS2
            unless
            > > we find out what serial port the UART is hooked up to.
            >
            > It works for me. The Disk Full Light (RED) flashes on and off then
            > the next command turns it off totally.
            >
            > bash-2.05a# uname -a
            > Linux LINKY 2.4.20_mipsel_linkstation #79 2004û 8À¯ 16ã³
            À¯═╦ã³
            > 12:56:10 JST mips unknown
            >
            > Cheers,
            > Al
          • frankusb
            Hi Sam, Ah, I was not aware of that feature as I don t use it, and the way my linkstation keeps time I don t think it would be useful anyway. But, that s the
            Message 5 of 13 , Jul 2, 2005
            • 0 Attachment
              Hi Sam,

              Ah, I was not aware of that feature as I don't use it, and the way
              my linkstation keeps time I don't think it would be useful anyway.
              But, that's the nice part of an open platform, tweak as the user
              sees fit!

              Frank

              --- In LinkStation_General@yahoogroups.com, "Frenchy "
              <glasseron@y...> wrote:
              > Hey Frank,
              >
              > Thank you for you + feadback.
              > I stayed away from using the power LED because it has a different
              > signifaction: LS set to sleep at certain time and wake up.
              > I use that LS feature already so I thought it would be confusing.
              > On the other hand using the red LED (usually signaling bad news)
              is
              > not often used by the LS.
              >
              > Originally I though of a workaround to all this by blinking the
              red
              > LED in a different pattern (ON-OFF-OFF) but that would use more
              CPU
              > when the LS is supposed to be sleeping.
              >
              > So I finally used the red LED as is with the "KISS principle".
              > Anyone is welcome to tweak the LED use. See the AVR info in the
              > script...
              >
              > -Sam
              >
              > How do you modulate the--- In
              > LinkStation_General@yahoogroups.com, "frankusb" <frank.banul@g...>
              > wrote:
              > > Sam,
              > >
              > > Your package rocks. I'm in the same boat, streaming radio to an
              > omnifi
              > > from the Linkstation. I applied your excellent Cool & Quiet
              package
              > > and I really like it. I did tweak it to slowly blink the power
              led
              > > instead of the disk full (red = bad). It turns out that it
              doesn't
              > > blink but modulates so that the power led appears to dim. To me,
              > this
              > > is more appropriate to what's happening anyway, less power is
              being
              > > used so the power led "dims".
              > >
              > > Again, thanks for the excellent script.
              > >
              > > Frank
              > >
              > > --- In LinkStation_General@yahoogroups.com, "Frenchy "
              > > <glasseron@y...> wrote:
              > > > Now that I can see the disk activities (ON/OFF) on the front
              > pannel
              > > > LED, I have realised this morning that while Twonky
              mediaserver
              > 2.8 is
              > > > streaming Net radio, the LS disk stays off and the fan runs
              > silently.
              > > >
              > > > The LS is becoming a real low power, low noise radio system:
              > very
              > > > practical for music fans.
              > > >
              > > > Note that you can't stream MP3 from the disk and expect it to
              > sleep at
              > > > the same time!
              > > > When streaming net radio the disk is alowed to sleep because
              the
              > LS
              > > > really only acts as a proxy server involving only CPU/NIC/RAM.
              > > > -Sam.
            • oseyboldt
              Hi there, I´m really looking forward to a mips-compatible script. So, the answer is: echo -n SSSS $devSERIAL Is that what you need? Regards, Oliver ...
              Message 6 of 13 , Aug 31 12:20 PM
              • 0 Attachment
                Hi there,
                I´m really looking forward to a mips-compatible script. So, the
                answer is:
                echo -n "SSSS" > "$devSERIAL"

                Is that what you need?

                Regards,
                Oliver

                --- In LinkStation_General@yahoogroups.com, "Frenchy "
                <glasseron@y...> wrote:
                > By the time we get to the bottom of this message we should have
                the
                > solution for LS2 mips...
                >
                > echo -n "YYYY" > /dev/ttyS0
                > is case sensitive and spelled with a ZERO at the end not letter O.
                > Is that what you entered?
                >
                > let's take a look at LS2/mips to figure the specific UART port:
                > cat /www/script/melsub_init.sh
                >
                > Near the top of the above file, LS1/ppc shows:
                > ### AVR ###
                > echo -n "SSSS" > /dev/ttyS1
                >
                > WHAT DO YOU HAVE on LS2/mips after the ">" /???/?????
                >
                > AutoFan script update is ready to work on either cpu. Just need
                the
                > correct UART string from LS2 user!
                > -Sam.
                >
                >
                > --- In LinkStation_General@yahoogroups.com, "gouldyis"
                > <gouldyis@y...> wrote:
                > > uname -n displays:
                > >
                > > root@LINKSTATION2:~# uname -m
                > > mips
                > >
                > > the other cmd did not flash my led
                > >
                > >
                > >
                > > --- In LinkStation_General@yahoogroups.com, "Frenchy "
                > > <glasseron@y...> wrote:
                > > > Outstanding, yes uname does it! Txs for the tip.
                > > >
                > > > That is where we get the infamous Linkstation welcome:
                > > > #990 2004╟» 5╖ε 21╞ⁿ
                > > ╢Γ═╦╞ⁿ 13:39:00 JST
                > > >
                > > >
                > > > 1- Can someone with a LS2 MIPS run this cmd: uname -m
                > > > and paste the answer?
                > > > Is the answer string: "mips"?
                > > >
                > > > 2- In anycase on LS1 it is returns "ppc" so I have a way to
                set
                > my
                > > > script to be handle LS2.
                > > >
                > > > 2- Can someone test this on a LS2: echo -n 'YYYY' >/dev/ttyS0
                > > > Does this blink your red LED?
                > > > If so this will stop the blinking: echo -n 'XXXX' >/dev/ttyS0
                > > > Report back.
                > > > If nothing happens above, there will be not AutoFan for LS2
                > unless
                > > > we find out what serial port the UART is hooked up to.
                > > > -Sam.
                > > >
                > > > --- In LinkStation_General@yahoogroups.com, "prb0x" <al@t...>
                > > wrote:
                > > > > --- In LinkStation_General@yahoogroups.com, "Frenchy "
                > > > > > Do you know the Shell cmd to tell what CPU is on the
                > platform?
                > > I
                > > > > > could make the CPU changes automatic by querying the CPU
                > > model...
                > > > > >
                > > > >
                > > > > Try uname -m
                > > > >
                > > > > mips on the LSII (2.05 firmware with busybox)
                > > > > ppc on the LSI (though that is under gentoo but should be
                the
                > > > same as
                > > > > it's reported from the kernel)
                > > > >
                > > > > bash-2.05a# uname -?
                > > > > #BusyBox v0.60.5 (2004.05.17-01:23+0000) multi-call binary
                > > > >
                > > > > Usage: uname [OPTION]...
                > > > >
                > > > > Print certain system information. With no OPTION, same as -
                s.
                > > > >
                > > > > Options:
                > > > > -a print all information
                > > > > -m the machine (hardware) type
                > > > > -n print the machine's network node hostname
                > > > > -r print the operating system release
                > > > > -s print the operating system name
                > > > > -p print the host processor type
                > > > > -v print the operating system version
              Your message has been successfully submitted and would be delivered to recipients shortly.