Loading ...
Sorry, an error occurred while loading the content.

Re: Need help debugging

Expand Messages
  • Marc D. Field
    ... Hi, What did you do to make sure your Perl is up to date? It looks like SlimServer is still looking to perl 5.6.1 instead of perl 5.8.x. Take a look at
    Message 1 of 15 , Jun 29, 2005
    • 0 Attachment
      On 06/27/2005 12:02 PM, gotsprings12 wrote:
      > I had a SLimserver installed on my Kuro a while ago and used the
      > instructions here to get it going. I have not used the box in a while
      > and seem to remember having an issue when I wanted to update slimserver...
      >
      > Anyways.. just tried installing slimserver and made sure that my perl
      > was up to date. Everything seemed find untill I tried...
      > ./slimserver.pl
      >
      > here is the output I got in the shell.
      > Can't locate strict.pm in @INC (@INC contains: /usr/lib/perl/5.6.1
      > /usr.share/perl/5.6.1 /usr/local/lib/perl5.6.1
      > /usr/local/share/perl/5.6.1 /usr/local/share/perl /usr/lib/perl5
      > /usr/share/perl5 /usr/share/perl5 .) at ./slimserver.pl line 15
      > BEGIN failed--complilation aborted at ./slimserver.pl line 15

      Hi,

      What did you do to make sure your Perl is up to date? It looks like
      SlimServer is still looking to perl 5.6.1 instead of perl 5.8.x. Take a
      look at my website (page 3) and follow those instructions to upgrade
      perl (making sure not to skip the step where you move Perl 5.6 out of
      the way): <http://fieldnetworks.com/slim/linkstation.html>.

      Marc
    • wedgemusic
      See www.bittorrent.com first. ... format ... works... ... file ... http://frontalot.is-a-geek.net:81/torrents/ppc-tools-v3.tgz.torrent. ... everything or ...
      Message 2 of 15 , Jun 29, 2005
      • 0 Attachment
        See www.bittorrent.com first.

        --- In LinkStation_General@yahoogroups.com, "gotsprings12"
        <cnichol@r...> wrote:
        > Now we are talking...
        >
        > I downloaded the file... that is not the package. I need to get the
        > package?
        >
        > Once I have the package then I need another set of instructions.
        >
        > I have saved the file to my desktop in suse. copied it to the share on
        > my Kurobox and am stopped there.
        >
        > I guess I need something else to get the package from the torrent?
        > --- In LinkStation_General@yahoogroups.com, "wedgemusic"
        > <wedgemusic@y...> wrote:
        > > First, did you actually download the package or did you just save the
        > > torrent file itself? If you did download the package, did you save it
        > > to your LinkStation or another computer? You need to do the following:
        > >
        > > 1.) Download the package with bittorrent (or any variation of
        > bittorrent).
        > > 2.) If you downloaded the package to anything other than the
        > > LinkStation, move the package to your LinkStation's hda1 root (that is
        > > "/").
        > > 3.) Open up a telnet or SSH session and change to "/" with the command
        > > "cd /".
        > > 4.) Unpack the package with the command "tar -zxvf ppc-tools-v3.tgz".
        > > 5.) Read the README_FIRST.txt. You can open it with pico, nano, vi, or
        > > any other text editor.
        > > 6.) Run the installation script with the command
        > "./ppc-tools-install.sh".
        > >
        > > --- In LinkStation_General@yahoogroups.com, "gotsprings12"
        > > <cnichol@r...> wrote:
        > > > forgive my stupidity...
        > > >
        > > > I am looking at the file that I downloaded and it is not in zip
        format
        > > > and I don't see how or waht to do with it.
        > > >
        > > > Clicking on it asks me what i want to open it with.
        > > >
        > > > I think I am missing a step that needs to be done before this
        works...
        > > >
        > > > Please a step by step on what to do or how to get to the read me
        file
        > > > is what I really need... :(
        > > >
        > > >
        > > > --- In LinkStation_General@yahoogroups.com, "wedgemusic"
        > > > <wedgemusic@y...> wrote:
        > > > > Read the README_FIRST.txt file; it includes all the directions you
        > > need.
        > > > >
        > > > > --- In LinkStation_General@yahoogroups.com, "gotsprings12"
        > > > > <cnichol@r...> wrote:
        > > > > > I guess i need some more direction. I have the file. But I don't
        > > know
        > > > > > what to do with it.
        > > > > >
        > > > > > I am about one or 2 steps up from a newbie when it comes to
        > > linux and
        > > > > > unix. I have been running SuSE 9.2 at home (Thanks to all the
        > time I
        > > > > > spent with the Kuro I had some clue when I started with SuSE.)
        > > > > >
        > > > > > I guess could I get some more specific directions on what to
        > do with
        > > > > > teh files like how to install them and some idea as to what
        > they are
        > > > > > doing as the install?
        > > > > >
        > > > > > Thanks again for all the help.
        > > > > >
        > > > > > >
        > > http://frontalot.is-a-geek.net:81/torrents/ppc-tools-v3.tgz.torrent
        > > > > > >
        > > > > > > --- In LinkStation_General@yahoogroups.com, "gotsprings12"
        > > > > > > <cnichol@r...> wrote:
        > > > > > > > All i get is a 404 when I follow the link... :(
        > > > > > > >
        > > > > > > > --- In LinkStation_General@yahoogroups.com, "wedgemusic"
        > > > > > > > <wedgemusic@y...> wrote:
        > > > > > > > > Just install the ppc-tools package from
        > > > > > > > >
        > > > >
        http://frontalot.is-a-geek.net:81/torrents/ppc-tools-v3.tgz.torrent.
        > > > > > > > > This version has an installation script that will take
        > care of
        > > > > > > > > everything for you. You can choose to install
        everything or
        > > > if you
        > > > > > > > > only need/want perl, select to install packages
        > > individually and
        > > > > > skip
        > > > > > > > > everything but perl. Please read the README_FIRST.txt file
        > > > > > first. Post
        > > > > > > > > back here with your results please.
        > > > > > > > >
        > > > > > > > > --- In LinkStation_General@yahoogroups.com, "gotsprings12"
        > > > > > > > > <cnichol@r...> wrote:
        > > > > > > > > > Any hints on how to install strict.pm... get
        > strict.pm... or
        > > > > > > where to
        > > > > > > > > > put it?
        > > > > > > > > >
        > > > > > > > > > Thanks
        > > > > > > > > > --- In LinkStation_General@yahoogroups.com, "wedgemusic"
        > > > > > > > > > <wedgemusic@y...> wrote:
        > > > > > > > > > > You're missing strict.pm, which is part of the
        > perl-base.
        > > > > > You can
        > > > > > > > > > > either fix perl yourself or install the ppc-tools
        > package
        > > > > > from the
        > > > > > > > > > > LinkStationWiki.
        > > > > > > > > > >
        > > > > > > > > > > --- In LinkStation_General@yahoogroups.com,
        > "gotsprings12"
        > > > > > > > > > > <cnichol@r...> wrote:
        > > > > > > > > > > > I had a SLimserver installed on my Kuro a while
        > ago and
        > > > > > used the
        > > > > > > > > > > > instructions here to get it going. I have not used
        > > the box
        > > > > > in a
        > > > > > > > > while
        > > > > > > > > > > > and seem to remember having an issue when I
        wanted to
        > > > update
        > > > > > > > > > > slimserver...
        > > > > > > > > > > >
        > > > > > > > > > > > Anyways.. just tried installing slimserver and
        > made sure
        > > > > > that my
        > > > > > > > > perl
        > > > > > > > > > > > was up to date. Everything seemed find untill I
        > tried...
        > > > > > > > > > > > ./slimserver.pl
        > > > > > > > > > > >
        > > > > > > > > > > > here is the output I got in the shell.
        > > > > > > > > > > > Can't locate strict.pm in @INC (@INC contains:
        > > > > > > /usr/lib/perl/5.6.1
        > > > > > > > > > > > /usr.share/perl/5.6.1 /usr/local/lib/perl5.6.1
        > > > > > > > > > > > /usr/local/share/perl/5.6.1 /usr/local/share/perl
        > > > > > /usr/lib/perl5
        > > > > > > > > > > > /usr/share/perl5 /usr/share/perl5 .) at
        > ./slimserver.pl
        > > > > > line 15
        > > > > > > > > > > > BEGIN failed--complilation aborted at
        ./slimserver.pl
        > > > > line 15
        > > > > > > > > > > >
        > > > > > > > > > > > Any help would be great.
        > > > > > > > > > > >
        > > > > > > > > > > > Thanks one and all...
      Your message has been successfully submitted and would be delivered to recipients shortly.