Loading ...
Sorry, an error occurred while loading the content.

Apache 1.3.33 + PHP 5.0.4 Working !

Expand Messages
  • Phillip Ward
    This procedure seems to work, although only tested so far with a hello world script, and no MySql support. Compile Apache with DSO support In Apache src
    Message 1 of 1 , Apr 5, 2005
    • 0 Attachment
      This procedure seems to work, although only tested so far with a hello world script, and
      no MySql support.

      Compile Apache with DSO support
      In Apache src directory (apache_1.3.33)
      # ./configure --prefix=/usr/local/apache \
          --enable-module=so

      # make
      # make install

      Install PHP as a Module
      In PHP src directory (php_5.0.4)
      # cd Zend
      # vi zend.c
      search and replace `usr_copy=args;" with memcpy(usr_copy,
      args, sizeof(va_list));"

      # ./configure --disable-libxml\
          --enable-track-vars \
          --with-apxs=/usr/local/apache/bin/apxs

      # make
      # make install

      # cp php.ini-dist /usr/local/lib/php.ini

      You must also edit the httpd.conf file which is located in
      /usr/local/apache/conf and add
      the following lines:
      #
      # This will load the PHP module into Apache. Put this line with other
      LoadModule lines.
      #
      LoadModule php5_module libexec/libphp5.so

      Note. The above line is usually already their

      #
      # This next section will add a handler for .php files, put it with
      other IfModule lines.
      #
      <IfModule mod_php5.c>
      AddType application/x-httpd-php .php
      AddType application/x-httpd-php .phtml
      AddType application/x-httpd-php-source .phps
      </IfModule>

      Autostart Apache Script
      create the following script
      # cd /usr/local/apache
      # vi start-apache.sh

      #!/bin/bash
      /usr/local/apache/bin/apachectl start

      make it runable
      # chmod +x start-apache.sh

      create a link
      # cd /etc/rc.d/rc2.d
      # ln -s /usr/local/apache/start-apache.sh S80StartApache

      # reboot

      Worked for me :-)

      Regards

      Phill
    Your message has been successfully submitted and would be delivered to recipients shortly.