Loading ...
Sorry, an error occurred while loading the content.

Re: Apache Server on LinkStation

Expand Messages
  • onurd
    I ve successfully installed Apache 2.53 but I didn t have any luck installing PHP. I ve tried PHP 4.3 and 5.0.3 and no luck. Did you sucessfully install php?
    Message 1 of 16 , Mar 25, 2005
    • 0 Attachment
      I've successfully installed Apache 2.53 but I didn't have any luck
      installing PHP. I've tried PHP 4.3 and 5.0.3 and no luck. Did you
      sucessfully install php?

      --- In LinkStation_General@yahoogroups.com, "downieabz"
      <ian.downie@t...> wrote:
      >
      > I've just gone through a very steep learning curve and have
      > successfully compiled and installed a basic Apache 1.3 web server
      on
      > my LinkStation. I don't think anyone else has posted anything about
      > this - I found one message early on saying that someone had
      > successfully installed Apache 2 but it didn't give any
      instructions.
      >
      > I got my LinkStation as a Christmas present from my wife (I did
      give
      > her some assistance in identifying a suitable present) and want to
      use
      > it as a low power, always on, web server for my family history
      website
      > (low traffic volume via ADSL). The site is live on my home network
      > right now.
      >
      > I've documented most of the process but it is a bit verbose
      because it
      > includes all my mistakes. These have been caused partly by my own
      > ignorance and partly by following instructions (some in this
      > discussion group) which are missing essential steps or informaiton.
      > These things are probably completely obvious to a Linux expert but
      not
      > to someone whose last attempt at compiling anything was an 8086
      > assembly language program in 1984.
      >
      > The actual compilation and installation of Apache was easy - it was
      > all the stuff I needed to do first which caused all the trouble.
      This
      > stuff will be needed by anyone who wants to install anything.
      >
      > Two things that stand out are the need to update grep from 2.4.2 to
      > 2.5 as there is a bug in the default 2.4.2 which breaks the PHP
      > installer (I've not reached that point yet) and which may affect
      the
      > Apache install; and the need to run Apache on another port apart
      from
      > the default 80, which is used by the LinkStation's internal web
      server
      > for the Admin interface. I'm glad to be able to report that running
      > Apache on port 81 does not interfere with the Admin server.
      >
      > Anyway, if anyone is interested in doing the same thing, I'm
      willing
      > to share my documentation in return for some proofreading. I'd
      also be
      > very happy for someone with more Unix/Linux experience to have a
      look
      > at it in case I have made any stupid mistakes. Once I've tidied it
      up,
      > I will post it in the How To section.
      >
      > Cheers
      >
      > Ian in Aberdeen, Scotland
    • downieabz
      To be honest, I got only a couple of responses to that post, both from novices. There has been another post suggesting that installing PHP slows the LS down to
      Message 2 of 16 , Mar 26, 2005
      • 0 Attachment
        To be honest, I got only a couple of responses to that post, both from
        novices. There has been another post suggesting that installing PHP
        slows the LS down to a crawl because of the restricted RAM so I have
        not gone through that. I discovered I had compiled Apache without DSO
        support so would need to recompile it to allow me to add PHP, but I'm
        not sure whether that applies with Apache 2.

        You can read the state of play here: http://www.downieabz.com/Apache/
        - that's my LinkStation - but I have been too busy at work to do any
        more with the LinkStation for a couple of months.

        By the way, the server had been up continuously from 16 January until
        yesterday, when I had to cut the power to everything in order to shut
        down my Windows XP box, so the LinkStation appears quite happy as a
        (very) low volume web server.

        I'm still interested in constructive feedback from anyone who knows
        what they are doing ....

        Ian

        --- In LinkStation_General@yahoogroups.com, "onurd" <onurd@y...>
        wrote:
        >
        > I've successfully installed Apache 2.53 but I didn't have any luck
        > installing PHP. I've tried PHP 4.3 and 5.0.3 and no luck. Did you
        > sucessfully install php?
        >
        > --- In LinkStation_General@yahoogroups.com, "downieabz"
        > <ian.downie@t...> wrote:
        > >
        > > I've just gone through a very steep learning curve and have
        > > successfully compiled and installed a basic Apache 1.3 web server
        > on
        > > my LinkStation. I don't think anyone else has posted anything
        about
        > > this - I found one message early on saying that someone had
        > > successfully installed Apache 2 but it didn't give any
        > instructions.
        > >
        .......
        > > Anyway, if anyone is interested in doing the same thing, I'm
        > willing
        > > to share my documentation in return for some proofreading. I'd
        > also be
        > > very happy for someone with more Unix/Linux experience to have a
        > look
        > > at it in case I have made any stupid mistakes. Once I've tidied
        it
        > up,
        > > I will post it in the How To section.
        > >
        > > Cheers
        > >
        > > Ian in Aberdeen, Scotland
      • ardper
        Do you really think that the LinkStation will not be able to cope with PHP? I did a lot of research on both the Linkstation and the NSLU2 before I bought my
        Message 3 of 16 , Mar 28, 2005
        • 0 Attachment
          Do you really think that the LinkStation will not be able to cope with
          PHP?

          I did a lot of research on both the Linkstation and the NSLU2 before I
          bought my Linkstation last week... I originally liked the NSLU2
          because the hacking community is well developed. But the Linkstation
          is so easy to get going with - and has twice the memory.

          Anyway, it is possible to run Apache, and PHP on the NSLU2.

          More to the point, besides streaming music to a UPnP player, I wanted
          the Linkstation to host all of my photos, and serve them to client PCs.

          The software I am considering is called "Gallery" and requires Apache,
          and PHP.

          The software works on a NSLU2 - so surely will work on a Linkstation?!!

          I will let you know if I get it working; at present i am trying to
          choose between Gallery (which requires PHP) and IDS (which is Perl
          based)...

          (See this link)
          http://gallery.menalto.com/index.php?name=PNphpBB2&file=viewtopic&t=26692&highlight=nslu2&sid=8805fd7143539e0fa868440059fe8ad7

          Is there any reason why the Linkstation should not be able to cope
          with this when the NSLU2 can?

          As an aside, thanks to all you guys for your help and advice. I got
          a Linkstation from EBuyer in the UK for £130 and its great..! I have
          NFS and Twonkyvision running at the moment, networked to my MEPIS
          Linux Laptop and PC, all works like a dream!

          Am really getting into this Linux stuff and can't wait to say goodbye
          to Windows... but my missus insists on using "Word" despite OpenOffice
          being just as good, so will have to live with a Windows parition for a
          while longer yet...

          All the best


          Adam.




          --- In LinkStation_General@yahoogroups.com, "downieabz"
          <ian.downie@t...> wrote:
          >
          > To be honest, I got only a couple of responses to that post, both from
          > novices. There has been another post suggesting that installing PHP
          > slows the LS down to a crawl because of the restricted RAM so I have
          > not gone through that. I discovered I had compiled Apache without DSO
          > support so would need to recompile it to allow me to add PHP, but I'm
          > not sure whether that applies with Apache 2.
          >
          > You can read the state of play here: http://www.downieabz.com/Apache/
          > - that's my LinkStation - but I have been too busy at work to do any
          > more with the LinkStation for a couple of months.
          >
          > By the way, the server had been up continuously from 16 January until
          > yesterday, when I had to cut the power to everything in order to shut
          > down my Windows XP box, so the LinkStation appears quite happy as a
          > (very) low volume web server.
          >
          > I'm still interested in constructive feedback from anyone who knows
          > what they are doing ....
          >
          > Ian
          >
          > --- In LinkStation_General@yahoogroups.com, "onurd" <onurd@y...>
          > wrote:
          > >
          > > I've successfully installed Apache 2.53 but I didn't have any luck
          > > installing PHP. I've tried PHP 4.3 and 5.0.3 and no luck. Did you
          > > sucessfully install php?
          > >
          > > --- In LinkStation_General@yahoogroups.com, "downieabz"
          > > <ian.downie@t...> wrote:
          > > >
          > > > I've just gone through a very steep learning curve and have
          > > > successfully compiled and installed a basic Apache 1.3 web server
          > > on
          > > > my LinkStation. I don't think anyone else has posted anything
          > about
          > > > this - I found one message early on saying that someone had
          > > > successfully installed Apache 2 but it didn't give any
          > > instructions.
          > > >
          > .......
          > > > Anyway, if anyone is interested in doing the same thing, I'm
          > > willing
          > > > to share my documentation in return for some proofreading. I'd
          > > also be
          > > > very happy for someone with more Unix/Linux experience to have a
          > > look
          > > > at it in case I have made any stupid mistakes. Once I've tidied
          > it
          > > up,
          > > > I will post it in the How To section.
          > > >
          > > > Cheers
          > > >
          > > > Ian in Aberdeen, Scotland
        • Nat Fairbanks
          I m running gallery on my linkstation, but I m using lighttpd and fastcgi php rather than apache with the php module. Don t forget you also need mysql, and
          Message 4 of 16 , Mar 29, 2005
          • 0 Attachment
            I'm running gallery on my linkstation, but I'm using lighttpd and
            fastcgi php rather than apache with the php module. Don't forget you
            also need mysql, and that could use some optimizations as well.
            Apache and the stock MySQL ran on my linkstation, but there was too
            much swapping when you added Samba, bittornado, tinyproxy and other
            services. You can check out the gallery running on my Linkstation
            (turned into a Kurobox running gentoo actually) at
            http://www.natfairbanks.com/gallery/

            -Nat
          • Frenchy
            Two thumbs up Nat! Your gallery is slick with php. You most likely have the most loaded LStation now. You managed to max out the 64MB RAM (swapping). Are these
            Message 5 of 16 , Mar 30, 2005
            • 0 Attachment
              Two thumbs up Nat! Your gallery is slick with php.

              You most likely have the most loaded LStation now. You managed to max
              out the 64MB RAM (swapping). Are these tools memory hogs /CPU
              intensive?

              (I have been in Fairbanks once during November... I won't forget how
              fast and skillfuly people can drive on ice with no spikes. All the
              cars in the parking lot with engine runing while at the movies or
              shopping.)

              I am curious as to how you protect your server from internet
              intrusions /destruction?

              What firewall solution do you use? (Tiny_Proxy is not a FW.)

              Sam.
              --- In LinkStation_General@yahoogroups.com, Nat Fairbanks
              <Fairbanks@a...> wrote:
              > I'm running gallery on my linkstation, but I'm using lighttpd and
              > fastcgi php rather than apache with the php module. Don't forget you
              > also need mysql, and that could use some optimizations as well.
              > Apache and the stock MySQL ran on my linkstation, but there was too
              > much swapping when you added Samba, bittornado, tinyproxy and other
              > services. You can check out the gallery running on my Linkstation
              > (turned into a Kurobox running gentoo actually) at
              > http://www.natfairbanks.com/gallery/
              >
              > -Nat
            • ardper
              Thankyou for your reply. I have read through all the posts on this forum and yes, lighttpd looks like a better solution than Apache. I wasn t aware of
              Message 6 of 16 , Mar 30, 2005
              • 0 Attachment
                Thankyou for your reply.

                I have read through all the posts on this forum and yes, lighttpd
                looks like a better solution than Apache. I wasn't aware of fastcgi,
                so thanks for the tip!

                The reason I am considering Gallery is that I store all of my digital
                photographs on my Linkstation and I would like a quick/easy way to
                browse thumbnails, over my home (Wifi) LAN.

                An alternative product I am considering is IDS.
                [ http://ids.sourceforge.net/ ]

                IDS looks like it just needs Perl and a webserver (such as lighttpd)

                I'll let you know how I get on...!

                Regards


                Adam.



                --- In LinkStation_General@yahoogroups.com, Nat Fairbanks
                <Fairbanks@a...> wrote:
                > I'm running gallery on my linkstation, but I'm using lighttpd and
                > fastcgi php rather than apache with the php module. Don't forget
                you
                > also need mysql, and that could use some optimizations as well.
                > Apache and the stock MySQL ran on my linkstation, but there was too
                > much swapping when you added Samba, bittornado, tinyproxy and other
                > services. You can check out the gallery running on my Linkstation
                > (turned into a Kurobox running gentoo actually) at
                > http://www.natfairbanks.com/gallery/
                >
                > -Nat
              • natfairbanks
                I m running my linkstation behind a hardware firewall/router (linksys wrt54g) with port forwarding set up. I also use nmap to double check that the settings
                Message 7 of 16 , Mar 30, 2005
                • 0 Attachment
                  I'm running my linkstation behind a hardware firewall/router (linksys
                  wrt54g) with port forwarding set up. I also use nmap to double check
                  that the settings only open the ports I want to the network I want.
                  I'm sure there are others with fairly loaded linkstation/kurobox
                  setups, the forums and wiki at
                  http://www.kurobox.com/forums/ and
                  http://www.kurobox.com/online/tiki-index.php have been very helpful.
                  Thanks for the comments on the gallery, it's a stock install of the
                  http://gallery.menalto.com/ software.

                  The most memory intensive tools have been MySQL and Apache, although
                  other software that runs multiple instances have to be configured to
                  run fewer instances as well. Set the number of spare servers and max
                  servers down fairly now, don't compile in features you don't need and
                  everything should work fine. The way my system is set up now I
                  haven't noticed any swapping, there's usually 8-16MB of free ram.

                  I haven't been to Fairbanks, Alaska, but I'm in New Hampshire, which
                  does get plenty of ice and snow. Not as bad as Alaska I guess, since
                  there are only a couple of days a year you'd leave your car running.

                  -Nat

                  --- In LinkStation_General@yahoogroups.com, "Frenchy "
                  <glasseron@y...> wrote:
                  >
                  > Two thumbs up Nat! Your gallery is slick with php.
                  >
                  > You most likely have the most loaded LStation now. You managed to max
                  > out the 64MB RAM (swapping). Are these tools memory hogs /CPU
                  > intensive?
                  >
                  > (I have been in Fairbanks once during November... I won't forget how
                  > fast and skillfuly people can drive on ice with no spikes. All the
                  > cars in the parking lot with engine runing while at the movies or
                  > shopping.)
                  >
                  > I am curious as to how you protect your server from internet
                  > intrusions /destruction?
                  >
                  > What firewall solution do you use? (Tiny_Proxy is not a FW.)
                  >
                  > Sam.
                Your message has been successfully submitted and would be delivered to recipients shortly.