Loading ...
Sorry, an error occurred while loading the content.

More Netatalk Problems

Expand Messages
  • vanyaedwards
    With the help of Marc s fix of the configuration script bug, I got through the configuration - it found the BerkeleyDB.4.3 libraries. However, when making I
    Message 1 of 2 , Mar 13, 2005
    • 0 Attachment
      With the help of Marc's fix of the configuration script bug, I got through the
      configuration - it found the BerkeleyDB.4.3 libraries. However, when making I got the
      following error:

      Making all in cnid
      make[3]: Entering directory `/mnt/opt/netatalk-2.0.2/bin/cnid'
      source='cnid_index.c' object='cnid_index.o' libtool=no \
      depfile='.deps/cnid_index.Po' tmpdepfile='.deps/cnid_index.TPo' \
      depmode=gcc /bin/sh ../../depcomp \
      gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../include -g -O2 -I../../sys -I/usr/local/
      BerkeleyDB.4.3//include/ -c `test -f 'cnid_index.c' || echo './'`cnid_index.c
      cnid_index.c: In function `dbif_count':
      cnid_index.c:277: warning: passing arg 2 of pointer to function from incompatible
      pointer type
      cnid_index.c:277: too few arguments to function
      make[3]: *** [cnid_index.o] Error 1
      make[3]: Leaving directory `/mnt/opt/netatalk-2.0.2/bin/cnid'
      make[2]: *** [all-recursive] Error 1
      make[2]: Leaving directory `/mnt/opt/netatalk-2.0.2/bin'
      make[1]: *** [all-recursive] Error 1
      make[1]: Leaving directory `/mnt/opt/netatalk-2.0.2'
      make: *** [all] Error 2

      This is a similar error encountered by others previously but occuring in a different
      directory. Will Marc's suggested libtools modification (replacing SED="" with SED="/
      bin/sed") and rerunning the configuration work for this? Unfortunately, I don't know
      what any of this means.

      TIA,
      Vanya
    • Marc Bizer
      ... Have you downloaded the very latest set of instructions (posted last week) and followed them carefully? --Marc
      Message 2 of 2 , Mar 13, 2005
      • 0 Attachment
        On 3/13/05 at 4:36 PM +0000, vanyaedwards wrote:
        >With the help of Marc's fix of the configuration script bug, I got
        >through the configuration - it found the BerkeleyDB.4.3 libraries.
        >However, when making I got the following error:

        Have you downloaded the very latest set of instructions (posted last
        week) and followed them carefully?

        --Marc
      Your message has been successfully submitted and would be delivered to recipients shortly.