Loading ...
Sorry, an error occurred while loading the content.

Re: Foreign language support

Expand Messages
  • kykpeng
    Hi beefdotcom, I just upgraded my firmware to 1.45_13 and it now includes support for a large number of languages (codepages). I can now save in some Chinese
    Message 1 of 5 , Mar 4, 2005
    • 0 Attachment
      Hi beefdotcom,

      I just upgraded my firmware to 1.45_13 and it now includes support
      for a large number of languages (codepages). I can now save in some
      Chinese filenames that I couldn't before with firmware 1.43, although
      I have not tested it fully.

      We should be careful though. The Buffalo Taiwan's website said non-
      English filenames are strongly discouraged as they may cause damages,
      and another major website said Linux 2.4's support for the NTFS
      filesystem (which is used in Linkstation) for the write operation in
      Asian characters is highly unreliable. I'm not a Linux expert, but
      be sure to know what you are doing.

      Also, I have a HD-H120LAN. There are a lot of problems reported with
      firmware upgrading on certain machines, be very careful.

      I don't know where I got ver. 1.45, but the filename is
      fw_up145_13.zip

      For the rest of you looking for firmware 1.44, Buffalo China has a
      ver 1.44_14.

      My next project ... hopefully get this thing to work with my USB
      printer / scanner. Is it possible?!



      --- In LinkStation_General@yahoogroups.com, "beefdotcom"
      <beefdotcom@y...> wrote:
      >
      > I just called up Buffalo tech support asking about store filenames
      > with Asian characters. The first thing they said was, "We don't
      > support that foreign language". I was like damn, spent almost $300
      on
      > this device and doesn't have this basic support. They said that
      they
      > have a version of the LS just for the Asian market, but the problem
      is
      > I already have the North America version and I'm stuck with this.
      I
      > must have this support for all my multimedia files. So I'm wonder
      if
      > any linux expert here can help me hack the LS and add foreign
      support
      > into the linux the LS uses. Let me know what i can do and my
      options.
      > thanks
    • irvine_stock
      The LinkStation does not use the NTFS filesystem! It uses a Linux filesystem known as Third Extended filesystem (ext3). Nearly every Linux system uses this
      Message 2 of 5 , Mar 4, 2005
      • 0 Attachment
        The LinkStation does not use the NTFS filesystem! It uses a Linux
        filesystem known as Third Extended filesystem (ext3). Nearly every
        Linux system uses this journaled version. Its quick, defragments
        itself, and can recover from an abrupt system reboot or power fail
        quicker and with less pain than most other filesystems. You must
        have got that impression because Windose says so.
        The Samba used to connect the Windose network to the Linux will
        cause it to show NTFS on the windose side.
        The 1.46_10 firmware can be hacked and upgraded to support TELNET
        too. You just have to know how. Three files are missing. If you
        can't figure out how to do it from reading other posts here, let us
        know and we will repost the steps.
        Your device should support printing right out of the box for USB
        printers. Only MAC's sometimes have issues on the LinkStation since
        they require postscript info on the printer you choose.
        Rich
        --- In LinkStation_General@yahoogroups.com, "kykpeng" <kykpeng@y...>
        wrote:
        >
        > Hi beefdotcom,
        >
        > I just upgraded my firmware to 1.45_13 and it now includes support
        > for a large number of languages (codepages). I can now save in
        some
        > Chinese filenames that I couldn't before with firmware 1.43,
        although
        > I have not tested it fully.
        >
        > We should be careful though. The Buffalo Taiwan's website said
        non-
        > English filenames are strongly discouraged as they may cause
        damages,
        > and another major website said Linux 2.4's support for the NTFS
        > filesystem (which is used in Linkstation) for the write operation
        in
        > Asian characters is highly unreliable. I'm not a Linux expert,
        but
        > be sure to know what you are doing.
        >
        > Also, I have a HD-H120LAN. There are a lot of problems reported
        with
        > firmware upgrading on certain machines, be very careful.
        >
        > I don't know where I got ver. 1.45, but the filename is
        > fw_up145_13.zip
        >
        > For the rest of you looking for firmware 1.44, Buffalo China has a
        > ver 1.44_14.
        >
        > My next project ... hopefully get this thing to work with my USB
        > printer / scanner. Is it possible?!
        >
        >
        >
        > --- In LinkStation_General@yahoogroups.com, "beefdotcom"
        > <beefdotcom@y...> wrote:
        > >
        > > I just called up Buffalo tech support asking about store
        filenames
        > > with Asian characters. The first thing they said was, "We don't
        > > support that foreign language". I was like damn, spent almost
        $300
        > on
        > > this device and doesn't have this basic support. They said that
        > they
        > > have a version of the LS just for the Asian market, but the
        problem
        > is
        > > I already have the North America version and I'm stuck with
        this.
        > I
        > > must have this support for all my multimedia files. So I'm
        wonder
        > if
        > > any linux expert here can help me hack the LS and add foreign
        > support
        > > into the linux the LS uses. Let me know what i can do and my
        > options.
        > > thanks
      • kykpeng
        Okay, as I have demonstrated in my earlier post, I m a complete Linux rookie. It took me about 3 hours to figure out how to use vi , had to find a different
        Message 3 of 5 , Mar 4, 2005
        • 0 Attachment
          Okay, as I have demonstrated in my earlier post, I'm a complete Linux
          rookie. It took me about 3 hours to figure out how to use "vi", had
          to find a different Telnet client than that bundled with WinXP. I
          have finally been able to gain root access (thanks mfield3 on that
          detailed SlimServer tutorial!).

          But I'm wondering if anyone has attempted installing a USB multi-
          function (i.e. printer+scanner) device? I have an HP PSC1210,
          apparently a Linux driver exists at http://hpoj.sourceforge.net/ ...
          but it doesn't look like I can just double-click a "setup.exe" file =)

          Cheers -
        • Paul Milligan (home)
          What you are trying to do is seriously non-trivial . i.e. it almost certainly can be done but anything less than 2 or 3 snags along the way would be a
          Message 4 of 5 , Mar 7, 2005
          • 0 Attachment
            What you are trying to do is "seriously non-trivial". i.e. it almost certainly can be done but anything less than 2 or 3 snags along the way would be a miracle. There is also a bigger issue to answer, how do you plan to access the scanner? The software you are looking at would allow a Linux application running on the Linkstation to scan, but it would not make the scanner available as a network device. This would almost certainly not achieve what I suspect you want to do.

            If all you need is to print then I believe there is a cups driver, which should work, but that setup is outside the scope of the basic Linkstation.

            There has not been much successful correspondence on printers in this forum. I'm planning to setup a CUPS printer on my Linkstation in a week or two. If I succeed, and no-one else beats me to it,  I'll post the results.

            Regards


            kykpeng wrote:

            Okay, as I have demonstrated in my earlier post, I'm a complete Linux
            rookie.  It took me about 3 hours to figure out how to use "vi", had
            to find a different Telnet client than that bundled with WinXP.  I
            have finally been able to gain root access (thanks mfield3 on that
            detailed SlimServer tutorial!).

            But I'm wondering if anyone has attempted installing a USB multi-
            function (i.e. printer+scanner) device?  I have an HP PSC1210,
            apparently a Linux driver exists at http://hpoj.sourceforge.net/ ...
            but it doesn't look like I can just double-click a "setup.exe" file =)

            Cheers -




          Your message has been successfully submitted and would be delivered to recipients shortly.