Loading ...
Sorry, an error occurred while loading the content.
 

Re: USB storage slowed down on purpose?

Expand Messages
  • tad94564
    It s probably still in there if your kernel is based on the HD-LAN_GPL source. I ve recieved word this fix will be in the next firmware release, which is
    Message 1 of 12 , Oct 29, 2004
      It's probably still in there if your kernel is based on the
      HD-LAN_GPL source.

      I've recieved word this fix will be in the next firmware release,
      which is supposed to be RSN.

      thomas

      --- In LinkStation_General@yahoogroups.com, Rick Flower <rickf@c...>
      wrote:
      >
      > I've already done this on my updated kernel with no ill effects
      yet..
      > Of course, I've not actually tried using the USB yet, so I can't
      really
      > vouch for whether or not my changes solve the problem or not.
      >
      > -- Rick
      >
      >
      > On Fri, 29 Oct 2004, tad94564 wrote:
      >
      > >
      > >
      > > --- In LinkStation_General@yahoogroups.com, "dtaub001"
      <taubert@g...>
      > > wrote:
      > > >
      > > >
      > > > I was moving some big files to an external 250GB drive
      yesterday,
      > > and
      > > > noticed that klogd and syslogd were taking up a fair amount of
      cpu
      > > > (40-ish percent).
      > > >
      > > > It looks like some debug messages were left in or put into the
      > > > usb-storage driver. A "cat /proc/kmsg" will produce a flood
      of
      > > output
      > > > while the external device is being accessed (something about
      > > "switchin").
      > > >
      > > > This driver is compiled into the kernel (not loadable), so
      I'll see
      > > if
      > > > I can get a new kernel compiled with the kurobox tools...
      > > >
      > >
      > > After suffering from this problem last night, I found one
      possible
      > > cause of the poor performance. There may be more, but this one
      is
      > > HUGE. Too bad just compiling a new kernel will not fix this
      problem.
      > > Someone added a hardcoded printk to the usb-storage subsystem
      that is
      > > not in the kernel-2.4 sources I have.
      > >
      > > Setting /proc/sys/kernel/printk to a higher value doesn't stop
      it
      > > either.
      > >
      > > To fix this, you have to get the HD-LAN_GPL source, along with
      > > installation of the kuro box stuff, break apart the zip file,
      untar
      > > the kernel source, goto drivers/usb/storage, edit the file
      > > transport.c (do a search for 'task-switch', around line 531 in
      my
      > > sources), and DELETE that line, build a new kernel/ramdisk, and
      then
      > > install.. and pray that it comes back.
      > >
      > > thomas
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > >
      > > Yahoo! Groups Links
      > >
      > >
      > >
      > >
      > >
      > >
      > >
    • James Ronald
      What does RSN stand for?
      Message 2 of 12 , Oct 29, 2004
        What does RSN stand for?

        >
        >
        > It's probably still in there if your kernel is
        > based on the
        > HD-LAN_GPL source.
        >
        > I've recieved word this fix will be in the next
        > firmware release,
        > which is supposed to be RSN.
        >
        > thomas
        >
        > --- In LinkStation_General@yahoogroups.com, Rick
        > Flower <rickf@c...>
        > wrote:
        >>
        >> I've already done this on my updated kernel
        >> with no ill effects
        > yet..
        >> Of course, I've not actually tried using the
        >> USB yet, so I can't
        > really
        >> vouch for whether or not my changes solve the
        >> problem or not.
        >>
        >> -- Rick
        >>
        >>
        >> On Fri, 29 Oct 2004, tad94564 wrote:
        >>
        >> >
        >> >
        >> > --- In LinkStation_General@yahoogroups.com,
        >> > "dtaub001"
        > <taubert@g...>
        >> > wrote:
        >> > >
        >> > >
        >> > > I was moving some big files to an external
        >> > > 250GB drive
        > yesterday,
        >> > and
        >> > > noticed that klogd and syslogd were taking
        >> > > up a fair amount of
        > cpu
        >> > > (40-ish percent).
        >> > >
        >> > > It looks like some debug messages were left
        >> > > in or put into the
        >> > > usb-storage driver. A "cat /proc/kmsg"
        >> > > will produce a flood
        > of
        >> > output
        >> > > while the external device is being accessed
        >> > > (something about
        >> > "switchin").
        >> > >
        >> > > This driver is compiled into the kernel
        >> > > (not loadable), so
        > I'll see
        >> > if
        >> > > I can get a new kernel compiled with the
        >> > > kurobox tools...
        >> > >
        >> >
        >> > After suffering from this problem last night,
        >> > I found one
        > possible
        >> > cause of the poor performance. There may be
        >> > more, but this one
        > is
        >> > HUGE. Too bad just compiling a new kernel
        >> > will not fix this
        > problem.
        >> > Someone added a hardcoded printk to the
        >> > usb-storage subsystem
        > that is
        >> > not in the kernel-2.4 sources I have.
        >> >
        >> > Setting /proc/sys/kernel/printk to a higher
        >> > value doesn't stop
        > it
        >> > either.
        >> >
        >> > To fix this, you have to get the HD-LAN_GPL
        >> > source, along with
        >> > installation of the kuro box stuff, break
        >> > apart the zip file,
        > untar
        >> > the kernel source, goto drivers/usb/storage,
        >> > edit the file
        >> > transport.c (do a search for 'task-switch',
        >> > around line 531 in
        > my
        >> > sources), and DELETE that line, build a new
        >> > kernel/ramdisk, and
        > then
        >> > install.. and pray that it comes back.
        >> >
        >> > thomas
      • Rick Flower
        Unless there was another issue of the same type, that problem should be solved in my kernel.. I went in and removed the kprintf call or whatever it was. As
        Message 3 of 12 , Oct 29, 2004
          Unless there was another issue of the same type, that problem should
          be solved in my kernel.. I went in and removed the kprintf call or
          whatever it was. As for the kernel update, I'll probably not be doing
          any firmware updates anymore since my system isn't exactly stock anymore.

          -- Rick

          On Fri, 29 Oct 2004, tad94564 wrote:

          >
          >
          > It's probably still in there if your kernel is based on the
          > HD-LAN_GPL source.
          >
          > I've recieved word this fix will be in the next firmware release,
          > which is supposed to be RSN.
          >
          > thomas
          >
          > --- In LinkStation_General@yahoogroups.com, Rick Flower <rickf@c...>
          > wrote:
          >>
          >> I've already done this on my updated kernel with no ill effects
          > yet..
          >> Of course, I've not actually tried using the USB yet, so I can't
          > really
          >> vouch for whether or not my changes solve the problem or not.
          >>
          >> -- Rick
          >>
          >>
          >> On Fri, 29 Oct 2004, tad94564 wrote:
          >>
          >>>
          >>>
          >>> --- In LinkStation_General@yahoogroups.com, "dtaub001"
          > <taubert@g...>
          >>> wrote:
          >>>>
          >>>>
          >>>> I was moving some big files to an external 250GB drive
          > yesterday,
          >>> and
          >>>> noticed that klogd and syslogd were taking up a fair amount of
          > cpu
          >>>> (40-ish percent).
          >>>>
          >>>> It looks like some debug messages were left in or put into the
          >>>> usb-storage driver. A "cat /proc/kmsg" will produce a flood
          > of
          >>> output
          >>>> while the external device is being accessed (something about
          >>> "switchin").
          >>>>
          >>>> This driver is compiled into the kernel (not loadable), so
          > I'll see
          >>> if
          >>>> I can get a new kernel compiled with the kurobox tools...
          >>>>
          >>>
          >>> After suffering from this problem last night, I found one
          > possible
          >>> cause of the poor performance. There may be more, but this one
          > is
          >>> HUGE. Too bad just compiling a new kernel will not fix this
          > problem.
          >>> Someone added a hardcoded printk to the usb-storage subsystem
          > that is
          >>> not in the kernel-2.4 sources I have.
          >>>
          >>> Setting /proc/sys/kernel/printk to a higher value doesn't stop
          > it
          >>> either.
          >>>
          >>> To fix this, you have to get the HD-LAN_GPL source, along with
          >>> installation of the kuro box stuff, break apart the zip file,
          > untar
          >>> the kernel source, goto drivers/usb/storage, edit the file
          >>> transport.c (do a search for 'task-switch', around line 531 in
          > my
          >>> sources), and DELETE that line, build a new kernel/ramdisk, and
          > then
          >>> install.. and pray that it comes back.
          >>>
          >>> thomas
          >>>
          >>>
          >>>
          >>>
          >>>
          >>>
          >>>
          >>>
          >>> Yahoo! Groups Links
          >>>
          >>>
          >>>
          >>>
          >>>
          >>>
          >>>
          >
          >
          >
          >
          >
          >
          >
          > Yahoo! Groups Links
          >
          >
          >
          >
          >
          >
          >
        • Roy M. Silvernail
          ... Real Soon Now. Not sure of the origin. I think I first saw it in Pournelle s Byte column. -- Roy M. Silvernail is roy@rant-central.com, and you re not
          Message 4 of 12 , Oct 29, 2004
            On Fri, 2004-10-29 at 15:25 -0400, James Ronald wrote:
            > What does RSN stand for?

            Real Soon Now. Not sure of the origin. I think I first saw it in
            Pournelle's Byte column.
            --
            Roy M. Silvernail is roy@..., and you're not
            "It's just this little chromium switch, here." - TFS
            SpamAssassin->procmail->/dev/null->bliss
            http://www.rant-central.com
          • sneed_siding
            This issue does appear to be fixed with firmware 1.45. Yay!
            Message 5 of 12 , Jan 2, 2005
              This issue does appear to be fixed with firmware 1.45. Yay!


              --- In LinkStation_General@yahoogroups.com, "tad94564" <tdavis@b...>
              wrote:
              >
              > It's probably still in there if your kernel is based on the
              > HD-LAN_GPL source.
              >
              > I've recieved word this fix will be in the next firmware release,
              > which is supposed to be RSN.
              >
              > thomas
            Your message has been successfully submitted and would be delivered to recipients shortly.