Loading ...
Sorry, an error occurred while loading the content.

Re: [LinkStation_General] increase memory?

Expand Messages
  • Paul Milligan (home)
    Just a bit of further info, I ve taken my Linkstation apart.There ate 2 unpopulated IC locations just waiting for RAM . In my model the RAM is Hyundai
    Message 1 of 18 , Feb 2 2:26 AM
    • 0 Attachment
      Just a bit of further info, I've taken my Linkstation apart.There ate 2 unpopulated IC locations "just waiting for RAM". In my model the RAM is Hyundai
      HY57V561620CT-H. I've checked the maufacturers datasheet and it a 16Mx16 part running at 133MHz. It would seem to be a "pretty easy" upgrade.
      Unfortunately my soldering skills (and equipment) predate SMT or I'd try it myself. I'll have to see if any of my local colleges has an electronics department!



      bob findlay (JIC) wrote:
      Is it possible to increase the memory on the linkstation?

      I am considering buying one in order to run slim server software.
      Running on my PC, the slim server software can take 90 MB of memory.  As
      the link station only comes with 64 (128?) I don't think it will run
      particularly well!

      Does anybody know what kind of memory it uses?  Is it hardwired?  Dimms?
      Simms?

      Cheers,

      Bob
    • irvine_stock
      Paul Soldering in the RAM (if you could) will not increase your memory size from 64Mbytes to 128Mbytes. The memory is currently configured for 32 bits. To
      Message 2 of 18 , Feb 3 2:08 PM
      • 0 Attachment
        Paul
        Soldering in the RAM (if you could) will not increase your memory
        size from 64Mbytes to 128Mbytes. The memory is currently configured
        for 32 bits. To upgrade the memory to 128Mbytes (like the Kuro/HG
        is) you have to go to 64 bits. The processor has another mode for
        this. One of the unstuffed resistors on the board will no doubt
        switch it over. When I get my new SDRAM's "next week" I will
        install them and figure it out. I have been waiting for the memory
        to arrive for months. I keep hearing "next week". :-(
        But free SDRAM is hard to find. About $7.00 each if you can find a
        place to buy them.
        I will post the results if I get there before somebody else. It
        does not look like rocket science!!!
        It will also be interesting to see if we get better performance with
        a 64 bit memory bus.
        Rich
        --- In LinkStation_General@yahoogroups.com, "Paul Milligan (home)"
        <paul_t_milligan@y...> wrote:
        >
      • Paul Milligan (home)
        Thanks for this. I have so far tried without success to find a source for the part in thr UK. I can get 10,000 from a broker in Taiwan, but no UK component
        Message 3 of 18 , Feb 4 1:32 AM
        • 0 Attachment
          Thanks for this. I have so far tried without success to find a source for the part in thr UK. I can get 10,000 from a broker in Taiwan, but no UK component retailer lists the part! Do you think it might be viable to get a 256Mb PC133 DIMM and reuse the chips?



          irvine_stock wrote:

          Paul
          Soldering in the RAM (if you could) will not increase your memory
          size from 64Mbytes to 128Mbytes.  The memory is currently configured
          for 32 bits.  To upgrade the memory to 128Mbytes (like the Kuro/HG
          is) you have to go to 64 bits.  The processor has another mode for
          this.  One of the unstuffed resistors on the board will no doubt
          switch it over.  When I get my new SDRAM's "next week" I will
          install them and figure it out.  I have been waiting for the memory
          to arrive for months.  I keep hearing "next week". :-(
          But free SDRAM is hard to find.  About $7.00 each if you can find a
          place to buy them.
          I will post the results if I get there before somebody else.  It
          does not look like rocket science!!!
          It will also be interesting to see if we get better performance with
          a 64 bit memory bus.
          Rich
          --- In LinkStation_General@yahoogroups.com, "Paul Milligan (home)"
          <paul_t_milligan@y...> wrote:
          >



        • freifegerste
          ... Hi there, I did some research which chips could be used to increase memory. The following types should be compatible to those already soldered: Hynix
          Message 4 of 18 , Feb 4 5:57 AM
          • 0 Attachment
            --- In LinkStation_General@yahoogroups.com, "Paul Milligan (home)"
            <paul_t_milligan@y...> wrote:
            >
            Hi there,

            I did some research which chips could be used to increase memory. The
            following types should be compatible to those already soldered:

            Hynix HY57V561620CT (-7)
            Micron MT48LC16M16A2 (-7E)
            Infineon HYB39S256160DT (-7)

            They are organised in 4Meg x 4 Banks x 16 Bits (32MByte per Chip).

            They can be found on old PC133-128MB SDRAM (not DDRAM!) DIMM Modules.
            It is possible to extract them from PCB using a hot-air-gun. You have
            to take care of not overheating the chips by doing this. The air
            should not exceed 400°C and the process should not last longer than 8
            to 10s. Most chips survive this without problems (I already tried this
            in other projects). Those DIMM modules are cheap and easy to get (used
            ones for 10€ apiece = 4 chips). I disassembled such a DIMM module and
            have now 4 of such chips for further experiments.

            If we could know the Linkstation memory organization, it would be easy
            to solder them on board. It is not necessary to use a 64 Bit bus for
            128 MByte memory. There could also be some kind of memory address
            decoder. Next week I have some time to do some measurements to clear
            this up. Perhaps someone did this already and could share his
            investigations. Especially interesting are these two resistors near
            the RAMS (switches??, extra decoder lines??).

            Best regards

            /Frank.
          • irvine_stock
            Paul, I can get them here in the states but small quantity are frowned upon. They want to sell thousands. Being an Engineer I can get samples and small
            Message 5 of 18 , Feb 4 10:31 PM
            • 0 Attachment
              Paul,
              I can get them here in the states but small quantity are frowned
              upon. They want to sell thousands. Being an Engineer I can get
              samples and small quantities for proto runs.
              Maybe if I can get it working I can send you some.
              I would be surprised if you could remove those SDRAMs from a DIMM.
              They usually are glued on with some solder paste and stuff so they
              need the right equipment. Hot air is the best for me.
              How much would it cost to send 2 to UK from California anyway?
              I should get them on Monday and we will see...
              Rich
              --- In LinkStation_General@yahoogroups.com, "Paul Milligan (home)"
              <paul_t_milligan@y...> wrote:
              >
            • irvine_stock
              Frank, I was going to blast you for throwing out so much misinformation after I just stated how it is connected as 64 bits. Then I figured you would just
              Message 6 of 18 , Feb 4 11:19 PM
              • 0 Attachment
                Frank,
                I was going to blast you for throwing out so much misinformation
                after I just stated how it is connected as 64 bits. Then I figured
                you would just throw it back at me.
                So instead:
                This processor must be connected up as 64 bits to get 128Mbytes.
                While it would be possible to connect up 32 bits to the PPC, this
                PCB is not setup that way. I don't think anybody wants to wire two
                50+ pin ICs with jumper wires. The other chip selects are not
                exposed.
                The two installed memories are not on the same data bits as the two
                that are missing. Obviously this means it is 64 bits. The address
                lines are the same for all 4 SDRAMs. In fact I also have some
                larger SDRAMs with same pinout that I will be putting on my KuroBox
                after I get four of the regular ones working. I don't know if the
                software will initialize the larger SDRAMs or four smaller ones.
                But its worth a try and it will probably just not work if I'm wrong.
                I figure most folks will not want to remove the two RAMs that are
                currently there. So I am working on the easy solution first.
                No research is needed to figure out which SDRAMs you need to add.
                They must be the same as the ones already there. Mixing will
                usually not work unless the loader (kernel) was very well
                programmed. They all have different programming and timing issues.
                All five of my boxes have Micron MT48LC16M16A2 (-7E). Everybody
                else should check there's and only use the same ones. I already
                know there is no decoder or spare address lines on the board. The
                PPC does not need them.
                And those two resistors appear to be the programming resistors for
                the SDRAM and flash. One will enable the 4 SDRAMS and the other
                will program the two FLASH devices for 64 bits too. Flash will be
                interesting since it will require a reprogramming of the current
                parts. But until I get SDRAMs into mine, I can't say for sure on
                the resistors. Buffalo forgot to mark them for us :-)
                Rich
                --- In LinkStation_General@yahoogroups.com, "freifegerste"
                <printmaster@i...> wrote:
                >
                > --- In LinkStation_General@yahoogroups.com, "Paul Milligan (home)"
                > <paul_t_milligan@y...> wrote:
                > >
                > Hi there,
                >
                > I did some research which chips could be used to increase memory.
                The
                > following types should be compatible to those already soldered:
                >
                > Hynix HY57V561620CT (-7)
                > Micron MT48LC16M16A2 (-7E)
                > Infineon HYB39S256160DT (-7)
                >
                > They are organised in 4Meg x 4 Banks x 16 Bits (32MByte per Chip).
                >
                > They can be found on old PC133-128MB SDRAM (not DDRAM!) DIMM
                Modules.
                > It is possible to extract them from PCB using a hot-air-gun. You
                have
                > to take care of not overheating the chips by doing this. The air
                > should not exceed 400°C and the process should not last longer
                than 8
                > to 10s. Most chips survive this without problems (I already tried
                this
                > in other projects). Those DIMM modules are cheap and easy to get
                (used
                > ones for 10€ apiece = 4 chips). I disassembled such a DIMM module
                and
                > have now 4 of such chips for further experiments.
                >
                > If we could know the Linkstation memory organization, it would be
                easy
                > to solder them on board. It is not necessary to use a 64 Bit bus
                for
                > 128 MByte memory. There could also be some kind of memory address
                > decoder. Next week I have some time to do some measurements to
                clear
                > this up. Perhaps someone did this already and could share his
                > investigations. Especially interesting are these two resistors near
                > the RAMS (switches??, extra decoder lines??).
                >
                > Best regards
                >
                > /Frank.
              • irvine_stock
                Paul, Finally got my SDRAM in. I installed both SDRAM s. Same speed and type as the originals. Turned the board on and it still works fine. :) However it
                Message 7 of 18 , Feb 10 12:21 AM
                • 0 Attachment
                  Paul,
                  Finally got my SDRAM in. I installed both SDRAM's. Same speed and
                  type as the originals. Turned the board on and it still works
                  fine. :)
                  However it does not see the other two SDRAM's. That was pretty much
                  expected. The board had to be configured for 32 bits somehow. I
                  confirmed it is connected up as either 32 bit or 64 bit.
                  One 1K resistor decides if its 64Mbytes or 128Mbytes. The resistor
                  in forces 32 bit mode. Taking the resistor out forces 64 bit mode.
                  Well 64bit mode only makes the unit hang until the watchdog timer
                  kills the power. No uart access at all.
                  Couple of possibilities I see at this point.
                  1) The firmware does not allow 64 bit mode.
                  2) I didn't get it into 64 bit mode.
                  3) SDRAM could be bad or soldered wrong. (not likely)
                  Since the Kuro/HG does support 4 SDRAM's it could still be either 1
                  or 2. Will have to spend some more time researching other
                  possibilities. Trying to use my wiggler on the JTAG to access the
                  memory and decode if the memory size is changing right.

                  During this execise I also confirmed that the Flash @IC18 is used as
                  8 bit, not 16 as I saw reported somewhere (I think here).
                  To much misinformation is reported. If you don't know then don't
                  say you do know. Say your guessing or your sons girlfiend who is a
                  biology major thinks so. :-)
                  Yes the flash is a 16 bit part but its shorted to byte mode. Its
                  chip select is connected to RCS0 for access. The flash at IC19 (if
                  installed) is connected up in parallel with the exception it uses
                  RCS1 for access. So both parts can be installed together. If more
                  Flash is needed it looks pretty simple to solder it in. But they
                  both are still 8 bit.
                  Rich

                  --- In LinkStation_General@yahoogroups.com, "Paul Milligan (home)"
                  <paul_t_milligan@y...> wrote:
                  >
                • Marc Bizer
                  Hi everyone, Though utter stupidity, I just clobbered my /usr/local/bin subdirectory. I have no idea what was in it before, but what can I do to restore it?
                  Message 8 of 18 , Feb 16 7:54 PM
                  • 0 Attachment
                    Hi everyone,

                    Though utter stupidity, I just clobbered my /usr/local/bin
                    subdirectory. I have no idea what was in it before, but what can I do
                    to restore it?

                    --Marc
                  • Tim Lewis
                    ... What firmware do you have? In the 1.45_13 firmware, there is no /usr/local/bin . Did you clobber /usr/local ? The only thing that s in there are
                    Message 9 of 18 , Feb 16 8:10 PM
                    • 0 Attachment
                      Marc Bizer wrote:
                      >
                      > Though utter stupidity, I just clobbered my /usr/local/bin
                      > subdirectory. I have no idea what was in it before, but what can I do
                      > to restore it?

                      What firmware do you have? In the 1.45_13 firmware, there is no
                      "/usr/local/bin". Did you clobber "/usr/local"? The only thing that's
                      in there are printer definitions.

                      You can probably restore it by doing another firmware install.
                      If you can't do that I can send you a tar of the directory.

                      Let me know...

                      - Tim
                    • Marc Bizer
                      ... I have 1.44, but I think that my update to netatalk 2.0.2 installed stuff in /usr/local/bin. I m going to do another ./configure, make, and make install to
                      Message 10 of 18 , Feb 16 8:14 PM
                      • 0 Attachment
                        On 2/16/05 at 11:10 PM -0500, Tim Lewis wrote:
                        >What firmware do you have? In the 1.45_13 firmware, there is no
                        >"/usr/local/bin". Did you clobber "/usr/local"? The only thing that's
                        >in there are printer definitions.

                        I have 1.44, but I think that my update to netatalk 2.0.2 installed
                        stuff in /usr/local/bin. I'm going to do another ./configure, make,
                        and make install to see if that restores stuff.

                        Thanks for your help!

                        --Marc
                      • Marc Bizer
                        Hi, In my /var/log/messages, I m seeing errors like this: Feb 16 22:26:24 TREE250 kernel: EXT3-fs warning: maximal mount count reached, running e2fsck is
                        Message 11 of 18 , Feb 16 8:30 PM
                        • 0 Attachment
                          Hi,

                          In my /var/log/messages, I'm seeing errors like this:

                          Feb 16 22:26:24 TREE250 kernel: EXT3-fs warning: maximal mount count
                          reached, running e2fsck is recommended

                          Any idea why? Has anyone else seen this?

                          --Marc
                        • Tim Lewis
                          ... Yes, only every time I m in hurry to boot a Linux system!!! :) This is a fairly routine message and is nothing to worry about. It s just a little reminder
                          Message 12 of 18 , Feb 16 9:21 PM
                          • 0 Attachment
                            Marc Bizer wrote:
                            > In my /var/log/messages, I'm seeing errors like this:
                            >
                            > Feb 16 22:26:24 TREE250 kernel: EXT3-fs warning: maximal mount count
                            > reached, running e2fsck is recommended
                            >
                            > Any idea why? Has anyone else seen this?

                            Yes, only every time I'm in hurry to boot a Linux system!!! :)

                            This is a fairly routine message and is nothing to worry
                            about. It's just a little reminder for Linux that it needs
                            to perform a filesystem check.

                            Linux keeps a count of how many times it mounts its partitions.
                            Usually during boot, Linux checks to see how many times a
                            partition has been mounted, and if this value equals the
                            "maximum mount count" for the partition, it performs a file
                            system check. The boot sequence pauses while the file system
                            check is performed, and continues when it is finished. When
                            you're in a hurry to boot a Linux machine, and this occurs,
                            the wait can be maddening, which is why this is often referred
                            to as, "losing the lottery".

                            Try restarting your LinkStation, and see if it takes longer to
                            boot (i.e. it performs a check). You shouldn't see those messages
                            for a while after that. If this doesn't fix the problem, you can run
                            a disk check from the administration page. That should make the
                            messages go away for a while.

                            You can view when the next time this is going to occur
                            with "/sbin/tune2fs -l /dev/hda3". You can also set the,
                            "maximum mount count", as well as the, "mount count", using
                            tune2fs, but I don't recommend doing this, especially not on
                            a mounted filesystem.

                            I'm on 19 out of 24 mounts, so I'll be doing this soon, too.

                            - Tim
                          • James Ronald
                            ... From: irvine_stock To: Sent: Thursday, February 10, 2005 4:21 AM Subject:
                            Message 13 of 18 , Apr 27, 2005
                            • 0 Attachment
                              ----- Original Message -----
                              From: "irvine_stock" <r_obermeyer@...>
                              To: <LinkStation_General@yahoogroups.com>
                              Sent: Thursday, February 10, 2005 4:21 AM
                              Subject: [LinkStation_General] Re: increase memory?


                              >
                              >
                              > Paul,
                              > Finally got my SDRAM in. I installed both SDRAM's. Same speed and
                              > type as the originals. Turned the board on and it still works
                              > fine. :)
                              > However it does not see the other two SDRAM's. That was pretty much
                              > expected. The board had to be configured for 32 bits somehow. I
                              > confirmed it is connected up as either 32 bit or 64 bit.
                              > One 1K resistor decides if its 64Mbytes or 128Mbytes. The resistor
                              > in forces 32 bit mode. Taking the resistor out forces 64 bit mode.
                              > Well 64bit mode only makes the unit hang until the watchdog timer
                              > kills the power. No uart access at all.
                              > Couple of possibilities I see at this point.
                              > 1) The firmware does not allow 64 bit mode.
                              > 2) I didn't get it into 64 bit mode.
                              > 3) SDRAM could be bad or soldered wrong. (not likely)
                              > Since the Kuro/HG does support 4 SDRAM's it could still be either 1
                              > or 2. Will have to spend some more time researching other
                              > possibilities. Trying to use my wiggler on the JTAG to access the
                              > memory and decode if the memory size is changing right.
                              >
                              > During this execise I also confirmed that the Flash @IC18 is used as
                              > 8 bit, not 16 as I saw reported somewhere (I think here).
                              > To much misinformation is reported. If you don't know then don't
                              > say you do know. Say your guessing or your sons girlfiend who is a
                              > biology major thinks so. :-)
                              > Yes the flash is a 16 bit part but its shorted to byte mode. Its
                              > chip select is connected to RCS0 for access. The flash at IC19 (if
                              > installed) is connected up in parallel with the exception it uses
                              > RCS1 for access. So both parts can be installed together. If more
                              > Flash is needed it looks pretty simple to solder it in. But they
                              > both are still 8 bit.
                              > Rich
                              >

                              Rich,

                              Any progress on the SDRAM upgrade to 128MB?

                              JR
                            Your message has been successfully submitted and would be delivered to recipients shortly.