Loading ...
Sorry, an error occurred while loading the content.

HDD - Shutdown standby

Expand Messages
  • Michael Olszynski
    ... Hi, I read the upper comment about spinning down of the HD, but this does not work with my LS. I did set the timeout to 5 seconds for playing hdparm -S 1
    Message 1 of 5 , Jan 23, 2005
    • 0 Attachment
      >> Does the HD spin down after certain time of
      >> inactivity as in regular PC ?
      >> If so what are the settings ?
      >>
      >
      > There's a script /etc/init.d/hdparm for it to set it
      > spin down after 241 seconds, you can change it if you
      > want...either disable the script or change the time.
      >
      > Wilson

      Hi, I read the upper comment about spinning down of the HD, but this does
      not work with my LS.

      I did set the timeout to 5 seconds for playing
      hdparm -S 1 /dev/hda
      but the linkstation HD did not shutdown even after some hours

      But setting:
      hdparm -y /dev/hda
      or
      hdparm -Y /dev/hda

      does shut down the internal drive until the next request on the HD´s content
      is made.
      Any ideas how to shutdown the HD (if it is not used) automatically?

      BR Michael
    • chano22000
      Hi Michael 241 does not mean 241 s. According to man hdparm : -S Set the standby (spindown) timeout for the drive. This value is used by the drive to
      Message 2 of 5 , Jan 23, 2005
      • 0 Attachment
        Hi Michael

        241 does not mean 241 s.

        According to man hdparm :

        -S Set the standby (spindown) timeout for the drive.
        This value is used by the drive to determine how
        long to wait (with no disk activity) before turning
        off the spindle motor to save power. Under such
        circumstances, the drive may take as long as 30
        seconds to respond to a subsequent disk access,
        though most drives are much quicker. The encoding
        of the timeout value is somewhat peculiar. A value
        of zero means "off". Values from 1 to 240 specify
        multiples of 5 seconds, for timeouts from 5 seconds
        to 20 minutes. Values from 241 to 251 specify from
        1 to 11 units of 30 minutes, for timeouts from 30
        minutes to 5.5 hours. A value of 252 signifies a
        timeout of 21 minutes, 253 sets a vendor-defined
        timeout, and 255 is interpreted as 21 minutes plus
        15 seconds.

        If you want to change this value, modify it in the boot script :
        /etc/rc.d/init.d/hdparm

        Regards.
      • olszynski1
        Hi, yes, I know it is not seconds. But I have the problem, that the drive will not spin in 5 seconds. I did set manually after booting: # hdparm -S 1 /dev/hda
        Message 3 of 5 , Jan 23, 2005
        • 0 Attachment
          Hi,

          yes, I know it is not seconds. But I have the problem, that the drive
          will not spin in 5 seconds. I did set manually after booting:
          # hdparm -S 1 /dev/hda
          I thought about LAN-activity and disconnected the LAN-cable, that
          didn´t work. I think there must be a running process, which keeps the
          linkstation alive. Any ideas?
          Or is it necessary to set it in the script which is called after
          booting?
          #hdparm -Y /dev/hda or hdparm -y /dev/hda does work fine and the
          drive shuts down correct.

          Can you help me there?

          Thank you BR Michael


          --- In LinkStation_General@yahoogroups.com, "chano22000"
          <philippe.deysine@l...> wrote:
          >
          > Hi Michael
          >
          > 241 does not mean 241 s.
          >
          > According to man hdparm :
          >
          > -S Set the standby (spindown) timeout for the drive.
          > This value is used by the drive to determine how
          > long to wait (with no disk activity) before turning
          > off the spindle motor to save power. Under such
          > circumstances, the drive may take as long as 30
          > seconds to respond to a subsequent disk access,
          > though most drives are much quicker. The encoding
          > of the timeout value is somewhat peculiar. A value
          > of zero means "off". Values from 1 to 240 specify
          > multiples of 5 seconds, for timeouts from 5 seconds
          > to 20 minutes. Values from 241 to 251 specify from
          > 1 to 11 units of 30 minutes, for timeouts from 30
          > minutes to 5.5 hours. A value of 252 signifies a
          > timeout of 21 minutes, 253 sets a vendor-defined
          > timeout, and 255 is interpreted as 21 minutes plus
          > 15 seconds.
          >
          > If you want to change this value, modify it in the boot script :
          > /etc/rc.d/init.d/hdparm
          >
          > Regards.
        • Andrew Hodgson
          Hi, Without stating the obvious, spinning the drive down after one second is quite a short while, and there may be some internal config which stops it from
          Message 4 of 5 , Jan 24, 2005
          • 0 Attachment
            Hi,

            Without stating the obvious, spinning the drive down after one second is quite a short while, and there may be some internal config which stops it from spinning down so soon - indeed, with that amount of spinning up/down will cause more power to be used, and will also shorten the age of the drive. What are you trying to achieve? What is wrong with the default setting?

            Andrew.


            -----Original Message-----
            From: olszynski1 [mailto:michael@...]
            Sent: Mon 24/01/2005 07:32
            To: LinkStation_General@yahoogroups.com
            Subject: [LinkStation_General] Re: HDD - Shutdown standby



            Hi,

            yes, I know it is not seconds. But I have the problem, that the drive
            will not spin in 5 seconds. I did set manually after booting:
            # hdparm -S 1 /dev/hda
            I thought about LAN-activity and disconnected the LAN-cable, that
            didn´t work. I think there must be a running process, which keeps the
            linkstation alive. Any ideas?
            Or is it necessary to set it in the script which is called after
            booting?
            #hdparm -Y /dev/hda or hdparm -y /dev/hda does work fine and the
            drive shuts down correct.

            Can you help me there?

            Thank you BR Michael


            --- In LinkStation_General@yahoogroups.com, "chano22000"
            <philippe.deysine@l...> wrote:
            >
            > Hi Michael
            >
            > 241 does not mean 241 s.
            >
            > According to man hdparm :
            >
            > -S Set the standby (spindown) timeout for the drive.
            > This value is used by the drive to determine how
            > long to wait (with no disk activity) before turning
            > off the spindle motor to save power. Under such
            > circumstances, the drive may take as long as 30
            > seconds to respond to a subsequent disk access,
            > though most drives are much quicker. The encoding
            > of the timeout value is somewhat peculiar. A value
            > of zero means "off". Values from 1 to 240 specify
            > multiples of 5 seconds, for timeouts from 5 seconds
            > to 20 minutes. Values from 241 to 251 specify from
            > 1 to 11 units of 30 minutes, for timeouts from 30
            > minutes to 5.5 hours. A value of 252 signifies a
            > timeout of 21 minutes, 253 sets a vendor-defined
            > timeout, and 255 is interpreted as 21 minutes plus
            > 15 seconds.
            >
            > If you want to change this value, modify it in the boot script :
            > /etc/rc.d/init.d/hdparm
            >
            > Regards.






            Yahoo! Groups Links
          • olszynski1
            Yes I know that this is quite a short time. This is for testing, that I cen see fast if drive is shutting down or nor. I´ll leave this value at 30 minutes
            Message 5 of 5 , Jan 24, 2005
            • 0 Attachment
              Yes I know that this is quite a short time. This is for testing,
              that I cen see fast if drive is shutting down or nor. I´ll leave
              this value at 30 minutes (241) when it is working.
              But my drive is not spinning down at all, with
              # hdparm -S <anyvalueyouliketohave> /dev/hda

              That´s my problem. So I was thinking of a running process which does
              access the harddrive that it can not shut down.?!?!??

              Thank you BR Michael

              --- In LinkStation_General@yahoogroups.com, "Andrew Hodgson"
              <andrew@h...> wrote:
              > Hi,
              >
              > Without stating the obvious, spinning the drive down after one
              second is quite a short while, and there may be some internal config
              which stops it from spinning down so soon - indeed, with that amount
              of spinning up/down will cause more power to be used, and will also
              shorten the age of the drive. What are you trying to achieve? What
              is wrong with the default setting?
              >
              > Andrew.
              >
              >
              > -----Original Message-----
              > From: olszynski1 [mailto:michael@o...]
              > Sent: Mon 24/01/2005 07:32
              > To: LinkStation_General@yahoogroups.com
              > Subject: [LinkStation_General] Re: HDD - Shutdown standby
              >
              >
              >
              > Hi,
              >
              > yes, I know it is not seconds. But I have the problem, that the
              drive
              > will not spin in 5 seconds. I did set manually after booting:
              > # hdparm -S 1 /dev/hda
              > I thought about LAN-activity and disconnected the LAN-cable, that
              > didn´t work. I think there must be a running process, which keeps
              the
              > linkstation alive. Any ideas?
              > Or is it necessary to set it in the script which is called after
              > booting?
              > #hdparm -Y /dev/hda or hdparm -y /dev/hda does work fine and the
              > drive shuts down correct.
              >
              > Can you help me there?
              >
              > Thank you BR Michael
              >
              >
              > --- In LinkStation_General@yahoogroups.com, "chano22000"
              > <philippe.deysine@l...> wrote:
              > >
              > > Hi Michael
              > >
              > > 241 does not mean 241 s.
              > >
              > > According to man hdparm :
              > >
              > > -S Set the standby (spindown) timeout for the drive.
              > > This value is used by the drive to determine how
              > > long to wait (with no disk activity) before turning
              > > off the spindle motor to save power. Under such
              > > circumstances, the drive may take as long as 30
              > > seconds to respond to a subsequent disk access,
              > > though most drives are much quicker. The encoding
              > > of the timeout value is somewhat peculiar. A value
              > > of zero means "off". Values from 1 to 240 specify
              > > multiples of 5 seconds, for timeouts from 5 seconds
              > > to 20 minutes. Values from 241 to 251 specify from
              > > 1 to 11 units of 30 minutes, for timeouts from 30
              > > minutes to 5.5 hours. A value of 252 signifies a
              > > timeout of 21 minutes, 253 sets a vendor-defined
              > > timeout, and 255 is interpreted as 21 minutes plus
              > > 15 seconds.
              > >
              > > If you want to change this value, modify it in the boot script :
              > > /etc/rc.d/init.d/hdparm
              > >
              > > Regards.
              >
              >
              >
              >
              >
              >
              > Yahoo! Groups Links
            Your message has been successfully submitted and would be delivered to recipients shortly.