Loading ...
Sorry, an error occurred while loading the content.

816Re: Samba-3.0.9 binaries for Linkstation (README)

Expand Messages
  • whoisnader
    Jan 1, 2005
    • 0 Attachment
      Has anyone noticed that you cannot shutdown (either via the shutdown
      command in a telnet session, via the web interface or the button)
      when running this version of samba, or is it just my configration?

      When I reverted back the samba version that comes with 1.45_13 it
      will shutdown correctly.

      --- In LinkStation_General@yahoogroups.com, "whoisnader"
      <whoisnader@h...> wrote:
      >
      > I can't seem to get SWAT to work. I have made the changes to the
      > inetd.conf file but I get a connection refused error when I try to
      > connect to http://ip:901/
      >
      > Here is how my inetd.conf looks like
      >
      > telnet stream tcp nowait root /usr/sbin/tcpd
      > in.telnetd /usr/local/samba/sbin/swat swat
      >
      > I am able to get samba working, just not SWAT.
      >
      > --- In LinkStation_General@yahoogroups.com, Wilson
      <sonsondei@y...>
      > wrote:
      > > or you can set up the smbpasswd location inside the
      > > smb.conf file.
      > >
      > >
      > > --- stratmoens <strat321@c...> wrote:
      > >
      > > >
      > > > A small addition to your "how to" is necessary for
      > > > these binaries to
      > > > operate correctly....
      > > >
      > > > A symbolic link must be created for smbpasswd. For
      > > > example,
      > > >
      > > > ln -s /etc/samba/smbpasswd
      > > > /usr/local/samba/private/smbpasswd
      > > >
      > > > Otherwise I believe everything is correct. I rebuilt
      > > > samba from the
      > > > sources before I found that smbd was looking in this
      > > > file, but it
      > > > was in fact empty thus preventing a client from
      > > > mounting a share.
      > > >
      > > > --- In LinkStation_General@yahoogroups.com, Wilson
      > > > <sonsondei@y...>
      > > > wrote:
      > > > > Hi all,
      > > > >
      > > > [snip]
      > > > > Q: How to make it work with the current samba from
      > > > LS?
      > > > > A: You should first stop the current samba
      > > > process,
      > > > > change the /etc/init.d/smb to point to the new
      > > > server
      > > > > daemon location (/usr/sbin/smbd to
      > > > > /usr/local/samba/sbin/smbd etc) Then make a
      > > > symbolic
      > > > > link: ln -s /etc/samba/smb.conf
      > > > > /usr/local/samba/lib/smb.conf
      > > > > start the process again and you should be now
      > > > using
      > > > > samba 3.0.9 binaries.
      > > > [snip]
      > > > > Wilson
      > > >
      > > >
      > > >
      > > >
      > > >
      > >
      > >
      > >
      > >
      > > __________________________________
      > > Do you Yahoo!?
      > > Jazz up your holiday email with celebrity designs. Learn more.
      > > http://celebrity.mail.yahoo.com
    • Show all 19 messages in this topic