Loading ...
Sorry, an error occurred while loading the content.

5805Stock v2.6 Kernel on a Linkstation HS

Expand Messages
  • daveyip
    Jan 27, 2007
    • 0 Attachment
      Hi,

      I was wondering if anyone can help me.

      I have a Linkstation HS that I have installed u-boot on according to

      http://www.kurobox.com/mwiki/index.php/Kurobox_support_in_stock_2.6_kernels

      Over at the Kurobox wiki

      I have everything installed and a 2.6.20-rc5 kernel booting over nc

      But have run up against

      linkstation: disarming the AVR watchdog:
      VFS: Cannot open root device "sda1" or unknown-block(0,0)
      Please append a correct "root=" boot option
      Kernel panic - not syncing: VFS: Unable to mount root fs on
      unknown-block(0,0)

      I have used the stock .config file for the linkstation out of the
      kernel that has IDE disabled and PATA enabled. My fstab looks like

      # /etc/fstab: static file system information.
      #
      # <file system> <mount point> <type> <options> <dump>
      <pass>
      /dev/sda1 / ext3 defaults,noatime,errors=remount-ro
      0 0
      proc /proc proc defaults
      0 0
      none /dev/pts devpts gid=5,mode=20
      0 0
      /dev/sda2 swap swap defaults
      0 0
      /dev/sda3 /datafiles ext3 defaults,noatime
      0 0


      My u-boot config for CONFIG_BOOTARGS looks like

      #define CONFIG_BOOTARGS "root=/dev/sda1
      netconsole=6666@192.168.0.13/,@192.168.0.7/00:11:D8:1A:78:21"

      (Incidently, the instructions say to have rtc-rs5c372.probe=0,0x32 in
      there to, but I found that this causes no kernel messages to be
      displayed in nc)

      Any help would be appreciated.

      Thanks,

      David
    • Show all 16 messages in this topic