Loading ...
Sorry, an error occurred while loading the content.

1912Re: Compiling on the Linkstation

Expand Messages
  • whoisnader
    Apr 3, 2005
    • 0 Attachment
      Success, managed to get samba 3.0.13 compiled and working along with
      swat.

      All is well accept for one little problem. When I enable the trash
      can facility, it denies access to the shares. I am thinking that
      this has something to do with the way I compiled samba given that
      recycle.so is compiled into the /usr/local/samba/lib drectory but
      samba is assigning the /usr/lib/samba directory.

      This sounds a lot like what you have discussed below but remember
      that I am a newbie and I need a little more detail.

      Here are the configure parameters that I used:

      --prefix=/usr/local/samba --with-privatedir=/etc/samba/ --with-
      lockdir=/mnt2/ram/var/run/ --with-piddir=/mnt2/ram/var/run/

      Help is greatly appreciated. Thanks in advance.

      --- In LinkStation_General@yahoogroups.com, "jceklosk"
      <jceklosk@y...> wrote:
      >
      > I used the binaries from the kurbox site:
      >
      > http://www.kurobox.com/downloads.html
      >
      > (click on binaries)
      >
      > Note, my approach for this build environment may seem a little
      > backwards, but does work well, though you will run into issues
      > locating some shared libs from the dev binaries. To get around
      this
      > copy them to /usr/local/lib (create this) and export
      > LD_LIBRARY_PATH=/usr/local/lib.
      >
      > I have built the latest rsync, samba, apache all this way.
      >
      >
      >
      > --- In LinkStation_General@yahoogroups.com, "whoisnader"
      > <whoisnader@h...> wrote:
      > >
      > > This is fantastic;
      > >
      > > Thanks for all that. One more thing, which specific compiler
      > > binaries did you unarchive?
      > >
      > >
      > >
      > > --- In LinkStation_General@yahoogroups.com, "jceklosk"
      > > <jceklosk@y...> wrote:
      > > >
      > > > Here is what I did to get around the compiling path deal and
      to NOT
      > > > disturb anything else on the machine, because some of the
      files in
      > > > the compiler pack overwrite system some system libs.
      > > >
      > > > 1. tar off the root file system,
      > > > cd /
      > > > tar cvlf /mnt/share/root.tar
      > > > NOTE: the l is just do the local filesystem
      > > >
      > > > 2. mkdir /mnt/share/ROOT
      > > >
      > > > 3. cd /mnt/share/ROOT
      > > >
      > > > 4. tar xvf /mnt/share/root.tar
      > > >
      > > > 5. Untar all the compiler binaries
      > > > MAKE SURE YOU ARE IN /mnt/share/ROOT FIRST!
      > > >
      > > > 6. Get a copy of chroot from the files section in the group
      here
      > > >
      > > > 7. run chroot /mnt/share/ROOT
      > > >
      > > > 8. The compilers and all will work now.
      > > >
      > > > 9. I usualy do this:
      > > > ./configure --prefix=/usr/local/packagename
      > > > make
      > > > make install
      > > > The new code will be installed in /usr/local/packagename
      > > >
      > > > 10. exit out of the chroot command
      > > >
      > > > 11. Copy cp -ra /mnt/share/ROOT/usr/local/package
      to /usr/local
      > > >
      > > >
      > > >
      > > > --- In LinkStation_General@yahoogroups.com, "whoisnader"
      > > > <whoisnader@h...> wrote:
      > > > >
      > > > > Hi all;
      > > > >
      > > > > I have been toying with trying to compile on my linkstation
      > > (namely
      > > > > samba v3.0.13) and want some help with installing compilers.
      > > > >
      > > > > I have downloaded the binary.zip archive and then extracted
      > > binutils-
      > > > > 2.10.91.0.2.tar.gz. I then used a telnet session to extract
      that
      > > > > archive into the required location.
      > > > >
      > > > > Upon running ./configure with the required arguments it
      > > complained
      > > > > about not finding a compiler. So I then proceeded to extract
      gcc-
      > > > > 2.95.3.tar.gz into the required locations.
      > > > >
      > > > > I ran ./configure yet again and after finding gcc, it then
      > > > > complained about not finding a c compiler.
      > > > >
      > > > > Can someone give some "no fuss" instructions on what we need
      to
      > > do
      > > > > to be able to compile on the linkstation.
      > > > >
      > > > > I am a noob at compiling so be gentle....
    • Show all 7 messages in this topic