Loading ...
Sorry, an error occurred while loading the content.

Re: [LacrosseWS] Open2300 crazy temperature values

Expand Messages
  • Jeff Bogumil
    ... I m not familiar specifically with the WS2355 model that, from your further ... apparently may not employ the bit-banging (nonstandard) serial port
    Message 1 of 5 , Dec 8, 2012
    View Source
    • 0 Attachment
      > These crazy values don't get logged on the actual weather console
      > so I am thinking the connection to the PC may be the issue?

      I'm not familiar specifically with the WS2355 model that, from your further
      remark:
      > the USB serial adapter provided with the weather station

      apparently may not employ the bit-banging (nonstandard) "serial port"
      interface found on various other LaCrosse models.

      However, with a long corporate history of disdain for their weather station
      users (e.g., unwilling to properly document proprietary comm protocols), I
      would not put it past LaCrosse to bundle a WS with a USB adapter ill suited
      to reliable communication; it's how they unload remaining stock. [Check
      this group's archive for LaCrosse USB serial port adapter complaints.]

      Although typically no longer brought out to a backplane 9pin subD
      connector, some modern PCs are still equipped with legacy UART serial port
      mobo pin headers, so you might check for that; if present, requiring only
      purchase or custom fabrication of a suitably configured cable.
      Alternatively, you might consider equipping your new PC with a UART-based
      serial port card; but of course that requires an open/available PCI,
      PCMCIA, PCIe or miniPCIe "slot" and purchase of an appropriate accessory
      card.

      It's also possible that the USB adapter is in no way contributing to your
      problem. You remark that: "these crazy values don't get logged on the
      actual weather console", and in fact some LaCrosse weather station models
      employ a crude (undocumented) error/false-reading detection flag that, if
      used in the WS2355 and not handled appropriately by code in your
      Silverlight project, could hypothetically explain your observation.

      BTW, I did glance at your webpage; and found it to display OK, though
      extremely slow loading; and Silverlight, with all its overhead, seems an
      odd choice of a platform for the sample graphical data display. However,
      ultimately, you may plan to incorporate streaming video with radar and/or
      other display; possibly motivating the selection of Silverlight.


      On Sat, Dec 8, 2012 at 3:40 AM, InsanePenguin <
      amo.la.noche.oscura@...> wrote:

      > **
      >
      >
      > Hi everyone,
      >
      > I have recently switched my WS2355 to a more powerful PC, the only
      > difference is I've had to use the USB serial adapter provided with the
      > weather station(could plug in directly to older PC). Using open2300
      > (log2300), sometimes the outdoor temperature is way out (things like 50 -
      > 60c or - 25c).
      >
      > These crazy values don't get logged on the actual weather console so I am
      > thinking the connection to the PC may be the issue? I have checked all of
      > the equipment and replaced the batteries with top of the range ones but I
      > still get the problems.
      >
      > You can see the problems yourself if you go to
      > http://www.theweatherproject.net/#Daily This is a Silverlight application
      > I have been developing, the 28.8 and and - 5.6, - 11.2 are greatly
      > inaccurate!
      >
      > (Apologies if the app doesn't load, some people are having problems with
      > Silverlight but it works fine for most people)
      >
      > Any advice appreciated!!
      >
      > Many thanks,
      > Mike
      >


      [Non-text portions of this message have been removed]
    • Michael Harper
      Hi Jeff, I was thinking I could implement some error detection logic before the data reaches my database. I developed a Silverlight application for my final
      Message 2 of 5 , Dec 8, 2012
      View Source
      • 0 Attachment
        Hi Jeff,

        I was thinking I could implement some error detection logic before the data reaches my database. I developed a Silverlight application for my final year Uni project, I’m also going to build a ‘Weather Dashboard’ in MVC4 with jQuery charting which will be a lot more lightweight and accessible!

        Many thanks

        From: Jeff Bogumil
        Sent: Saturday, December 8, 2012 1:46 PM
        To: Lacrosse_weather_stations@yahoogroups.com
        Subject: Re: [LacrosseWS] Open2300 crazy temperature values


        > These crazy values don't get logged on the actual weather console
        > so I am thinking the connection to the PC may be the issue?

        I'm not familiar specifically with the WS2355 model that, from your further
        remark:
        > the USB serial adapter provided with the weather station

        apparently may not employ the bit-banging (nonstandard) "serial port"
        interface found on various other LaCrosse models.

        However, with a long corporate history of disdain for their weather station
        users (e.g., unwilling to properly document proprietary comm protocols), I
        would not put it past LaCrosse to bundle a WS with a USB adapter ill suited
        to reliable communication; it's how they unload remaining stock. [Check
        this group's archive for LaCrosse USB serial port adapter complaints.]

        Although typically no longer brought out to a backplane 9pin subD
        connector, some modern PCs are still equipped with legacy UART serial port
        mobo pin headers, so you might check for that; if present, requiring only
        purchase or custom fabrication of a suitably configured cable.
        Alternatively, you might consider equipping your new PC with a UART-based
        serial port card; but of course that requires an open/available PCI,
        PCMCIA, PCIe or miniPCIe "slot" and purchase of an appropriate accessory
        card.

        It's also possible that the USB adapter is in no way contributing to your
        problem. You remark that: "these crazy values don't get logged on the
        actual weather console", and in fact some LaCrosse weather station models
        employ a crude (undocumented) error/false-reading detection flag that, if
        used in the WS2355 and not handled appropriately by code in your
        Silverlight project, could hypothetically explain your observation.

        BTW, I did glance at your webpage; and found it to display OK, though
        extremely slow loading; and Silverlight, with all its overhead, seems an
        odd choice of a platform for the sample graphical data display. However,
        ultimately, you may plan to incorporate streaming video with radar and/or
        other display; possibly motivating the selection of Silverlight.

        On Sat, Dec 8, 2012 at 3:40 AM, InsanePenguin <
        mailto:amo.la.noche.oscura%40googlemail.com> wrote:

        > **
        >
        >
        > Hi everyone,
        >
        > I have recently switched my WS2355 to a more powerful PC, the only
        > difference is I've had to use the USB serial adapter provided with the
        > weather station(could plug in directly to older PC). Using open2300
        > (log2300), sometimes the outdoor temperature is way out (things like 50 -
        > 60c or - 25c).
        >
        > These crazy values don't get logged on the actual weather console so I am
        > thinking the connection to the PC may be the issue? I have checked all of
        > the equipment and replaced the batteries with top of the range ones but I
        > still get the problems.
        >
        > You can see the problems yourself if you go to
        > http://www.theweatherproject.net/#Daily This is a Silverlight application
        > I have been developing, the 28.8 and and - 5.6, - 11.2 are greatly
        > inaccurate!
        >
        > (Apologies if the app doesn't load, some people are having problems with
        > Silverlight but it works fine for most people)
        >
        > Any advice appreciated!!
        >
        > Many thanks,
        > Mike
        >

        [Non-text portions of this message have been removed]





        [Non-text portions of this message have been removed]
      • workherz
        Hi all, My WS2300 has (or had) the same problem using a Serial to USB converter. All is explained in the LaCrosse Serial Port.pdf in the files section.
        Message 3 of 5 , Dec 10, 2012
        View Source
        • 0 Attachment
          Hi all, My WS2300 has (or had) the same problem using a Serial to USB converter. All is explained in the LaCrosse Serial Port.pdf in the files section.
          Basically the RS232 interface in the WS23xx is powered using the DTS and the RTS lines. Some serial to USB converters use these two lines correctly others do not, I don't which! I just build a small 5 volt PSU to power the the WS23xx RS232 interface. But I can't find the info on how I did it or which of the lines is acting as a ground and 5 volt, it was sometime ago.

          Hope this is helpful.

          John.

          --- In Lacrosse_weather_stations@yahoogroups.com, "Michael Harper" <michaeljharper@...> wrote:
          >
          > Hi Jeff,
          >
          > I was thinking I could implement some error detection logic before the data reaches my database. I developed a Silverlight application for my final year Uni project, I’m also going to build a ‘Weather Dashboard’ in MVC4 with jQuery charting which will be a lot more lightweight and accessible!
          >
          > Many thanks
          >
          > From: Jeff Bogumil
          > Sent: Saturday, December 8, 2012 1:46 PM
          > To: Lacrosse_weather_stations@yahoogroups.com
          > Subject: Re: [LacrosseWS] Open2300 crazy temperature values
          >
          >
          > > These crazy values don't get logged on the actual weather console
          > > so I am thinking the connection to the PC may be the issue?
          >
          > I'm not familiar specifically with the WS2355 model that, from your further
          > remark:
          > > the USB serial adapter provided with the weather station
          >
          > apparently may not employ the bit-banging (nonstandard) "serial port"
          > interface found on various other LaCrosse models.
          >
          > However, with a long corporate history of disdain for their weather station
          > users (e.g., unwilling to properly document proprietary comm protocols), I
          > would not put it past LaCrosse to bundle a WS with a USB adapter ill suited
          > to reliable communication; it's how they unload remaining stock. [Check
          > this group's archive for LaCrosse USB serial port adapter complaints.]
          >
          > Although typically no longer brought out to a backplane 9pin subD
          > connector, some modern PCs are still equipped with legacy UART serial port
          > mobo pin headers, so you might check for that; if present, requiring only
          > purchase or custom fabrication of a suitably configured cable.
          > Alternatively, you might consider equipping your new PC with a UART-based
          > serial port card; but of course that requires an open/available PCI,
          > PCMCIA, PCIe or miniPCIe "slot" and purchase of an appropriate accessory
          > card.
          >
          > It's also possible that the USB adapter is in no way contributing to your
          > problem. You remark that: "these crazy values don't get logged on the
          > actual weather console", and in fact some LaCrosse weather station models
          > employ a crude (undocumented) error/false-reading detection flag that, if
          > used in the WS2355 and not handled appropriately by code in your
          > Silverlight project, could hypothetically explain your observation.
          >
          > BTW, I did glance at your webpage; and found it to display OK, though
          > extremely slow loading; and Silverlight, with all its overhead, seems an
          > odd choice of a platform for the sample graphical data display. However,
          > ultimately, you may plan to incorporate streaming video with radar and/or
          > other display; possibly motivating the selection of Silverlight.
          >
          > On Sat, Dec 8, 2012 at 3:40 AM, InsanePenguin <
          > mailto:amo.la.noche.oscura%40googlemail.com> wrote:
          >
          > > **
          > >
          > >
          > > Hi everyone,
          > >
          > > I have recently switched my WS2355 to a more powerful PC, the only
          > > difference is I've had to use the USB serial adapter provided with the
          > > weather station(could plug in directly to older PC). Using open2300
          > > (log2300), sometimes the outdoor temperature is way out (things like 50 -
          > > 60c or - 25c).
          > >
          > > These crazy values don't get logged on the actual weather console so I am
          > > thinking the connection to the PC may be the issue? I have checked all of
          > > the equipment and replaced the batteries with top of the range ones but I
          > > still get the problems.
          > >
          > > You can see the problems yourself if you go to
          > > http://www.theweatherproject.net/#Daily This is a Silverlight application
          > > I have been developing, the 28.8 and and - 5.6, - 11.2 are greatly
          > > inaccurate!
          > >
          > > (Apologies if the app doesn't load, some people are having problems with
          > > Silverlight but it works fine for most people)
          > >
          > > Any advice appreciated!!
          > >
          > > Many thanks,
          > > Mike
          > >
          >
          > [Non-text portions of this message have been removed]
          >
          >
          >
          >
          >
          > [Non-text portions of this message have been removed]
          >
        • Jeff Bogumil
          I found John s 12/10/12 post last month interesting/hopeful re his efforts to devise a workaround for the (inadequately disclosed/documented by LaCrosse)
          Message 4 of 5 , Jan 5, 2013
          View Source
          • 0 Attachment
            I found John's 12/10/12 post last month interesting/hopeful re his efforts
            to devise a workaround for the (inadequately disclosed/documented by
            LaCrosse) legacy hardware/UART dependency of some LaCrosse WS models
            (specifically for my needs the WS-8610.) With LaCrosse unable or unwilling
            to support their products, as the techno world moves forward, I've been
            increasing hard pressed to keep my WS-8610 and WS-2010 PC data-logging
            operational (each WS model with its own, distinct PC hardware/software
            compatibility issues.) However, John's observation that the problem can be
            remedied simply by powering one or more of the handshaking lines (that the
            WS-8610 employs for signalling) raises questions/doubts in my mind.

            Not because I have remedies to impart, but rather hoping that this note
            might elicit further informative comments: FYI, I've been running both WS
            models with the original LaCrosse supplied MS-Windows software: the WS8610
            with "Data Recorder" and the WS2010 PC interface with "PC Weather Station."
            This NOT because I've found LaCrosse bundled software strikingly good,
            but rather because, lacking comm interface tech specifications, 3rd party
            developers have been forced to reverse engineer their communications and
            control logic, with (to my use/observation) compromised functionality.
            E.g., while Open8610 can log the current WS8610 reading, I need to
            quickly/reliably dump and then reset the 8610's 2177-record multi-channel
            cache, weekly (but have been unable to do so using Open8610 "History" or
            other utilities.)

            Thus, for several years I've been running both programs (Data Recorder and
            PC Weather Station) under Windows Vista Business 32-bit; finding that the
            "PC Weather Station" installer fails on 64-bit Windows variants; though
            Data Recorder can be installed, and seems to run OK in the 64-bit
            environment (provided a legacy hardware UART and suitable drivers.) In my
            experience with 32-bit Vista-- "PC Weather Station" works fine with several
            brands of USB-RS232 serial port adapters that are lethal to WS8610/"Data
            Recorder."

            Unhappily, I've gotten less reliable operation in recent experiments under
            Windows-7 (32-bit and/or 64-bit), despite setting the OS compatibility
            properties to Win98 or 2000 or XP or Vista. However, it does seem that,
            resorting to the incredible elaboration of Win7-Pro's virtual XP-mode,
            under 32-bit Win7p, and providing a legacy, PCIe bus UART, it's possible to
            run both weather stations with original LaCrosse software on a modern PC
            platform!

            In other experiments it seemed that "PC Weather Station" might run OK under
            Wine on FreeBSD v9; but I didn't pursue/test that fully because another
            data-logging program I want to run concurrently (for a different/unrelated
            purpose) seems incompatible with Wine.

            Such is life.

            On Mon, Dec 10, 2012 at 2:02 PM, workherz <john.g6bhb@...> wrote:

            > **
            >
            >
            > Hi all, My WS2300 has (or had) the same problem using a Serial to USB
            > converter. All is explained in the LaCrosse Serial Port.pdf in the files
            > section.
            >
            > Basically the RS232 interface in the WS23xx is powered using the DTS and
            > the RTS lines. Some serial to USB converters use these two lines correctly
            > others do not, I don't which! I just build a small 5 volt PSU to power the
            > the WS23xx RS232 interface. But I can't find the info on how I did it or
            > which of the lines is acting as a ground and 5 volt, it was sometime ago.
            >
            >
            > Hope this is helpful.
            >
            > John.
            > ---------------
            >


            [Non-text portions of this message have been removed]
          Your message has been successfully submitted and would be delivered to recipients shortly.