Loading ...
Sorry, an error occurred while loading the content.
 

Re: Resolution Question

Expand Messages
  • jps8008
    Chad, Yes I have all those keys, but pressing them all at once does nothing on my system. What do mean by while in X ? Thanks, -Jay.
    Message 1 of 18 , Mar 1, 2005
      Chad, Yes I have all those keys, but pressing them all at once does
      nothing on my system. What do mean by 'while in X'? Thanks, -Jay.


      > Huh? There's a Ctrl, an Alt, and a number pad on your keyboard, right?
      > While in X, press the Ctrl, the Alt, and the - key on the number pad
      > all at once. It is infinitely simpler than reconfiguring X. It will
      > decrease the resolution.
      >
      > Chad Martin
    • Chad Martin
      ... Ah, that s different than not understanding what pressing Ctrl+Alt+- meant, hence my confusion. X is what the graphical interface to Linux is called, in
      Message 2 of 18 , Mar 1, 2005
        jps8008 wrote:
        > Chad, Yes I have all those keys, but pressing them all at once does
        > nothing on my system. What do mean by 'while in X'? Thanks, -Jay.
        >
        >>Huh? There's a Ctrl, an Alt, and a number pad on your keyboard, right?
        >> While in X, press the Ctrl, the Alt, and the - key on the number pad
        >>all at once. It is infinitely simpler than reconfiguring X. It will
        >>decrease the resolution.

        Ah, that's different than not understanding what pressing Ctrl+Alt+-
        meant, hence my confusion. X is what the graphical interface to Linux
        is called, in the general case. XFree86 and X.org are common versions
        of X. GNOME, KDE, and others build on top of X to create full graphical
        user interfaces.

        Well, you may have only one resolution configured, then. Instead of
        running Xconfigurator, it may be easiest to just change the
        configuration file directly. It's not hard, and you won't risk losing
        the rest of your configuration. The hardest part, actually, will be
        finding the file to configure. Since you're running RH 7.3, you're
        using XFree86. Take a look in your X logs to figure out where your
        configuration file is. It'll be in /var/log, and it should match
        XFree*.log. Open it up (you may need to be root), and take a look in
        the first 20 lines or so for something like:

        (==) Using config file: "/etc/X11/xorg.conf"

        Now open that file mentioned (you'll definitely have to be root for
        this) and scroll down until you find the following:

        Section "Screen"

        In this section (there may be more than one of them) there will likely
        be many lines that begin with the word "Modes". At the end of all of
        these lines, add "800x600" with the quotes, putting some amount of white
        space between the last mode and this one.

        Once you've added your 800x600 resolution to all of your Modes, you can
        either reboot, or just restart X by pressing Ctrl+Alt+Backspace. Once
        you're back in X, try Ctrl+Alt+- again. It should cycle you through all
        of your configured resolutions.

        Let us know if you have any problems with this.

        Chad Martin
      • Mark Jensen
        I believe that the file will be: /etc/X11/XF86Config (case is sensitive, in case you aren t that familiar with *nix files, jps8008) Then just add the
        Message 3 of 18 , Mar 1, 2005
          I believe that the file will be:
          /etc/X11/XF86Config
          (case is sensitive, in case you aren't that familiar with *nix files,
          jps8008)

          Then just add the resolution(s) that you want (and are supported by your
          hardware).


          Mark


          Chad Martin wrote:
          <snip>
          > Well, you may have only one resolution configured, then. Instead of
          > running Xconfigurator, it may be easiest to just change the
          > configuration file directly. It's not hard, and you won't risk losing
          > the rest of your configuration. The hardest part, actually, will be
          > finding the file to configure. Since you're running RH 7.3, you're
          > using XFree86. Take a look in your X logs to figure out where your
          > configuration file is. It'll be in /var/log, and it should match
          > XFree*.log. Open it up (you may need to be root), and take a look in
          > the first 20 lines or so for something like:
          >
          > (==) Using config file: "/etc/X11/xorg.conf"
          <snip>
        • jps8008
          Thanks for your help Chad. The file listed in /var/log/XFree.log is called etc/X11/XF86Config-4 I went to that file and found the screen section you mentioned
          Message 4 of 18 , Mar 1, 2005
            Thanks for your help Chad. The file listed in /var/log/XFree.log is
            called etc/X11/XF86Config-4

            I went to that file and found the screen section you mentioned and
            found ONE 'mode' line which reads:
            Modes "1024x768" "800x600" "640x480"

            I guess this means I already have 640x480 configured, which is the
            resolution I want for use with my panel projector. However, pressing
            Ctrl+Alt+- (while in Gnome) still doesn't do anything.

            Any other ideas? -Jay.


            > Ah, that's different than not understanding what pressing Ctrl+Alt+-
            > meant, hence my confusion. X is what the graphical interface to Linux
            > is called, in the general case. XFree86 and X.org are common versions
            > of X. GNOME, KDE, and others build on top of X to create full
            graphical
            > user interfaces.
            >
            > Well, you may have only one resolution configured, then. Instead of
            > running Xconfigurator, it may be easiest to just change the
            > configuration file directly. It's not hard, and you won't risk losing
            > the rest of your configuration. The hardest part, actually, will be
            > finding the file to configure. Since you're running RH 7.3, you're
            > using XFree86. Take a look in your X logs to figure out where your
            > configuration file is. It'll be in /var/log, and it should match
            > XFree*.log. Open it up (you may need to be root), and take a look in
            > the first 20 lines or so for something like:
            >
            > (==) Using config file: "/etc/X11/xorg.conf"
            >
            > Now open that file mentioned (you'll definitely have to be root for
            > this) and scroll down until you find the following:
            >
            > Section "Screen"
            >
            > In this section (there may be more than one of them) there will likely
            > be many lines that begin with the word "Modes". At the end of all of
            > these lines, add "800x600" with the quotes, putting some amount of
            white
            > space between the last mode and this one.
            >
            > Once you've added your 800x600 resolution to all of your Modes, you can
            > either reboot, or just restart X by pressing Ctrl+Alt+Backspace. Once
            > you're back in X, try Ctrl+Alt+- again. It should cycle you through
            all
            > of your configured resolutions.
            >
            > Let us know if you have any problems with this.
            >
            > Chad Martin
          • Mark Jensen
            Are you sure you are using the Num Pad plus & minus? Mark
            Message 5 of 18 , Mar 1, 2005
              Are you sure you are using the Num Pad plus & minus?

              Mark


              jps8008 wrote:
              >
              > Thanks for your help Chad. The file listed in /var/log/XFree.log is
              > called etc/X11/XF86Config-4
              >
              > I went to that file and found the screen section you mentioned and
              > found ONE 'mode' line which reads:
              > Modes "1024x768" "800x600" "640x480"
              >
              > I guess this means I already have 640x480 configured, which is the
              > resolution I want for use with my panel projector. However, pressing
              > Ctrl+Alt+- (while in Gnome) still doesn't do anything.
              >
              > Any other ideas? -Jay.
              >
            • jps8008
              Mark, I m pressing Ctrl, Alt and - simutaneously.
              Message 6 of 18 , Mar 1, 2005
                Mark, I'm pressing Ctrl, Alt and - simutaneously.

                --- In LINUX_Newbies@yahoogroups.com, Mark Jensen <markjensen@c...> wrote:
                > Are you sure you are using the Num Pad plus & minus?
                >
                > Mark
                >
                >
                > jps8008 wrote:
                > >
                > > Thanks for your help Chad. The file listed in /var/log/XFree.log is
                > > called etc/X11/XF86Config-4
                > >
                > > I went to that file and found the screen section you mentioned and
                > > found ONE 'mode' line which reads:
                > > Modes "1024x768" "800x600" "640x480"
                > >
                > > I guess this means I already have 640x480 configured, which is the
                > > resolution I want for use with my panel projector. However, pressing
                > > Ctrl+Alt+- (while in Gnome) still doesn't do anything.
                > >
                > > Any other ideas? -Jay.
                > >
              • Chad Martin
                ... Weird. Well, if you change that line to read Modes 640x480 and restart X, you really should have only that resolution. I don t think I ve ever seen the
                Message 7 of 18 , Mar 1, 2005
                  jps8008 wrote:
                  > Thanks for your help Chad. The file listed in /var/log/XFree.log is
                  > called etc/X11/XF86Config-4
                  >
                  > I went to that file and found the screen section you mentioned and
                  > found ONE 'mode' line which reads:
                  > Modes "1024x768" "800x600" "640x480"
                  >
                  > I guess this means I already have 640x480 configured, which is the
                  > resolution I want for use with my panel projector. However, pressing
                  > Ctrl+Alt+- (while in Gnome) still doesn't do anything.
                  >
                  > Any other ideas? -Jay.

                  Weird. Well, if you change that line to read

                  Modes "640x480"

                  and restart X, you really should have only that resolution. I don't
                  think I've ever seen the Ctrl+Alt+- thing not work before.

                  If you do change your mode line, then comment out the one you have (put
                  a # character in front of it) and add a new line like I describe above.
                  That way, when you want to use the other resolutions, you can just
                  comment out one line and uncomment the other.

                  Chad Martin
                • Mark Jensen
                  Well, if you are using the number pad plus and the number pad minus to switch, and it still isn t working, try this: In a terminal, as root, type in
                  Message 8 of 18 , Mar 1, 2005
                    Well, if you are using the number pad plus and the number pad minus to
                    switch, and it still isn't working, try this:

                    In a terminal, as root, type in redhat-config-display
                    and see if you can select a different resolution there.

                    Mark
                  • jps8008
                    Aha it works! I just deleted the two other resolutions (in gedit) and then hit Ctrl, Alt and Backspace - Presto, instant 640x480! Didn t even have to reboot.
                    Message 9 of 18 , Mar 2, 2005
                      Aha it works! I just deleted the two other resolutions (in gedit) and
                      then hit Ctrl, Alt and Backspace - Presto, instant 640x480! Didn't
                      even have to reboot. Thanks for you excellent help.Chad!

                      Now I'll bet getting the scroll wheel on my mouse to work is even more
                      complicated.
                      Still, I'm not going back to windows.-Jay.



                      > Weird. Well, if you change that line to read
                      >
                      > Modes "640x480"
                      >
                      > and restart X, you really should have only that resolution. I don't
                      > think I've ever seen the Ctrl+Alt+- thing not work before.
                      >
                      > If you do change your mode line, then comment out the one you have (put
                      > a # character in front of it) and add a new line like I describe above.
                      > That way, when you want to use the other resolutions, you can just
                      > comment out one line and uncomment the other.
                      >
                      > Chad Martin
                    • Mark Jensen
                      ... Actually, it is generally just as easy (though maybe a bit more obscure as to what you are doing or why). Add this line to your mouse input defintion in
                      Message 10 of 18 , Mar 2, 2005
                        jps8008 wrote:
                        >
                        > Aha it works! I just deleted the two other resolutions (in gedit) and
                        > then hit Ctrl, Alt and Backspace - Presto, instant 640x480! Didn't
                        > even have to reboot. Thanks for you excellent help.Chad!
                        >
                        > Now I'll bet getting the scroll wheel on my mouse to work is even more
                        > complicated.
                        > Still, I'm not going back to windows.-Jay.
                        >

                        Actually, it is generally just as easy (though maybe a bit more obscure
                        as to what you are doing or why).

                        Add this line to your mouse input defintion in your XF86Conf file:
                        Option "ZAxisMapping" "4 5"
                        and you should have scrolling goodness. :)


                        Mark
                      • Chad Martin
                        ... Don t you also have to add: Option Buttons 5 FYI, this is for my USB mouse with a scroll wheel in the X config: Section InputDevice Identifier USB
                        Message 11 of 18 , Mar 2, 2005
                          Mark Jensen wrote:
                          >>Now I'll bet getting the scroll wheel on my mouse to work is even more
                          >>complicated.
                          >
                          > Actually, it is generally just as easy (though maybe a bit more obscure
                          > as to what you are doing or why).
                          >
                          > Add this line to your mouse input defintion in your XF86Conf file:
                          > Option "ZAxisMapping" "4 5"
                          > and you should have scrolling goodness. :)

                          Don't you also have to add:

                          Option "Buttons" "5"

                          FYI, this is for my USB mouse with a scroll wheel in the X config:

                          Section "InputDevice"
                          Identifier "USB Mouse"
                          Driver "mouse"
                          Option "Protocol" "ImPS/2"
                          Option "Device" "/dev/input/mice"
                          Option "ZAxisMapping" "4 5"
                          Option "Buttons" "5"
                          EndSection

                          Adding those last two options to whatever you have will do the trick.

                          Chad Martin
                        • Scott
                          ... Hash: SHA1 ... Not with a PS/2, at least. Although FreeBSD, NetBSD and Linux all differ in my xorg.conf (minor things, such as one calling the mouse
                          Message 12 of 18 , Mar 2, 2005
                            -----BEGIN PGP SIGNED MESSAGE-----
                            Hash: SHA1

                            On Wed, Mar 02, 2005 at 10:30:08PM -0600, Chad Martin wrote:
                            >
                            > Mark Jensen wrote:
                            > >>Now I'll bet getting the scroll wheel on my mouse to work is even more
                            > >>complicated.
                            > >
                            > > Actually, it is generally just as easy (though maybe a bit more obscure
                            > > as to what you are doing or why).
                            > >
                            > > Add this line to your mouse input defintion in your XF86Conf file:
                            > > Option "ZAxisMapping" "4 5"
                            > > and you should have scrolling goodness. :)
                            >
                            > Don't you also have to add:
                            >
                            > Option "Buttons" "5"

                            Not with a PS/2, at least.
                            Although FreeBSD, NetBSD and Linux all differ in my xorg.conf (minor
                            things, such as one calling the mouse /dev/psaux, /dev/psm0 and
                            /dev/wsmouse) all let me use the scrollwheel (MS optical PS2 mouse)
                            with only the ZAxisMapping line.

                            I wonder if the Buttons 5 is a USB thing?

                            Chad, what happens if you comment that line out, does the scrollwheel
                            stop working?


                            - --

                            Scott Robbins

                            PGP keyID EB3467D6
                            ( 1B48 077D 66F6 9DB0 FDC2 A409 FA54 EB34 67D6 )
                            gpg --keyserver pgp.mit.edu --recv-keys EB3467D6

                            Riley: When I'm around you Buffy I find myself needing to know
                            the plural of apocalypse.

                            -----BEGIN PGP SIGNATURE-----
                            Version: GnuPG v1.4.0 (FreeBSD)

                            iD8DBQFCJpeR+lTVdes0Z9YRAopCAJ9j5zQog0mfL2b9C1KzAtX6oqbOhgCbBFP3
                            dtS7B6+nzpo1mGP0lRBaNMo=
                            =9ZMw
                            -----END PGP SIGNATURE-----
                          • Chad Martin
                            ... Nope. It works without the 5 button option. Learn something new every day, I guess. I was really just working off of what other people have told me in
                            Message 13 of 18 , Mar 2, 2005
                              Scott wrote:
                              >>>Don't you also have to add:
                              >>>
                              >>>Option "Buttons" "5"
                              >
                              > Not with a PS/2, at least.
                              > Although FreeBSD, NetBSD and Linux all differ in my xorg.conf (minor
                              > things, such as one calling the mouse /dev/psaux, /dev/psm0 and
                              > /dev/wsmouse) all let me use the scrollwheel (MS optical PS2 mouse)
                              > with only the ZAxisMapping line.
                              >
                              > I wonder if the Buttons 5 is a USB thing?
                              >
                              > Chad, what happens if you comment that line out, does the scrollwheel
                              > stop working?

                              Nope. It works without the 5 button option. Learn something new every
                              day, I guess. I was really just working off of what other people have
                              told me in the past, and defining your number of buttons along with the
                              Z Axis Mapping was standard fare.

                              Knowing is half the battle!

                              Chad Martin
                            • jps8008
                              Mark, I had the words ZAxisMapping 4 5 in my file so I typed the word Option in front of them and put quotation marks as you described. Doesn t work....maybe I
                              Message 14 of 18 , Mar 3, 2005
                                Mark, I had the words ZAxisMapping 4 5 in my file so I typed the word
                                Option in front of them and put quotation marks as you described.
                                Doesn't work....maybe I should leave out the word Option??? -Jay.

                                >
                                > Actually, it is generally just as easy (though maybe a bit more obscure
                                > as to what you are doing or why).
                                >
                                > Add this line to your mouse input defintion in your XF86Conf file:
                                > Option "ZAxisMapping" "4 5"
                                > and you should have scrolling goodness. :)
                                >
                                >
                                > Mark
                              Your message has been successfully submitted and would be delivered to recipients shortly.