Loading ...
Sorry, an error occurred while loading the content.

Multiprocessor shutdown

Expand Messages
  • nodrag70
    Hello all, Thanks to the incredible stability of linux, I know almost nothing about Linux. That is, I have a server in my basement that humms along nicely for
    Message 1 of 12 , Nov 30, 2004
    • 0 Attachment
      Hello all,
      Thanks to the incredible stability of linux, I know almost nothing
      about Linux.

      That is, I have a server in my basement that humms along nicely for
      years without attention. Any attention. In fact, it gets shut down
      when I go on vacation, etc. to conserve power but otherwise just
      happily serves up any files I ask for and other menial tasks for me
      on occasion.

      That said, I'm wondering if I might be able to save some $$$ by
      having it shut down automatically when I'm not at home (during work
      days). However, this wasn't possible with older kernels because
      automatic shutdown wasn't supported in SMP mode.

      Since it's been a few years since I tinkered with Linux, I wanted to
      pose the question to you guys who keep up on this kind of thing- has
      this been fixed? Will Linux now perform complete shutdowns on
      multiprocessor systems?

      Thanks for any help you can provide!
    • ed
      ... Hash: SHA1 On Tue, 30 Nov 2004 22:07:33 -0000 ... You know it s stable right? But this is kind of impossible, if you know nothing, how do you know it or
      Message 2 of 12 , Dec 1, 2004
      • 0 Attachment
        -----BEGIN PGP SIGNED MESSAGE-----
        Hash: SHA1

        On Tue, 30 Nov 2004 22:07:33 -0000
        "nodrag70" <nodrag70@...> wrote:

        > Hello all,
        > Thanks to the incredible stability of linux, I know almost nothing
        > about Linux.

        You know it's stable right? But this is kind of impossible, if you know
        nothing, how do you know it or the GNU applications are stable?

        > That said, I'm wondering if I might be able to save some $$$ by
        > having it shut down automatically when I'm not at home (during work
        > days). However, this wasn't possible with older kernels because
        > automatic shutdown wasn't supported in SMP mode.

        The APM module can perform a power down, AFAIK, at least with APM loaded
        the system powers down with a shutdown command.

        If you own a Zalman heatsink/fan, you will know that the fan does not
        spin fast enough for the BIOS to be happy that the CPU is being cooled.
        Therefore, you can just call a reboot and the system will power off
        during the POST test.

        > Since it's been a few years since I tinkered with Linux, I wanted to
        > pose the question to you guys who keep up on this kind of thing- has
        > this been fixed? Will Linux now perform complete shutdowns on
        > multiprocessor systems?

        I was not aware that is ever was not able to. Either of the methods
        above should accomplish what you need. What kernel version are you
        running?

        - --
        /-- _| | Regards. Please note, my PGP key ID has changed.
        |-- / | | If you are planning on sending me something encrypted
        \__ \_| | please update your keyring. Debian/OpenBSD. 53C9FC6C.
        -----BEGIN PGP SIGNATURE-----
        Version: GnuPG v1.2.4 (GNU/Linux)

        iD8DBQFBriofjtZArFPJ/GwRAhvbAJ0SbuzuniZSOIqf5xySVSLTabrynQCferDw
        Q4dM5ZZle6aMv/iJIjlTJOw=
        =D+Ov
        -----END PGP SIGNATURE-----
      • nodrag70
        What I was saying is that I set up this system years ago, and have since forgotten almost all I had to learn to set it up because I haven t had to touch it
        Message 3 of 12 , Dec 1, 2004
        • 0 Attachment
          What I was saying is that I set up this system years ago, and have
          since forgotten almost all I had to learn to set it up because I
          haven't had to touch it since it was set up. I'm sorry I wasn't more
          clear. Since I haven't tried to keep my Linux knowledge current, I
          also don't know what new developments and/or improvements have been
          made in the last 2 or 3 years.

          I think I need to re-ask my question.

          When I set up this server, Red Hat Linux was brand new and that's
          what I used. I don't know what revision kernel I have, but I do know
          that at the time Linux was not capable of powering down when running
          in multiprocessor mode. I'm not sure what you're getting at with the
          CPU cooling fan, but suffice it to say that it's not an option on
          this server.

          That said, I also don't know if it was just Red Hat that wasn't
          capable of powering down. It gets to the prompt "power down now"
          after shutting down all services but powering down was manually
          operated.

          Is there anyone out there with experience getting power down
          capability with multi-processor mode? It would be very helpful to
          know if this has been resolved or if it was only Red Hat!

          Thanks!
        • Chad Martin
          ... That sounds more like a power management issue than a multiprocessor issue. I know that ACPI systems allow software shutdowns, but that would require a
          Message 4 of 12 , Dec 2, 2004
          • 0 Attachment
            nodrag70 wrote:
            > That said, I also don't know if it was just Red Hat that wasn't
            > capable of powering down. It gets to the prompt "power down now"
            > after shutting down all services but powering down was manually
            > operated.
            >
            > Is there anyone out there with experience getting power down
            > capability with multi-processor mode? It would be very helpful to
            > know if this has been resolved or if it was only Red Hat!

            That sounds more like a power management issue than a multiprocessor
            issue. I know that ACPI systems allow software shutdowns, but that
            would require a newer BIOS. I have a strong feeling that it will be
            your hardware holding you back, not the software.

            Chad Martin
          • Hylton Conacher (ZR1HPC)
            ... Using cron to specify the time to run a script, create a script that will issue the command shutdown -h now . See man shutdown for more options. -- The
            Message 5 of 12 , Dec 2, 2004
            • 0 Attachment
              nodrag70 wrote:
              >
              > Hello all,
              > Thanks to the incredible stability of linux, I know almost nothing
              > about Linux.
              >
              > That is, I have a server in my basement that humms along nicely for
              > years without attention. Any attention. In fact, it gets shut down
              > when I go on vacation, etc. to conserve power but otherwise just
              > happily serves up any files I ask for and other menial tasks for me
              > on occasion.
              >
              > That said, I'm wondering if I might be able to save some $$$ by
              > having it shut down automatically when I'm not at home (during work
              > days). However, this wasn't possible with older kernels because
              > automatic shutdown wasn't supported in SMP mode.
              >
              > Since it's been a few years since I tinkered with Linux, I wanted to
              > pose the question to you guys who keep up on this kind of thing- has
              > this been fixed? Will Linux now perform complete shutdowns on
              > multiprocessor systems?

              Using cron to specify the time to run a script, create a script that
              will issue the command 'shutdown -h now'. See 'man shutdown for more
              options.

              --
              The Little Helper
              ========================================================================
              Hylton Conacher - Linux user # 229959 at http://counter.li.org
              Currently using SuSE 9.0 Professional with KDE 3.1
              Licenced Windows user
              ========================================================================
            • ed
              ... Hash: SHA1 On Thu, 02 Dec 2004 04:04:07 -0000 ... Try: modprobe apm ; shutdown -h now ; It *should* power down. Your mobo will have to be ATX. And if you
              Message 6 of 12 , Dec 2, 2004
              • 0 Attachment
                -----BEGIN PGP SIGNED MESSAGE-----
                Hash: SHA1

                On Thu, 02 Dec 2004 04:04:07 -0000
                "nodrag70" <nodrag70@...> wrote:

                > Is there anyone out there with experience getting power down
                > capability with multi-processor mode? It would be very helpful to
                > know if this has been resolved or if it was only Red Hat!

                Try:

                modprobe apm ; shutdown -h now ;

                It *should* power down. Your mobo will have to be ATX. And if you really
                want to know, there's two cables in the ATX mobo loom that tell the PSU
                to terminate supply.

                At one point I soldered the green/black (I think it was) cables
                together with a switch to prevent the PSU from powering off.. I forget
                why now.

                - --
                /-- _| | Regards. Please note, my PGP key ID has changed.
                |-- / | | If you are planning on sending me something encrypted
                \__ \_| | please update your keyring. Debian/OpenBSD. 53C9FC6C.
                -----BEGIN PGP SIGNATURE-----
                Version: GnuPG v1.2.4 (GNU/Linux)

                iD8DBQFBr2F9jtZArFPJ/GwRApVUAJ9468id2t3CnopvFb/73G2jbrrrWACfcTeY
                TKD9hASANbEHlWvgiFHX2J8=
                =LSEM
                -----END PGP SIGNATURE-----
              • nodrag70
                I regularly use this command remotely to initiate the shutdown sequence, and it completes with the statement power down after ending all processes. I have
                Message 7 of 12 , Dec 2, 2004
                • 0 Attachment
                  I regularly use this command remotely to initiate the shutdown
                  sequence, and it completes with the statement "power down" after
                  ending all processes. I have to press the power button manually
                  (it's not a toggle like the old AT machines, it's a momentary
                  pushbutton).

                  This is what I've been trying to explain! Is anyone here familiar
                  with this issue? I can't be the only one to be familiar with it!

                  > Using cron to specify the time to run a script, create a script
                  that
                  > will issue the command 'shutdown -h now'. See 'man shutdown for
                  more
                  > options.
                  >
                • Chad Martin
                  ... OK. If you have an ATX power supply, then you probably just have to upgrade to a newer version of your distro, or load an APM module, if you have it. The
                  Message 8 of 12 , Dec 2, 2004
                  • 0 Attachment
                    nodrag70 wrote:
                    > I regularly use this command remotely to initiate the shutdown
                    > sequence, and it completes with the statement "power down" after
                    > ending all processes. I have to press the power button manually
                    > (it's not a toggle like the old AT machines, it's a momentary
                    > pushbutton).
                    >
                    > This is what I've been trying to explain! Is anyone here familiar
                    > with this issue? I can't be the only one to be familiar with it!

                    OK. If you have an ATX power supply, then you probably just have to
                    upgrade to a newer version of your distro, or load an APM module, if you
                    have it. The reason we're all kinda wondering what the problem is is
                    that none of us really have it. It's not an issue any more. Just upgrade.

                    Chad Martin
                  • ed
                    ... Hash: SHA1 On Thu, 02 Dec 2004 21:41:49 -0000 ... Does your kernel have APM support though, and if as a module, is the module loaded? - -- /-- _| |
                    Message 9 of 12 , Dec 2, 2004
                    • 0 Attachment
                      -----BEGIN PGP SIGNED MESSAGE-----
                      Hash: SHA1

                      On Thu, 02 Dec 2004 21:41:49 -0000
                      "nodrag70" <nodrag70@...> wrote:

                      > I regularly use this command remotely to initiate the shutdown
                      > sequence, and it completes with the statement "power down" after
                      > ending all processes. I have to press the power button manually
                      > (it's not a toggle like the old AT machines, it's a momentary
                      > pushbutton).

                      Does your kernel have APM support though, and if as a module, is the
                      module loaded?

                      - --
                      /-- _| | Regards. Please note, my PGP key ID has changed.
                      |-- / | | If you are planning on sending me something encrypted
                      \__ \_| | please update your keyring. Debian/OpenBSD. 53C9FC6C.
                      -----BEGIN PGP SIGNATURE-----
                      Version: GnuPG v1.2.4 (GNU/Linux)

                      iD8DBQFBr55UjtZArFPJ/GwRAk79AJ98Onlgi12pkzoR5JcAJCLafk6CsgCdGOdF
                      Ft/LVDm0sl0JNFOTpUxnYd8=
                      =IFvP
                      -----END PGP SIGNATURE-----
                    • gblaisepublic
                      ... My PC doesn t power-off on shutting down? Well, you are not a lone user coming to this problem. Make sure of all these things first- *Check your
                      Message 10 of 12 , Dec 3, 2004
                      • 0 Attachment
                        --- In LINUX_Newbies@yahoogroups.com, "nodrag70" <nodrag70@y...>
                        wrote:
                        >
                        >
                        > I regularly use this command remotely to initiate the shutdown
                        > sequence, and it completes with the statement "power down" after
                        > ending all processes. I have to press the power button manually
                        > (it's not a toggle like the old AT machines, it's a momentary
                        > pushbutton).
                        >
                        > This is what I've been trying to explain! Is anyone here familiar
                        > with this issue? I can't be the only one to be familiar with it!
                        >


                        My PC doesn't power-off on shutting down?

                        Well, you are not a lone user coming to this problem. Make sure of
                        all these things first-

                        *Check your motherboard for APM support

                        *Your kernel is compiled with the APM support and the 'real-mode
                        flag' is enabled

                        *For 2.2 kernels add the "apm=on" flag in the /etc/lilo.conf (for
                        append="" secion) or pass at the boot time

                        *For SMP kernels add the "apm=power-off" also in /etc/lilo.conf or
                        pass at the boot time

                        *For 2.4 kernels, do "insmod apm power_off=1"

                        *Use the appropriate command like poweroff or shutdown -h to
                        shutdown your system. If you use ctr-alt-del on the command line,
                        change the line in /etc/inittab to begin with 'ca:'

                        *If you still can't make it work, try using ACPI instead of APM
                        (only for 2.4 kernels). ACPI does not need any other boot parameters
                      • Bob Hodges
                        ... My PC doesn t power-off on shutting down? Well, you are not a lone user coming to this problem. Make sure of all these things first- *Check your
                        Message 11 of 12 , Dec 3, 2004
                        • 0 Attachment
                          ----------begin quote-----------
                          My PC doesn't power-off on shutting down? Well, you are not a lone user
                          coming to this problem. Make sure of all these things first-

                          *Check your motherboard for APM support

                          *Your kernel is compiled with the APM support and the 'real-mode
                          flag' is enabled

                          *For 2.2 kernels add the "apm=on" flag in the /etc/lilo.conf (for
                          append="" secion) or pass at the boot time

                          *For SMP kernels add the "apm=power-off" also in /etc/lilo.conf or
                          pass at the boot time

                          *For 2.4 kernels, do "insmod apm power_off=1"

                          *Use the appropriate command like poweroff or shutdown -h to
                          shutdown your system. If you use ctr-alt-del on the command line,
                          change the line in /etc/inittab to begin with 'ca:'

                          *If you still can't make it work, try using ACPI instead of APM
                          (only for 2.4 kernels). ACPI does not need any other boot parameters
                          ---------end quote----------

                          At last, after 4 days, the poor guy get's a real answer.

                          Bob




                          To unsubscribe from this list, please email
                          LINUX_Newbies-unsubscribe@yahoogroups.com & you will be removed.
                          Yahoo! Groups Links
                        • Chad Martin
                          ... Yeah, see I ve never worried about it until I started using ACPI, then is just worked, so I wasn t exactly sure what the problem was, especially since he
                          Message 12 of 12 , Dec 3, 2004
                          • 0 Attachment
                            Bob Hodges wrote:
                            > ----------begin quote-----------
                            > *If you still can't make it work, try using ACPI instead of APM
                            > (only for 2.4 kernels). ACPI does not need any other boot parameters
                            > ---------end quote----------
                            >
                            > At last, after 4 days, the poor guy get's a real answer.

                            Yeah, see I've never worried about it until I started using ACPI, then
                            is just worked, so I wasn't exactly sure what the problem was,
                            especially since he was claiming that it was a problem unique to
                            multiprocessor machines.

                            Chad
                          Your message has been successfully submitted and would be delivered to recipients shortly.