Loading ...
Sorry, an error occurred while loading the content.

fstab question

Expand Messages
  • Tony Gist
    What entries do I need to give all users read-write access to a mounted partition? The current entry is: /dev/hda2 /bkup ext2 defaults 1 2 When I try to save
    Message 1 of 5 , Apr 29, 2004
    • 0 Attachment
      What entries do I need to give all users read-write access to a mounted
      partition?

      The current entry is:

      /dev/hda2 /bkup ext2 defaults 1 2

      When I try to save to the above partition I get an Access Denied mesage.
    • Chad Martin
      ... That sounds like you re being denied write access to /etc/fstab rather than the partition itself. Are you root when you re editing that file? Chad Martin
      Message 2 of 5 , Apr 29, 2004
      • 0 Attachment
        Tony Gist wrote:
        > What entries do I need to give all users read-write access to a mounted
        > partition?
        >
        > The current entry is:
        >
        > /dev/hda2 /bkup ext2 defaults 1 2
        >
        > When I try to save to the above partition I get an Access Denied mesage.

        That sounds like you're being denied write access to /etc/fstab rather
        than the partition itself. Are you root when you're editing that file?

        Chad Martin
      • Tony Gist
        ... Thanks for your reply. I alterrd the fstab file as su with no problems. The acces denied message (in Konqueror) occurs when I try to copy files (as a
        Message 3 of 5 , Apr 29, 2004
        • 0 Attachment
          On Thursday 29 Apr 2004 17:53, Chad Martin wrote:

          > That sounds like you're being denied write access to /etc/fstab rather
          > than the partition itself. Are you root when you're editing that file?
          >

          Thanks for your reply.

          I alterrd the fstab file as su with no problems. The acces denied message (in
          Konqueror) occurs when I try to copy files (as a user) to the partion
          listed in fstab as:

          /dev/hda2 /bkup ext2 defaults 1 2
        • Horror Vacui
          On Thu, 29 Apr 2004 19:07:48 +0100 ... To be sure, you are copying to /bkup/somefile and have mounted the drive with beforehand? Sorry if my asking this
          Message 4 of 5 , Apr 29, 2004
          • 0 Attachment
            On Thu, 29 Apr 2004 19:07:48 +0100
            Tony wrote:

            > On Thursday 29 Apr 2004 17:53, Chad Martin wrote:
            >
            > > That sounds like you're being denied write access to /etc/fstab
            > > rather than the partition itself. Are you root when you're editing
            > > that file?
            > >
            >
            > Thanks for your reply.
            >
            > I alterrd the fstab file as su with no problems. The acces denied
            > message (in Konqueror) occurs when I try to copy files (as a user)
            > to the partion listed in fstab as:
            >
            > /dev/hda2 /bkup ext2 defaults 1 2

            To be sure, you are copying to /bkup/somefile and have mounted the drive
            with beforehand?

            Sorry if my asking this offends you, but it should work with this
            settings. defaults mean mounting read-write AFAIK, and that will
            override any permissions you have set on the mountpoint (/bkup).

            Also, are you trying to write to /bkup/ directly, or to some subdir of
            /bkup? If so, what are the permissions on the subdir?

            Cheers

            --
            Horror Vacui

            Registered Linux user #257714

            Go get yourself... counted: http://counter.li.org/
            - and keep following the GNU.
          • Tony Gist
            ... The partition is auto-mounted ... No, certainly doesn t , grateful for any help! ... Trying to write directly (Using Mandrake 10 Community - if that is any
            Message 5 of 5 , Apr 29, 2004
            • 0 Attachment
              On Thursday 29 Apr 2004 19:22, Horror Vacui wrote:

              > > /dev/hda2 /bkup ext2 defaults 1 2
              >
              > To be sure, you are copying to /bkup/somefile and have mounted the drive
              > with beforehand?

              The partition is auto-mounted

              > Sorry if my asking this offends you,

              No, certainly doesn't , grateful for any help!

              > Also, are you trying to write to /bkup/ directly, or to some subdir of
              > /bkup? If so, what are the permissions on the subdir?

              Trying to write directly

              (Using Mandrake 10 Community - if that is any help)
            Your message has been successfully submitted and would be delivered to recipients shortly.