Loading ...
Sorry, an error occurred while loading the content.

sendmail upgrade RH8

Expand Messages
  • Dave Gorman
    I currently have sendmail-8.12.8 wanting to upgrade to 8.12.9 (because of the security flaw that was fixed...). When I attempt to install the upgrade I get:
    Message 1 of 1 , May 1, 2003
    • 0 Attachment
      I currently have sendmail-8.12.8 wanting to upgrade to 8.12.9 (because
      of the security flaw that was fixed...). When I attempt to install the
      upgrade I get:

      error: Failed dependencies:
      libcrypto.so.4 is needed by sendmail-8.12.9-4
      libssl.so.4 is needed by sendmail-8.12.9-4
      libwrap.so.0 is needed by sendmail-8.12.9-4

      Apparently libcrypto & libssl (unsure about libwrap) are part of an
      openssl upgrade. I currently have openssl-0.9.6b. Attempting to
      upgrade to openssl-0.9.7a I get:

      error: Failed dependencies:
      libcrypto.so.2 is needed by (installed) python-2.2.1-17
      libcrypto.so.2 is needed by (installed) gnome-vfs2-2.0.2-5
      and so on for about 70 more lines about libcrypto.so.2 and
      libsssl.so.2.

      Now it isn't necessarily crucial that I upgrade sendmail right now as
      it's going to be inaccessible from the outside world until I get it
      set up the way I want. But eventually I'll want to upgrade and will
      surely face the same problem.

      What are my options?

      --
      Dave
    Your message has been successfully submitted and would be delivered to recipients shortly.