Loading ...
Sorry, an error occurred while loading the content.

Re: [LINUX_Newbies] Problems compiling ethernet drivers

Expand Messages
  • Scott Robbins
    ... This is where I feel RH strikes an excellent balance--making it newbie friendly as does Mandrake, but making it easier to get your hands dirty. ... I m a
    Message 1 of 16 , Aug 31, 2002
    • 0 Attachment
      On Sun, Sep 01, 2002 at 04:27:39AM -0000, phil_is_phil wrote:
      > Hi all,
      >
      > First, an apology to everyone for twice posting my last query. Thanks
      > to everyone for their replies.
      >
      > I like Red Hat okay, but I find I'm having to do manually a lot of
      > the stuff Mandrake used to automagically. On the one hand, this is a
      > bit of a drag and kind of frustrating when things don't work out, but
      > on the other hand, it's nice that I'm learning about Linux by doing
      > this stuff myself.


      This is where I feel RH strikes an excellent balance--making it newbie
      friendly as does Mandrake, but making it easier to get your hands dirty.

      >
      > One thing I need help with is compiling some ethernet drivers for use
      > on my system. I still don't really understand all the magic behind
      > compiling software, and find I just follow the instructions, hope for
      > the best and feel lost when things go wrong.

      I'm a bit surprised--RH generally has excellent ethernet support OOTB
      (Out of the Box). What sort of ethernet card are you using. Are you
      sure that it's not recognized.

      If you do
      /sbin/ifconfig eth0
      do you get anything?

      (We once had this issue before--someone thought that their card wasn't
      recognized and it turned out that it was, it wasn't getting an address
      which is a completely different issue.)

      As for compiling software, it's often straightforward--if you start
      running into trouble that usually means that either the coders have
      erred or, more likely that their instructions weren't quite clear and
      you made a small error--unfortunately, these small errors can really
      mess us up with software code. :)
      >
      > Well, something went wrong when I tried to compile these ethernet
      > drivers. According to the makefile, I'm to do 'make clean', 'make
      > depend' and 'make all'. I did 'make clean' and things seemed to go
      > okay, but 'make depend' said something like 'no rules given on how to
      > make target "depend".

      This often means that you weren't in the right directory. Believe me,
      I"m not saying this is definitely the case, but I remember when I first
      tried to do this, and thought it was their fault--it turned out,
      amazingly enough, to be an error I made.

      However, if you don't mind, I'd really like to start at the beginning
      with this--as I said, RH usually has very good ethernet support out of
      the box, so, I'd like to see the results of the /sbin/ifconfig eth0.

      A couple of other points that will probably help us help you--let us
      know which version of RH, and which ethernet card. Sometimes, you'll
      find that someone will have gone through the exact same experience, and
      already done all the research for you. :)

      (I know you uploaded the file, but sometimes, especially if someone is
      busy, it's good to just mention which card, etc--in this case, I did go
      to look for it, but see below)



      Stop.' I tried 'make all' anyways, but of
      > course it didn't work. Can someone give me some ideas to try? I took
      > the liberty of uploading the Makefile, the readme and the source code
      > to the files section (look for 'ethdrv.zip'). If that helps anyone.

      (And it would help of course. See above where I said see below. :)


      I don't see it up there. :-(



      >

      --
      Scott

      PGP keyID EB3467D6 (1B48 077d 66F6 9DB0 FDC2 A409 FA54 D575 EB34 67D6 )
      gpg --keyserver pgp.mit.edu --recv-keys EB3467D6

      Spike: You won. Alright? You came in and you killed them,
      and you took their land. That's what conquering nations do. It's
      what Caeser did, and he's not going around saying I came, I conquered,
      I felt really bad about it.


      [Non-text portions of this message have been removed]
    • phil_is_phil
      ... OOTB ... you ... It s a D-Link DFE 538TX 10/100. /sbin/ifconfig eth0 gives eth0: error fetching interface information: Device not found . When booting I
      Message 2 of 16 , Sep 1, 2002
      • 0 Attachment
        > I'm a bit surprised--RH generally has excellent ethernet support
        OOTB
        > (Out of the Box). What sort of ethernet card are you using. Are
        you
        > sure that it's not recognized.
        >
        > If you do
        > /sbin/ifconfig eth0
        > do you get anything?

        It's a D-Link DFE 538TX 10/100. '/sbin/ifconfig eth0' gives 'eth0:
        error fetching interface information: Device not found'. When booting
        I also see "FAILED" after "fetching ethernet information" or whatever
        it says. The card wasn't listed in the graphical network config tool
        either, which is why I first suspected it wasn't supported. I think
        it's only a Canadian model (works better in colder climates? Who
        knows! :0)


        > > ...but 'make depend' said something like 'no rules given on how
        to
        > > make target "depend".
        >
        > This often means that you weren't in the right directory. Believe
        me,
        > I"m not saying this is definitely the case, but I remember when I
        first
        > tried to do this, and thought it was their fault--it turned out,
        > amazingly enough, to be an error I made.

        I tried this from /usr/src/redhat. It seems that the Readme says to
        do it from /usr/src/linux, but there is no such dir on my system, so
        I tried it from /usr/src/redhat instead.

        > However, if you don't mind, I'd really like to start at the
        beginning
        > with this--as I said, RH usually has very good ethernet support out
        of
        > the box, so, I'd like to see the results of the /sbin/ifconfig
        eth0.

        See above for error msg.

        > A couple of other points that will probably help us help you--let us
        > know which version of RH, and which ethernet card.

        RH 7.3. See above for make of card.

        Thanks for the reply, but I'm still as mystified as ever. I wish I
        knew someone nearby who was a Linux guru and could come and help me!

        Hope someone can help me still!

        ph!L
      • Scott Robbins
        ... Yup, it s not recognized. ... Is there a /usr/src/linux-2.4? That would be RH s answer to /usr/src/linux. If you don t have that, then install
        Message 3 of 16 , Sep 1, 2002
        • 0 Attachment
          On Mon, Sep 02, 2002 at 01:04:05AM -0000, phil_is_phil wrote:
          > >
          > > If you do
          > > /sbin/ifconfig eth0
          > > do you get anything?
          >
          > It's a D-Link DFE 538TX 10/100. '/sbin/ifconfig eth0' gives 'eth0:
          > error fetching interface information: Device not found'. When booting
          > I also see "FAILED" after "fetching ethernet information" or whatever
          > it says. The card wasn't listed in the graphical network config tool
          > either, which is why I first suspected it wasn't supported. I think
          > it's only a Canadian model (works better in colder climates? Who
          > knows! :0)

          Yup, it's not recognized.
          >
          >
          > > > ...but 'make depend' said something like 'no rules given on how
          > to
          > > > make target "depend".
          > >
          > > This often means that you weren't in the right directory. Believe
          > me,
          > > I"m not saying this is definitely the case, but I remember when I
          > first
          > > tried to do this, and thought it was their fault--it turned out,
          > > amazingly enough, to be an error I made.
          >
          > I tried this from /usr/src/redhat. It seems that the Readme says to
          > do it from /usr/src/linux, but there is no such dir on my system, so
          > I tried it from /usr/src/redhat instead.

          Is there a /usr/src/linux-2.4? That would be RH's answer to
          /usr/src/linux. If you don't have that, then install kernel-src.rpm

          (It'll be something like kernel-source-2.4.18.rpm probably on the second
          CD.)
          >
          >
          > Thanks for the reply, but I'm still as mystified as ever. I wish I
          > knew someone nearby who was a Linux guru and could come and help me!
          >
          > Hope someone can help me still!

          One other possibility. (Assuming that installing kernel-src rpms
          doesn't help). I once spent a few hours on the net with ymessenger
          trying to help someone get their NIC working. Eventually, as it became
          later and later, we gave up and I suggested he try another card
          (Netgears are almost always supported out of the box by RH and go for
          20-30 dollars) as it might save a lot of aggravation. I got an email
          from him the following day--he'd gone out, bought the netgear, booted up
          and the card was recognized upon boot.

          I know that's not a ~good~ answer, but sometimes, it's the easiest.



          --
          Scott

          PGP KeyID EB3467D6 (1B48 077D 66F6 9DB0 FDC2 A409 FA54 D575 EB34 67D6)

          gpg --keyserver pgp.mit.edu --recv-keys EB3467D6
          Buffy: Willow, you're alive.
          Willow: Aren't I usually?


          [Non-text portions of this message have been removed]
        • Godwin Stewart
          On Mon, 02 Sep 2002 01:04:05 -0000, phil_is_phil ... That particular NIC isn t directly supported by the kernel. We need to know what chip is on it to be
          Message 4 of 16 , Sep 2, 2002
          • 0 Attachment
            On Mon, 02 Sep 2002 01:04:05 -0000, "phil_is_phil"
            <hellomynameisphil@...> squashed this out of the keyboard:

            > It's a D-Link DFE 538TX 10/100. '/sbin/ifconfig eth0' gives 'eth0:
            > error fetching interface information: Device not found'.

            That particular NIC isn't directly supported by the kernel. We need to know
            what chip is on it to be able to help. Try running "lspci -v" and get back
            to us with the output.

            --
            G. Stewart -- gstewart@...
            gstewart@...
            Registered Linux user #284683

            GPG key: BA3D01C6 (pgp.mit.edu)
            F'print: C3DF C686 6572 6E59 E3E4 0F40 2B9A 2218 BA3D 01C6
            -----------------------------------------------------------
            Give a man a fish and he will eat for a day. Teach him
            how to fish, and he will sit in a boat and drink beer
            all day.


            [Non-text portions of this message have been removed]
          • Francesca
            It s comes up as 8139too on all my installs. ... [Non-text portions of this message have been removed]
            Message 5 of 16 , Sep 2, 2002
            • 0 Attachment
              It's comes up as 8139too on all my installs.

              Godwin Stewart wrote:

              > On Mon, 02 Sep 2002 01:04:05 -0000, "phil_is_phil"
              > <hellomynameisphil@...> squashed this out of the keyboard:
              >
              > > It's a D-Link DFE 538TX 10/100. '/sbin/ifconfig eth0' gives 'eth0:
              > > error fetching interface information: Device not found'.
              >
              > That particular NIC isn't directly supported by the kernel. We need to
              > know
              > what chip is on it to be able to help. Try running "lspci -v" and get back
              > to us with the output.
              >
              > --
              > G. Stewart -- gstewart@...
              > gstewart@...
              > Registered Linux user #284683
              >
              > GPG key: BA3D01C6 (pgp.mit.edu)
              > F'print: C3DF C686 6572 6E59 E3E4 0F40 2B9A 2218 BA3D 01C6
              > -----------------------------------------------------------
              > Give a man a fish and he will eat for a day. Teach him
              > how to fish, and he will sit in a boat and drink beer
              > all day.
              >
              >
              > [Non-text portions of this message have been removed]
              >
              >
              > Yahoo! Groups Sponsor
              > ADVERTISEMENT
              > <http://rd.yahoo.com/M=212804.2303158.3720906.2225242/D=egroupweb/S=1705006580:HM/A=810327/R=0/*http://geocities.yahoo.com/ps/info?.refer=blrecs>
              >
              > <http://rd.yahoo.com/M=212804.2303158.3720906.2225242/D=egroupweb/S=1705006580:HM/A=810327/R=1/*http://geocities.yahoo.com/ps/info?.refer=blrecs>
              >
              >
              >
              > To unsubscribe from this list, please email
              > LINUX_Newbies-unsubscribe@yahoogroups.com & you will be removed.
              >
              > Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service
              > <http://docs.yahoo.com/info/terms/>.




              [Non-text portions of this message have been removed]
            • Godwin Stewart
              On Mon, 02 Sep 2002 10:58:59 -0400, Francesca squashed this ... In that case, you want to go into your kernel configuration (make menuconfig),
              Message 6 of 16 , Sep 2, 2002
              • 0 Attachment
                On Mon, 02 Sep 2002 10:58:59 -0400, Francesca <kesca@...> squashed this
                out of the keyboard:

                > It's comes up as 8139too on all my installs.

                In that case, you want to go into your kernel configuration
                (make menuconfig), then to the "Network device support" page. From there,
                into the "Ethernet (10 or 100Mbit)" page, and actavate the
                "RealTek RTL-8139 PCI Fast Ethernet Adapter support" option.

                Recompile, install, and your NIC should be usable.

                --
                G. Stewart -- gstewart@...
                gstewart@...
                Registered Linux user #284683

                GPG key: BA3D01C6 (pgp.mit.edu)
                F'print: C3DF C686 6572 6E59 E3E4 0F40 2B9A 2218 BA3D 01C6
                -----------------------------------------------------------
                Some days you are the bug; some days you are the
                windshield.


                [Non-text portions of this message have been removed]
              • Francesca
                ... I wrote that wrong. I meant to say that I had the same card as the original poster and the Linux/FreeBSD installs it found it as 8139too. I have had no
                Message 7 of 16 , Sep 2, 2002
                • 0 Attachment
                  Godwin Stewart wrote:

                  > On Mon, 02 Sep 2002 10:58:59 -0400, Francesca <kesca@...> squashed
                  > this
                  > out of the keyboard:
                  >
                  > > It's comes up as 8139too on all my installs.
                  >
                  > In that case, you want to go into your kernel configuration
                  > (make menuconfig), then to the "Network device support" page. From there,
                  > into the "Ethernet (10 or 100Mbit)" page, and actavate the
                  > "RealTek RTL-8139 PCI Fast Ethernet Adapter support" option.
                  >
                  > Recompile, install, and your NIC should be usable.

                  I wrote that wrong. I meant to say that I had the same card as the
                  original poster and the Linux/FreeBSD installs it found it as 8139too.
                  I have had no problems with Linux finding my ethernet card, though
                  I've had to select 8139too. At first this was confusing since the box
                  says D-Linuk DFE-530TX+.
                • Godwin Stewart
                  On Mon, 02 Sep 2002 13:29:43 -0400, Francesca squashed this ... Odd..... Because a 530TX+ definitly *is* based on an RTL-8139 chip.... -- G.
                  Message 8 of 16 , Sep 2, 2002
                  • 0 Attachment
                    On Mon, 02 Sep 2002 13:29:43 -0400, Francesca <kesca@...> squashed this
                    out of the keyboard:

                    > At first this was confusing since the box says D-Linuk DFE-530TX+.

                    Odd..... Because a 530TX+ definitly *is* based on an RTL-8139 chip....

                    --
                    G. Stewart -- gstewart@...
                    gstewart@...
                    Registered Linux user #284683

                    GnuPG key : BA3D01C6 (pgp.mit.edu)
                    Fingerprint: C3DF C686 6572 6E59 E3E4 0F40 2B9A 2218 BA3D 01C6
                    ---------------------------------------------------------------
                    The journey of a thousand miles begins with a broken
                    fan belt and a leaky tyre.
                  • Francesca
                    ... Yeah, I know that now. : ) I didn t know it when I attempted to install Gentoo. But Gentoo was nice enough to probe for my ethernet card and told me
                    Message 9 of 16 , Sep 2, 2002
                    • 0 Attachment
                      Godwin Stewart wrote:

                      > On Mon, 02 Sep 2002 13:29:43 -0400, Francesca <kesca@...> squashed
                      > this
                      > out of the keyboard:
                      >
                      > > At first this was confusing since the box says D-Linuk DFE-530TX+.
                      >
                      > Odd..... Because a 530TX+ definitly *is* based on an RTL-8139 chip....

                      Yeah, I know that now. : )

                      I didn't know it when I attempted to install Gentoo. But Gentoo was
                      nice enough to probe for my ethernet card and told me what chip it was
                      using. : )
                    • Jerry A. Stevens
                      ... Did a little poking around on google. The D-Link 538TX uses an rtl8139 chipset. It is supposed to be a NE2000 PCI clone. So I d try the rtl8139 driver
                      Message 10 of 16 , Sep 2, 2002
                      • 0 Attachment
                        On Monday 02 September 2002 03:38 am, you wrote:
                        > On Mon, 02 Sep 2002 01:04:05 -0000, "phil_is_phil"
                        >
                        > <hellomynameisphil@...> squashed this out of the keyboard:
                        > > It's a D-Link DFE 538TX 10/100. '/sbin/ifconfig eth0' gives 'eth0:
                        > > error fetching interface information: Device not found'.
                        >
                        > That particular NIC isn't directly supported by the kernel. We need to know
                        > what chip is on it to be able to help. Try running "lspci -v" and get back
                        > to us with the output.

                        Did a little poking around on google. The D-Link 538TX uses an rtl8139
                        chipset. It is supposed to be a NE2000 PCI clone. So I'd try the rtl8139
                        driver first and then try the ne2k-pci driver. Good directions can be found
                        at:

                        http://www.oreilly.com/catalog/debian/chapter/appd_06.html
                        http://www.xmission.com/~howardm/ethernet.html

                        Hope this helps.

                        Jerry
                      • Godwin Stewart
                        On Mon, 2 Sep 2002 15:53:55 -0500, Jerry A. Stevens ... Yep. With Francesca s help we cleared that one up earlier on today. -- G.
                        Message 11 of 16 , Sep 2, 2002
                        • 0 Attachment
                          On Mon, 2 Sep 2002 15:53:55 -0500, "Jerry A. Stevens" <jstevens@...>
                          squashed this out of the keyboard:

                          > Did a little poking around on google. The D-Link 538TX uses an rtl8139
                          > chipset.

                          Yep. With Francesca's help we cleared that one up earlier on today.

                          --
                          G. Stewart -- gstewart@...
                          gstewart@...
                          Registered Linux user #284683

                          GnuPG key : BA3D01C6 (pgp.mit.edu)
                          Fingerprint: C3DF C686 6572 6E59 E3E4 0F40 2B9A 2218 BA3D 01C6
                          ---------------------------------------------------------------
                          Seen in the classified ads:
                          COMPLETE SET OF ENCYCLOPEDIA BRITANNICA. 45 VOLUMES.
                          EXCELLENT CONDITION. $1000 OR BEST OFFER. NO LONGER
                          NEEDED. MARRIED. WIFE KNOWS EVERYTHING.


                          [Non-text portions of this message have been removed]
                        • Jerry A. Stevens
                          ... According to my very recent and short research the DFE 530TX uses the tulip driver and the DFE 530TX+ (which replaced the DFE 538TX) uses the rtl8139
                          Message 12 of 16 , Sep 2, 2002
                          • 0 Attachment
                            On Monday 02 September 2002 12:29 pm, you wrote:
                            > Godwin Stewart wrote:
                            > > On Mon, 02 Sep 2002 10:58:59 -0400, Francesca <kesca@...> squashed
                            > > this
                            > >
                            > > out of the keyboard:
                            > > > It's comes up as 8139too on all my installs.
                            > >
                            > > In that case, you want to go into your kernel configuration
                            > > (make menuconfig), then to the "Network device support" page. From there,
                            > > into the "Ethernet (10 or 100Mbit)" page, and actavate the
                            > > "RealTek RTL-8139 PCI Fast Ethernet Adapter support" option.
                            > >
                            > > Recompile, install, and your NIC should be usable.
                            >
                            > I wrote that wrong. I meant to say that I had the same card as the
                            > original poster and the Linux/FreeBSD installs it found it as 8139too.
                            > I have had no problems with Linux finding my ethernet card, though
                            > I've had to select 8139too. At first this was confusing since the box
                            > says D-Linuk DFE-530TX+.

                            According to my very recent and short research the DFE 530TX uses the tulip
                            driver and the DFE 530TX+ (which replaced the DFE 538TX) uses the rtl8139
                            driver. With D-Link apparently taking great steps to confuse us all.

                            Jerry:-)
                          • Godwin Stewart
                            On Mon, 2 Sep 2002 15:58:15 -0500, Jerry A. Stevens ... Actually it s the via-rhine driver. I have 3 of the things here :) -- G.
                            Message 13 of 16 , Sep 2, 2002
                            • 0 Attachment
                              On Mon, 2 Sep 2002 15:58:15 -0500, "Jerry A. Stevens" <jstevens@...>
                              squashed this out of the keyboard:

                              > According to my very recent and short research the DFE 530TX uses the
                              > tulip driver.....

                              Actually it's the via-rhine driver.

                              I have 3 of the things here :)

                              --
                              G. Stewart -- gstewart@...
                              gstewart@...
                              Registered Linux user #284683

                              GnuPG key : BA3D01C6 (pgp.mit.edu)
                              Fingerprint: C3DF C686 6572 6E59 E3E4 0F40 2B9A 2218 BA3D 01C6
                              ---------------------------------------------------------------
                              Give a man a fish and he will eat for a day. Teach him
                              how to fish, and he will sit in a boat and drink beer
                              all day.
                            • Jerry A. Stevens
                              ... They were arguing about that in one of the news groups I was looking at while researching. I don t have the definitive answer so I ll definitely believe
                              Message 14 of 16 , Sep 2, 2002
                              • 0 Attachment
                                On Monday 02 September 2002 04:02 pm, you wrote:
                                > On Mon, 2 Sep 2002 15:58:15 -0500, "Jerry A. Stevens"
                                > <jstevens@...>
                                >
                                > squashed this out of the keyboard:
                                > > According to my very recent and short research the DFE 530TX uses the
                                > > tulip driver.....
                                >
                                > Actually it's the via-rhine driver.
                                >
                                > I have 3 of the things here :)

                                They were arguing about that in one of the news groups I was looking at while
                                researching. I don't have the definitive answer so I'll definitely believe
                                you. I wonder though if some came with one chipset and some with another? It
                                wouldn't supprise me.

                                Jerry
                              • Bayu Notonegoro
                                ... since I don t have any network -yet, so if do some mistake correct me please... you can do this. use the module rtl8139too.o (ussually default on RH7.2 /
                                Message 15 of 16 , Sep 3, 2002
                                • 0 Attachment
                                  On Mon, 2002-09-02 at 22:04, Godwin Stewart wrote:
                                  > In that case, you want to go into your kernel configuration
                                  > (make menuconfig), then to the "Network device support" page. From there,
                                  > into the "Ethernet (10 or 100Mbit)" page, and actavate the
                                  > "RealTek RTL-8139 PCI Fast Ethernet Adapter support" option.
                                  >
                                  > Recompile, install, and your NIC should be usable.

                                  since I don't have any network -yet, so if do some mistake correct me
                                  please...

                                  you can do this.
                                  use the module rtl8139too.o (ussually default on RH7.2 / 7.3 on
                                  /lib/modules/2.4.x/kernel/drivers/net)
                                  then
                                  #insmod rtl18139too
                                  if there is no message error, then check
                                  #lsmod
                                  if rtl8139too exist, then it _should_ works :)

                                  --
                                  bn
                                Your message has been successfully submitted and would be delivered to recipients shortly.