Loading ...
Sorry, an error occurred while loading the content.

30414Aptitude fails to configure 'dirmngr'

Expand Messages
  • Pascal
    Jul 1, 2012
      Hey all,

      I'm having once again a problem with my Debian Testing. When doing an update %% upgrade, aptitude tells me that there is a syntax error in the configuration script (?) for dirmngr (terminal output see below). That also means that three other packages cannot be updated: kde-full, kleopatra & kdepim due to unmet dependencies, they depend on dirmngr. I've been looking around with Google but have failed to find a solution. So far, I wasn't able to locate the configuration script in question, to see what is wrong in the lines aptitude keeps complaining about.

      Can someone help me out?
      Thanks a lot,

      Pascal


      ======================================================
      Terminal output:

      E: Sub-process /usr/bin/dpkg returned an error code (1)
      Ein Paket konnte nicht installiert werden. Versuch, dies zu lösen:
      dirmngr (1.1.0-3) wird eingerichtet ...

      ##Unable to install package. Attempt to solve the issue: dirmngr (1.1.0-3) is set up...

      [....] Starting DirMngr: dirmngr-su: 15: shopt: not found
      -su: 21: shopt: not found
      -su: 51: Syntax error: Bad fd number
      failed!
      invoke-rc.d: initscript dirmngr, action "start" failed.
      dpkg: Fehler beim Bearbeiten von dirmngr (--configure):

      ##Error when configuring dirmngr (--configure)

      Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
      dpkg: Abhängigkeitsprobleme verhindern Konfiguration von kleopatra:

      ##Sub-process of installed post-installation script return error message 1
      ##dpkg: Dependency problems prevent configuration of kleopatra


      kleopatra hängt ab von libkdepim4 (= 4:4.4.11.1+l10n-2); aber:
      Version von libkdepim4 auf dem System ist 4:4.4.11.1+l10n-3.

      ##kleopatra depends on libkdepim......

      kleopatra hängt ab von libkleo4 (= 4:4.4.11.1+l10n-2); aber:
      Version von libkleo4 auf dem System ist 4:4.4.11.1+l10n-3.
      kleopatra hängt ab von dirmngr; aber:
      Paket dirmngr ist noch nicht konfiguriert.

      ##Package dirmngr is not configured yet

      dpkg: Fehler beim Bearbeiten von kleopatra (--configure):
      Abhängigkeitsprobleme - verbleibt unkonfiguriert
      dpkg: Abhängigkeitsprobleme verhindern Konfiguration von kdepim:
      kdepim hängt ab von kleopatra (>= 4:4.4.11.1+l10n-2); aber:
      Paket kleopatra ist noch nicht konfiguriert.
      dpkg: Fehler beim Bearbeiten von kdepim (--configure):
      Abhängigkeitsprobleme - verbleibt unkonfiguriert
      dpkg: Abhängigkeitsprobleme verhindern Konfiguration von kde-full:
      kde-full hängt ab von kdepim (>= 4:4.4.11); aber:
      Paket kdepim ist noch nicht konfiguriert.
      dpkg: Fehler beim Bearbeiten von kde-full (--configure):
      Abhängigkeitsprobleme - verbleibt unkonfiguriert
      Fehler traten auf beim Bearbeiten von:
      dirmngr
      kleopatra
      kdepim
      kde-full
      ======================================================
    • Show all 8 messages in this topic