Loading ...
Sorry, an error occurred while loading the content.
 

>> Need some assistance: K2500 Digitech Effects not working!!!

Expand Messages
  • DEAFETHOS
    Hi everyone, The Digitech Effects in my Kurzweil K2500 76 note keyboard has stopped working!!! If I go to the effect s page in program mode and put the Wet/Dry
    Message 1 of 4 , Jun 29, 2011
      Hi everyone,

      The Digitech Effects in my Kurzweil K2500 76 note keyboard has stopped working!!! If I go to the effect's page in program mode and put the Wet/Dry Mix to 100% the audio fades completly with no interference or without any effects coming from K2500's Digitech effects processor. I do have the KDFX effects and both it and the Digitech effects were working fine together until now. Any help, suggestions or ideas where I might be able to source a Digitech effects chip for my Kurzweil K2500 would be great, cheers!!!

      Also, I just had some button pads replaced and I'm wondering would that have had something to do with the Digitech effects not working. It was working for a day after the buttons got fixed but then it decided to pack in.
    • Jon Stubbs
      The often suggested remedy is a hard reset-- Back up any of your needed objects (programs, etc.) Unplug the AC, remove the batteries (over night- 12 hours?).
      Message 2 of 4 , Jul 6 6:29 AM
        The often suggested remedy is a hard reset--

        Back up any of your needed objects (programs, etc.)
        Unplug the AC, remove the batteries (over night- 12 hours?).
        As I understand it, this drains the caps and allows a
        crashed or corrupted digitech chip to reset.

        When you replace batteries and boot up it will
        reset all internal factory objects.

        If that doesn't fix it, you may have to find out
        what was altered by the previous repair.

        good luck



        On Jun 29, 2011, at 11:14 AM, DEAFETHOS wrote:

        > Hi everyone,
        >
        > The Digitech Effects in my Kurzweil K2500 76 note keyboard has stopped working!!! If I go to the effect's page in program mode and put the Wet/Dry Mix to 100% the audio fades completly with no interference or without any effects coming from K2500's Digitech effects processor. I do have the KDFX effects and both it and the Digitech effects were working fine together until now. Any help, suggestions or ideas where I might be able to source a Digitech effects chip for my Kurzweil K2500 would be great, cheers!!!
        >
        > Also, I just had some button pads replaced and I'm wondering would that have had something to do with the Digitech effects not working. It was working for a day after the buttons got fixed but then it decided to pack in.
        >
        >



        [Non-text portions of this message have been removed]
      • DEAFETHOS
        ... As for the Button Pads, well I got them fixed last week but shortly after the screen started to skip MIDI channels and if I went into edit mode while in
        Message 3 of 4 , Jul 7 9:36 AM
          >> Thanks for that, the Digitech F/X are working again which was done by removing the batteries to force the my K2500 into doing a Hard Re-Set.

          As for the Button Pads, well I got them fixed last week but shortly after the screen started to skip MIDI channels and if I went into edit mode while in Program mode it would be the layers of my program that would skip. The skipping happens so fast that it's impossible to do anything with my K2500. I also checked the Pads and they seem to be fine which is strange, hopefully it's not to serious!!! Lets see what the repair guy has to say as it's his 2nd time now seeing it in a week. I also gave him a low down of what was done with my K2500 before. In future I'll start editing my K2500 form a MAC so not to use those flimsy Buttons again.

          >> Spotted this guy online, seems to know his stuff about Kurzweils, you can check him out at http://www.dgaudiorepair.com/

          Cheers >;-)...

          ###


          --- In KurzList@yahoogroups.com, Jon Stubbs <jonstubbs@...> wrote:
          >
          > The often suggested remedy is a hard reset--
          >
          > Back up any of your needed objects (programs, etc.)
          > Unplug the AC, remove the batteries (over night- 12 hours?).
          > As I understand it, this drains the caps and allows a
          > crashed or corrupted digitech chip to reset.
          >
          > When you replace batteries and boot up it will
          > reset all internal factory objects.
          >
          > If that doesn't fix it, you may have to find out
          > what was altered by the previous repair.
          >
          > good luck
          >
          >
          >
          > On Jun 29, 2011, at 11:14 AM, DEAFETHOS wrote:
          >
          > > Hi everyone,
          > >
          > > The Digitech Effects in my Kurzweil K2500 76 note keyboard has stopped working!!! If I go to the effect's page in program mode and put the Wet/Dry Mix to 100% the audio fades completly with no interference or without any effects coming from K2500's Digitech effects processor. I do have the KDFX effects and both it and the Digitech effects were working fine together until now. Any help, suggestions or ideas where I might be able to source a Digitech effects chip for my Kurzweil K2500 would be great, cheers!!!
          > >
          > > Also, I just had some button pads replaced and I'm wondering would that have had something to do with the Digitech effects not working. It was working for a day after the buttons got fixed but then it decided to pack in.
          > >
          > >
          >
          >
          >
          > [Non-text portions of this message have been removed]
          >
        • DEAFETHOS
          Message 4 of 4 , Jul 14 9:57 AM
            >> Quick update: Just got my Kurzweil K2500 returned form repair. I was told that a cable was caught somewhere in the unit (more details below) which could've caused the skipping! Anyways, just started using VASTprogrammer and it's work'n real smoothly while editing my K from a PC so not to use those flimsy button pads again. The skipping did happen once and VASTprogrammer was picking it up which wasn't good, anyways the skipping did stop and hopefully won't return, fingers crossed!

            ###


            --- In KurzList@yahoogroups.com, "DEAFETHOS" <deafethos@...> wrote:
            >
            >
            >
            > >> Thanks for that, the Digitech F/X are working again which was done by removing the batteries to force the my K2500 into doing a Hard Re-Set.
            >
            > As for the Button Pads, well I got them fixed last week but shortly after the screen started to skip MIDI channels and if I went into edit mode while in Program mode it would be the layers of my program that would skip. The skipping happens so fast that it's impossible to do anything with my K2500. I also checked the Pads and they seem to be fine which is strange, hopefully it's not to serious!!! Lets see what the repair guy has to say as it's his 2nd time now seeing it in a week. I also gave him a low down of what was done with my K2500 before. In future I'll start editing my K2500 form a MAC so not to use those flimsy Buttons again.
            >
            > >> Spotted this guy online, seems to know his stuff about Kurzweils, you can check him out at http://www.dgaudiorepair.com/
            >
            > Cheers >;-)...
            >
            > ###
            >
            >
            > --- In KurzList@yahoogroups.com, Jon Stubbs <jonstubbs@> wrote:
            > >
            > > The often suggested remedy is a hard reset--
            > >
            > > Back up any of your needed objects (programs, etc.)
            > > Unplug the AC, remove the batteries (over night- 12 hours?).
            > > As I understand it, this drains the caps and allows a
            > > crashed or corrupted digitech chip to reset.
            > >
            > > When you replace batteries and boot up it will
            > > reset all internal factory objects.
            > >
            > > If that doesn't fix it, you may have to find out
            > > what was altered by the previous repair.
            > >
            > > good luck
            > >
            > >
            > >
            > > On Jun 29, 2011, at 11:14 AM, DEAFETHOS wrote:
            > >
            > > > Hi everyone,
            > > >
            > > > The Digitech Effects in my Kurzweil K2500 76 note keyboard has stopped working!!! If I go to the effect's page in program mode and put the Wet/Dry Mix to 100% the audio fades completly with no interference or without any effects coming from K2500's Digitech effects processor. I do have the KDFX effects and both it and the Digitech effects were working fine together until now. Any help, suggestions or ideas where I might be able to source a Digitech effects chip for my Kurzweil K2500 would be great, cheers!!!
            > > >
            > > > Also, I just had some button pads replaced and I'm wondering would that have had something to do with the Digitech effects not working. It was working for a day after the buttons got fixed but then it decided to pack in.
            > > >
            > > >
            > >
            > >
            > >
            > > [Non-text portions of this message have been removed]
            > >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.