Loading ...
Sorry, an error occurred while loading the content.

K2000VP damage from parallel ZIP drive?

Expand Messages
  • fredbunn
    Hi, guys Yes, I m stupid. For some stupid reason, I plugged my PARALLEL zip drive into my K2000 s SCSI port. I have a SCSI zip drive, but picked up the wrong
    Message 1 of 3 , Jan 3, 2011
    • 0 Attachment
      Hi, guys

      Yes, I'm stupid.

      For some stupid reason, I plugged my PARALLEL zip drive into my K2000's SCSI port.

      I have a SCSI zip drive, but picked up the wrong one by mistake.
      (I hadn't used it for a while, and my compact flash card adapter failed.)

      I noticed it wasn't powering up, and then smelled the 'smoke' smell.

      I immediately unplugged everything, opened it, and examined the boards.
      No obvious damage, and nothing was hot to the touch.

      The unit powers on and plays. Sounds fine. Smells funny.

      I've got a SCSI hard drive on order. Hopefully I haven't damaged the internal SCSI circuitry. I'll try the external SCSI port again when I find my SCSI ZIP drive (which worked fine on before).

      Has anyone else done this? What kind of repairs were needed to fix any burned out components?

      I'm REALLY hoping was smelling a safety resistor starting to burn up. That would be great. It would be even better if the external SCSI still works (but I'm not holding my breath).

      ANY advice from folks who have seen this kind of problem before would be appreciated.

      Thanks,

      -Fred

      I had a compact flash card adapter in my K2000VP that worked great
    • David Durst
      Actually, I d love to hear more about that compact flash card adapter and how complicated it was (talk about newbie questions -- often thought about it but
      Message 2 of 3 , Jan 4, 2011
      • 0 Attachment
        Actually, I'd love to hear more about that compact flash card adapter and how
        complicated it was (talk about newbie questions -- often thought about it but
        never did it, and love the fact that my Yamaha S80 uses a smartmedia card).





        ________________________________
        From: fredbunn <fredbunn@...>
        To: KurzList@yahoogroups.com
        Sent: Tue, January 4, 2011 12:50:53 AM
        Subject: [KL] K2000VP damage from parallel ZIP drive?


        Hi, guys

        Yes, I'm stupid.

        For some stupid reason, I plugged my PARALLEL zip drive into my K2000's SCSI
        port.

        I have a SCSI zip drive, but picked up the wrong one by mistake.
        (I hadn't used it for a while, and my compact flash card adapter failed.)

        I noticed it wasn't powering up, and then smelled the 'smoke' smell.

        I immediately unplugged everything, opened it, and examined the boards.
        No obvious damage, and nothing was hot to the touch.

        The unit powers on and plays. Sounds fine. Smells funny.

        I've got a SCSI hard drive on order. Hopefully I haven't damaged the internal
        SCSI circuitry. I'll try the external SCSI port again when I find my SCSI ZIP
        drive (which worked fine on before).

        Has anyone else done this? What kind of repairs were needed to fix any burned
        out components?

        I'm REALLY hoping was smelling a safety resistor starting to burn up. That would
        be great. It would be even better if the external SCSI still works (but I'm not
        holding my breath).

        ANY advice from folks who have seen this kind of problem before would be
        appreciated.

        Thanks,

        -Fred

        I had a compact flash card adapter in my K2000VP that worked great







        [Non-text portions of this message have been removed]
      • fredbunn
        For posterity (those searching the net later), my K2000 STILL WORKS after smoking the SCSI hardware by plugging in an Iomega ZIP parallel drive. I was able to
        Message 3 of 3 , Jan 4, 2011
        • 0 Attachment
          For posterity (those searching the net later), my K2000 STILL WORKS after smoking the SCSI hardware by plugging in an Iomega ZIP parallel drive. I was able to hook up my REAL Iomega SCSI drive and read files without any problem!

          I'm sure I've stressed the hardware somewhat. Luckily, I pulled the power as soon as I smelled the smoke and saw the K2000VP wasn't booting properly. I was probably smelling the resistor paint or PC board finish burning. Thank you, Jesus and Almighty GOD!
          (Yes... I DID PRAY!)

          If any of you are using ZIP drives, PLEASE make SURE there is a SCSI address switch on the back BEFORE you plug it into your K2000. Otherwise, you may not be so lucky. I should also thank the Kurzweil hardware engineers. Somebody probably though ahead and added the protection circuit.


          OK! Now I will tell you about the CF card.
          Overall, I love the concept. It worked well for a while.

          Building it is simple. You will need:

          1. The K2000 hard drive cabling kit.
          2. A 3.5" IDE Compact flash (CF card) adapter
          (This fits where the floppy drive is now)
          3. An IDE-SCSI adapter board
          (be sure to get one with a 50 pin connector)

          Use the floppy power cable to power the flash reader and the hard drive power connector to power the IDE-SCSI adapter board.

          Connect the 50 pin SCSI cable to the IDE-SCSI board, and you're done.
          Brilliant! I can load/backup files from my PC onto the card and plug it into the K2000.

          Now for the downsides... First, not all cards seem to work. A 133x card was reliable. Second, anything more than 2GB can't be read, and is wasted. Third, remember to format the card as a FAT device.


          It is easy and reliable as long as you're good with MECHANICAL things. The CF card reader fits in the location of the floppy drive. The mounting didn't match, so I built a mount out of sheet metal.
          The IDE-SCSI bridge card plugs into the CF card reader, but doesn't latch. It's important to secure it so it doesn't slip off when shaken.

          My homebrew assembly worked perfectly for a while. Then the IDE-SCSI bridge adapter would occasionally slip off the CF reader pins. I had to open the K2000 and re-seat it. My cousin suggested I use a hot glue gun to secure it, which sounded like a great idea. Unfortunately, I wasn't careful. The glue must have reacted with either the connector, solder, or PC board. After gluing, the reader was no longer reliable. It eventually failed altogether.

          I looked for a replacement IDE-SCSI bridge card, but they are getting hard to find. I couldn't find one for less than $180.

          2GB SCSI drives (loaded with patches) are available on Ebay for $69, so I just bought one of those. I'll still keep my eye out for a replacement IDE-SCSI bridge card, but won't pay more than $60 for one.


          If you want to add a flash card, scsi4samplers.com sells the bridge card, and used to sell the entire kit, including a 3.5" CF reader. I would get the entire kit as my first choice, since the mechanical work is already done and has proven reliability.


          If I built my own again, here's what I would do differently.

          1. DON'T connect the IDE-SCSI bridge directly to the flash card reader. Connect it with an IDE cable and secure the bridge card independently. The top of the K2000 fan assembly presses on it and is likely what moved it all the time. It may have shorted it as well.


          In retrospect, I'm glad I bought a USB ZIP drive for my PC and a SCSI version for the K2000. It will be easier than floppies to load my custom sounds onto the new hard drive. These drives can be found cheaply on ebay. Don't forget to get the disks on eBay, too. They are getting expensive in the retail stores.


          Good luck with whatever you choose!

          -Fred



          --- In KurzList@yahoogroups.com, David Durst <thedurst@...> wrote:
          >
          > Actually, I'd love to hear more about that compact flash card adapter and how
          > complicated it was (talk about newbie questions -- often thought about it but
          > never did it, and love the fact that my Yamaha S80 uses a smartmedia card).
          >
          >
          >
          >
          >
          > ________________________________
          > From: fredbunn <fredbunn@...>
          > To: KurzList@yahoogroups.com
          > Sent: Tue, January 4, 2011 12:50:53 AM
          > Subject: [KL] K2000VP damage from parallel ZIP drive?
          >
          >
          > Hi, guys
          >
          > Yes, I'm stupid.
          >
          > For some stupid reason, I plugged my PARALLEL zip drive into my K2000's SCSI
          > port.
          >
          > I have a SCSI zip drive, but picked up the wrong one by mistake.
          > (I hadn't used it for a while, and my compact flash card adapter failed.)
          >
          > I noticed it wasn't powering up, and then smelled the 'smoke' smell.
          >
          > I immediately unplugged everything, opened it, and examined the boards.
          > No obvious damage, and nothing was hot to the touch.
          >
          > The unit powers on and plays. Sounds fine. Smells funny.
          >
          > I've got a SCSI hard drive on order. Hopefully I haven't damaged the internal
          > SCSI circuitry. I'll try the external SCSI port again when I find my SCSI ZIP
          > drive (which worked fine on before).
          >
          > Has anyone else done this? What kind of repairs were needed to fix any burned
          > out components?
          >
          > I'm REALLY hoping was smelling a safety resistor starting to burn up. That would
          > be great. It would be even better if the external SCSI still works (but I'm not
          > holding my breath).
          >
          > ANY advice from folks who have seen this kind of problem before would be
          > appreciated.
          >
          > Thanks,
          >
          > -Fred
          >
          > I had a compact flash card adapter in my K2000VP that worked great
          >
          >
          >
          >
          >
          >
          >
          > [Non-text portions of this message have been removed]
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.