Loading ...
Sorry, an error occurred while loading the content.

New to the group and some questions

Expand Messages
  • ve2vag
    Hello everyone, My name is Guy, callsign VE2VAG in Quebec city, province of Quebec, Canada. I m new to the group and have acquired a TS-50S last saturday at
    Message 1 of 1 , Aug 5 1:16 PM
    • 0 Attachment
      Hello everyone,

      My name is Guy, callsign VE2VAG in Quebec city, province of Quebec,
      Canada. I'm new to the group and have acquired a TS-50S last
      saturday at my local hamfest, along with a Vectronics VC300DLP
      antenna tuner. I've been mostly listening on an Icom discone antenna
      since my HF antenna hasn't been set up, should be doing that next
      week.

      I was told by the seller (who is a guy I know) that the radio has "a
      small problem": apparently when the radio has been for a long time
      and while listening to a SSB signal, the sound becomes distorted. The
      problem corrects itself when shutting the radio down for a second and
      opening it up again. I havent experienced the problem since I got the
      radio

      I've been browsing thru a lot of the messages in the group and the
      symptoms seems to be the ones of a failing DDS unit, unless someone
      in here thinks otherwise. Could someone in the group tell me what
      would be the parts numbers of these, and where to get these ? I've
      read they are not cheap, but about where it should range ? 50$, 100$
      or $200 each ?

      The part number of the encoder would also be appreciated; not that
      it's broken but if I am to make an order, I'll evaluate ordering it
      at the same time since I like to keep spare parts "just in case".

      73's from Guy VE2VAG
    Your message has been successfully submitted and would be delivered to recipients shortly.