Loading ...
Sorry, an error occurred while loading the content.

weird bug, starting at 4.60

Expand Messages
  • Stef Mientki
    hello All, In one of my libraries I ve documented a few websites. One of these addresses contains the following substring --
    Message 1 of 16 , Feb 12, 2005
    • 0 Attachment
      hello All,

      In one of my libraries I've documented a few websites.
      One of these addresses contains the following substring
      <JAL>

      -- key=random&from=%2Ftechref%2Fnew200502%2Etxt

      </JAL>

      From compiler 4.60 (GCC 3.2) this line is interpretated as "End Of
      File" !!! ???
      JAL 4.59 (1310.0 works ok).

      So when this line is at the top of a library file,
      the whole library is ignored.
      There are no hidden characters in the above line,
      you can just copy and paste it to see the effect.

      Stef
    • Javier Martinez
      Hi Stef, I can t reproduce the bug. My test file: include f452_20 var volatile byte b4 -- key=random&from=%2Ftechref%2Fnew200502%2Etxt b4 = 0x23
      Message 2 of 16 , Feb 13, 2005
      • 0 Attachment
        Hi Stef,

        I can't reproduce the bug. My test file:

        <JAL>
        include f452_20

        var volatile byte b4

        -- key=random&from=%2Ftechref%2Fnew200502%2Etxt

        b4 = 0x23
        </JAL>



        Result file (cropped):

        <ASM>
        (..)
        ;; 005 : var volatile byte b4
        ; var H'001:000' b4

        ;; 009 : b4 = 0x23
        movlw H'23'
        movwf H'001'
        (..)
        </ASM>


        Regards,
        Javi.




        El sáb, 12-02-2005 a las 22:54 +0100, Stef Mientki escribió:
        > hello All,
        >
        > In one of my libraries I've documented a few websites.
        > One of these addresses contains the following substring
        > <JAL>
        >
        > -- key=random&from=%2Ftechref%2Fnew200502%2Etxt
        >
        > </JAL>
        >
        > From compiler 4.60 (GCC 3.2) this line is interpretated as "End Of
        > File" !!! ???
        > JAL 4.59 (1310.0 works ok).
        >
        > So when this line is at the top of a library file,
        > the whole library is ignored.
        > There are no hidden characters in the above line,
        > you can just copy and paste it to see the effect.
        >
        > Stef
        >
        >
        > Yahoo! Groups Sponsor
        > ADVERTISEMENT
        >
        >
        >
        >
        > ______________________________________________________________________
        > Yahoo! Groups Links
        > * To visit your group on the web, go to:
        > http://groups.yahoo.com/group/Jal_developers/
        >
        > * To unsubscribe from this group, send an email to:
        > Jal_developers-unsubscribe@yahoogroups.com
        >
        > * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
        > Service.
        >
      • Stef Mientki
        hi Javi, did you really use JAL 4.60 (GCC 3.2) ? Here s my shortest source, that gives the error: (could you test this code, it doesn t need any libraries)
        Message 3 of 16 , Feb 13, 2005
        • 0 Attachment
          hi Javi,

          did you really use JAL 4.60 (GCC 3.2) ?

          Here's my shortest source, that gives the error:
          (could you test this code, it doesn't need any libraries)

          thanks,
          Stef

          <JAL>
          pragma target chip 12F675
          pragma target clock 4_000_000 ;internal clock
          pragma target osc hs
          var volatile byte PCL at 0x02
          PCL = 4
          -- key=random&from=%2Ftechref%2Fnew200502%2Etxt
          PCL = 2
          </JAL>

          <ASM>
          and the generated code:
          ;; 004 : var volatile byte PCL at 0x02
          ; var H'002:000' pcl

          ;; 005 : PCL = 4
          movlw H'04'
          movwf H'002'

          ;; 003 : idle_loop: page goto idle_loop
          as_872_idle_loop: ; 0006
          goto as_872_idle_loop

          END
          </ASM>



          Javier Martinez wrote:

          >Hi Stef,
          >
          > I can't reproduce the bug. My test file:
          >
          ><JAL>
          >include f452_20
          >
          >var volatile byte b4
          >
          >-- key=random&from=%2Ftechref%2Fnew200502%2Etxt
          >
          >b4 = 0x23
          ></JAL>
          >
          >
          >
          > Result file (cropped):
          >
          ><ASM>
          >(..)
          >;; 005 : var volatile byte b4
          >; var H'001:000' b4
          >
          >;; 009 : b4 = 0x23
          > movlw H'23'
          > movwf H'001'
          >(..)
          ></ASM>
          >
          >
          >Regards,
          >Javi.
          >
          >
          >
          >
          >El sáb, 12-02-2005 a las 22:54 +0100, Stef Mientki escribió:
          >
          >
          >>hello All,
          >>
          >>In one of my libraries I've documented a few websites.
          >>One of these addresses contains the following substring
          >><JAL>
          >>
          >>-- key=random&from=%2Ftechref%2Fnew200502%2Etxt
          >>
          >></JAL>
          >>
          >>From compiler 4.60 (GCC 3.2) this line is interpretated as "End Of
          >>File" !!! ???
          >>JAL 4.59 (1310.0 works ok).
          >>
          >>So when this line is at the top of a library file,
          >>the whole library is ignored.
          >>There are no hidden characters in the above line,
          >>you can just copy and paste it to see the effect.
          >>
          >>Stef
          >>
          >>
          >> Yahoo! Groups Sponsor
          >> ADVERTISEMENT
          >>
          >>
          >>
          >>
          >>______________________________________________________________________
          >>Yahoo! Groups Links
          >> * To visit your group on the web, go to:
          >> http://groups.yahoo.com/group/Jal_developers/
          >>
          >> * To unsubscribe from this group, send an email to:
          >> Jal_developers-unsubscribe@yahoogroups.com
          >>
          >> * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
          >> Service.
          >>
          >>
          >>
          >
          >
          >
          >
          >
          >Yahoo! Groups Links
          >
          >
          >
          >
          >
          >
          >
          >
          >
          >
          >
        • Javier Martinez
          Hi Stef, I ve 0.4.62 installed. From your words I undertood that this bug comes since 0.4.60. I ll test it this week. I m seeing this code OK with 0.4.62,
          Message 4 of 16 , Feb 13, 2005
          • 0 Attachment
            Hi Stef,

            I've 0.4.62 installed. From your words I undertood that this bug
            comes since 0.4.60. I'll test it this week.

            I'm seeing this code OK with 0.4.62, perhaps is it related only to
            Windows binary?

            Regards,
            Javi.

            <ASM>
            ; compiler : jal 0.4.62
            ; date : 13-Feb-2005 22:32:00
            ; main source : tstef
            ; command line : tstef.jal
            ; target chip : 12f675
            ; cpu : pic 14
            ; clock : 4000000
            ; input files : 2
            ; lines : 14
            ; chars : 281
            ; compilation nodes : 932
            ; stack : 3Kb
            ; heap : 287Kb
            ; seconds : 0.000 (0 lines/second)
            ; output code : 11
            ; page : 0 (0.0%)
            ; bank : 0 (0.0%)
            ; page+bank : 0 (0.0%)
            ; file : 1
            ; stack: 0 (0,0,0)

            errorlevel -306
            list p=PIC12f675

            ; note: the f629/675 config is still fixed!
            __CONFIG H'3FE2'
            ORG 0000
            goto __main
            ORG 0004
            ORG 0004
            __interrupt: ; 0004
            __main: ; 0004
            ; var H'020:000' transfer_bit
            ; var H'020:000' transfer_byte

            ;; 004 : var volatile byte PCL at 0x02
            ; var H'002:000' pcl

            ;; 005 : PCL = 4
            movlw H'04'
            bcf H'003',5
            bcf H'003',6
            movwf H'002'

            ;; 007 : PCL = 2
            movlw H'02'
            movwf H'002'

            ;; 003 : idle_loop: page goto idle_loop
            as_878_idle_loop: ; 000A
            goto as_878_idle_loop

            END

            ; ********** variable mapping
            ; 02:0 : ;
            ; pcl * 0004:19 tstef.jal
            ; 20:0 : ;
            ; transfer_byte
            ; transfer_bit

            </ASM>



            El dom, 13-02-2005 a las 22:05 +0100, Stef Mientki escribió:
            > hi Javi,
            >
            > did you really use JAL 4.60 (GCC 3.2) ?
            >
            > Here's my shortest source, that gives the error:
            > (could you test this code, it doesn't need any libraries)
            >
            > thanks,
            > Stef
            >
            > <JAL>
            > pragma target chip 12F675
            > pragma target clock 4_000_000 ;internal clock
            > pragma target osc hs
            > var volatile byte PCL at 0x02
            > PCL = 4
            > -- key=random&from=%2Ftechref%2Fnew200502%2Etxt
            > PCL = 2
            > </JAL>
            >
            > <ASM>
            > and the generated code:
            > ;; 004 : var volatile byte PCL at 0x02
            > ; var H'002:000' pcl
            >
            > ;; 005 : PCL = 4
            > movlw H'04'
            > movwf H'002'
            >
            > ;; 003 : idle_loop: page goto idle_loop
            > as_872_idle_loop: ; 0006
            > goto as_872_idle_loop
            >
            > END
            > </ASM>
            >
            >
            >
            > Javier Martinez wrote:
            >
            > >Hi Stef,
            > >
            > > I can't reproduce the bug. My test file:
            > >
            > ><JAL>
            > >include f452_20
            > >
            > >var volatile byte b4
            > >
            > >-- key=random&from=%2Ftechref%2Fnew200502%2Etxt
            > >
            > >b4 = 0x23
            > ></JAL>
            > >
            > >
            > >
            > > Result file (cropped):
            > >
            > ><ASM>
            > >(..)
            > >;; 005 : var volatile byte b4
            > >; var H'001:000' b4
            > >
            > >;; 009 : b4 = 0x23
            > > movlw H'23'
            > > movwf H'001'
            > >(..)
            > ></ASM>
            > >
            > >
            > >Regards,
            > >Javi.
            > >
            > >
            > >
            > >
            > >El sáb, 12-02-2005 a las 22:54 +0100, Stef Mientki escribió:
            > >
            > >
            > >>hello All,
            > >>
            > >>In one of my libraries I've documented a few websites.
            > >>One of these addresses contains the following substring
            > >><JAL>
            > >>
            > >>-- key=random&from=%2Ftechref%2Fnew200502%2Etxt
            > >>
            > >></JAL>
            > >>
            > >>From compiler 4.60 (GCC 3.2) this line is interpretated as "End Of
            > >>File" !!! ???
            > >>JAL 4.59 (1310.0 works ok).
            > >>
            > >>So when this line is at the top of a library file,
            > >>the whole library is ignored.
            > >>There are no hidden characters in the above line,
            > >>you can just copy and paste it to see the effect.
            > >>
            > >>Stef
            > >>
            > >>
            > >> Yahoo! Groups Sponsor
            > >> ADVERTISEMENT
            > >>
            > >>
            > >>
            > >>
            > >>______________________________________________________________________
            > >>Yahoo! Groups Links
            > >> * To visit your group on the web, go to:
            > >> http://groups.yahoo.com/group/Jal_developers/
            > >>
            > >> * To unsubscribe from this group, send an email to:
            > >> Jal_developers-unsubscribe@yahoogroups.com
            > >>
            > >> * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
            > >> Service.
            > >>
            > >>
            > >>
            > >
            > >
            > >
            > >
            > >
            > >Yahoo! Groups Links
            > >
            > >
            > >
            > >
            > >
            > >
            > >
            > >
            > >
            > >
            > >
            >
            > Yahoo! Groups Sponsor
            > ADVERTISEMENT
            >
            >
            >
            >
            > ______________________________________________________________________
            > Yahoo! Groups Links
            > * To visit your group on the web, go to:
            > http://groups.yahoo.com/group/Jal_developers/
            >
            > * To unsubscribe from this group, send an email to:
            > Jal_developers-unsubscribe@yahoogroups.com
            >
            > * Your use of Yahoo! Groups is subject to the Yahoo! Terms of
            > Service.
            >
          • Stef Mientki
            hi Javi, ... Could be well possible. I didn t test it on 4.61, and 4.62 is not yet available in Windows binary :-( I assumed the problem slipped in 4.60, and
            Message 5 of 16 , Feb 13, 2005
            • 0 Attachment
              hi Javi,

              Javier Martinez wrote:

              >Hi Stef,
              >
              > I've 0.4.62 installed. From your words I undertood that this bug
              >comes since 0.4.60. I'll test it this week.
              >
              >
              > I'm seeing this code OK with 0.4.62, perhaps is it related only to
              >Windows binary?
              >
              >
              >
              Could be well possible.
              I didn't test it on 4.61,
              and 4.62 is not yet available in Windows binary :-(
              I assumed the problem slipped in 4.60,
              and afaik nobody has mentioned it, so it probably will also be in the
              next versions.

              cheers,
              Stef
            • japus10
              Hi Stef, This bug becomes in ALL binaries compiled with gcc & MinGW. Tested with 0.59/60/61 & 62. The 0.4.60 (win32 zip) is compiled with GCC & MinGW. The
              Message 6 of 16 , Feb 13, 2005
              • 0 Attachment
                Hi Stef,

                This bug becomes in ALL binaries compiled with gcc & MinGW. Tested
                with 0.59/60/61 & 62.

                The 0.4.60 (win32 zip) is compiled with GCC & MinGW.
                The 0.4.59 (win32 zip) is compiled with MSVC.


                [PS] I don't have MSVC, if someone can build JAL (for Win32) with
                other compiler than GCC ...

                Regards,
                Javi.


                --- In Jal_developers@yahoogroups.com, Stef Mientki <s.mientki@m...>
                wrote:
                > hi Javi,
                >
                > Javier Martinez wrote:
                >
                > >Hi Stef,
                > >
                > > I've 0.4.62 installed. From your words I undertood that this bug
                > >comes since 0.4.60. I'll test it this week.
                > >
                > >
                > > I'm seeing this code OK with 0.4.62, perhaps is it related only to
                > >Windows binary?
                > >
                > >
                > >
                > Could be well possible.
                > I didn't test it on 4.61,
                > and 4.62 is not yet available in Windows binary :-(
                > I assumed the problem slipped in 4.60,
                > and afaik nobody has mentioned it, so it probably will also be in the
                > next versions.
                >
                > cheers,
                > Stef
              • Rob Hamerling
                ... Hello Stef, Javi, I compiled Stef s shortest code with my OS/2 version of Jal-0.4.60 (IBM VAC 3.0). It doesn t give the error you reported. Below the
                Message 7 of 16 , Feb 14, 2005
                • 0 Attachment
                  Stef Mientki wrote:
                  >
                  > did you really use JAL 4.60 (GCC 3.2) ?
                  >
                  > Here's my shortest source, that gives the error:
                  > (could you test this code, it doesn't need any libraries)
                  >

                  Hello Stef, Javi,
                  I compiled Stef's shortest code with my OS/2 version of Jal-0.4.60 (IBM
                  VAC 3.0). It doesn't give the error you reported. Below the relevant
                  part of the asm listing. Looks like your compiler-exe is bad.
                  Regards, Rob.

                  ------------------------------------------------------------------
                  errorlevel -306
                  list p=PIC12f675

                  ; note: the f629/675 config is still fixed!
                  __CONFIG H'3FE2'
                  ORG 0000
                  goto __main ; 0000: 2804 ; __main [0004]
                  ORG 0004
                  ORG 0004
                  __interrupt: ; 0004
                  __main: ; 0004
                  ; var H'020:000' transfer_bit
                  ; var H'020:000' transfer_byte

                  ;; 005 : var volatile byte PCL at 0x02
                  ; var H'002:000' pcl

                  ;; 006 : PCL = 4
                  movlw H'04' ; 0004: 3004 ; 4
                  movwf H'002' ; 0005: 0082 ; 0x002 pcl

                  ;; 008 : PCL = 2
                  movlw H'02' ; 0006: 3002 ; 2
                  movwf H'002' ; 0007: 0082 ; 0x002 pcl

                  ;; 003 : idle_loop: page goto idle_loop
                  as_878_idle_loop: ; 0008
                  goto as_878_idle_loop ; 0008: 2808 ; [0008]

                  END










                  --
                  Rob Hamerling, Vianen, NL phone +31-347-322822
                  homepage: http://www.robh.nl/
                • Rob Hamerling
                  Hi Javi, ... My OS/2 version of JAL-0.4.62 (IBM VAC 3.0) generates: ; ********** variable mapping ; 02:0 : ; ; pcl * 0005:19
                  Message 8 of 16 , Feb 14, 2005
                  • 0 Attachment
                    Hi Javi,

                    Javier Martinez wrote:

                    > ; ********** variable mapping
                    > ; 02:0 : ;
                    > ; pcl * 0004:19 tstef.jal
                    > ; 20:0 : ;
                    > ; transfer_byte
                    > ; transfer_bit

                    My OS/2 version of JAL-0.4.62 (IBM VAC 3.0) generates:

                    ; ********** variable mapping
                    ; 02:0 : ;
                    ; pcl * 0005:19 0000000000000000000000
                    ; 20:0 : ;
                    ; transfer_byte
                    ; transfer_bit

                    I truncated the line with the many '0'-chars. It is in reality 259 chars
                    line, ending with: 0000.000000new2005022.653353E-129txt
                    I don't know what it means, but it looks like wrong string handling.

                    When I compile it with my OS/2 version of JAL-0.4.62 (Watcom Open C
                    1.30) the compilation aborts prematurely (without generating hex or asm
                    files). I won't bother you with the error OS/2 codes ;-(

                    Regards, Rob.

                    --
                    Rob Hamerling, Vianen, NL phone +31-347-322822
                    homepage: http://www.robh.nl/
                  • japus10
                    Hi Stef, Rob, You re in the right way, but rather the compiler seems to be the configuration of each system. I ve compiled again JAL with CygWin & GCC, now
                    Message 9 of 16 , Feb 14, 2005
                    • 0 Attachment
                      Hi Stef, Rob,

                      You're in the right way, but rather the compiler seems to be the
                      configuration of each system.

                      I've compiled again JAL with CygWin & GCC, now seems to work.

                      Stef, please, test your files with this file:
                      http://groups.yahoo.com/group/Jal_developers/files/jal-0.4.62.exe

                      ... and report if works OK or not (inside JALcc, etc).


                      Regards,
                      Javi.


                      --- In Jal_developers@yahoogroups.com, Rob Hamerling
                      <r.hamerling@h...> wrote:
                      >
                      > Hi Javi,
                      >
                      > Javier Martinez wrote:
                      >
                      > > ; ********** variable mapping
                      > > ; 02:0 : ;
                      > > ; pcl * 0004:19 tstef.jal
                      > > ; 20:0 : ;
                      > > ; transfer_byte
                      > > ; transfer_bit
                      >
                      > My OS/2 version of JAL-0.4.62 (IBM VAC 3.0) generates:
                      >
                      > ; ********** variable mapping
                      > ; 02:0 : ;
                      > ; pcl * 0005:19 0000000000000000000000
                      > ; 20:0 : ;
                      > ; transfer_byte
                      > ; transfer_bit
                      >
                      > I truncated the line with the many '0'-chars. It is in reality 259
                      chars
                      > line, ending with: 0000.000000new2005022.653353E-129txt
                      > I don't know what it means, but it looks like wrong string handling.
                      >
                      > When I compile it with my OS/2 version of JAL-0.4.62 (Watcom Open C
                      > 1.30) the compilation aborts prematurely (without generating hex or asm
                      > files). I won't bother you with the error OS/2 codes ;-(
                      >
                      > Regards, Rob.
                      >
                      > --
                      > Rob Hamerling, Vianen, NL phone +31-347-322822
                      > homepage: http://www.robh.nl/
                    • Stef Mientki
                      hello Javi, ... thanks for the help, but the compiler won t run :-( because it s missing some CYGWIN1.DLL ??? Stef
                      Message 10 of 16 , Feb 14, 2005
                      • 0 Attachment
                        hello Javi,

                        japus10 wrote:

                        >Hi Stef, Rob,
                        >
                        > You're in the right way, but rather the compiler seems to be the
                        >configuration of each system.
                        >
                        > I've compiled again JAL with CygWin & GCC, now seems to work.
                        >
                        > Stef, please, test your files with this file:
                        >http://groups.yahoo.com/group/Jal_developers/files/jal-0.4.62.exe
                        >
                        > ... and report if works OK or not (inside JALcc, etc).
                        >
                        >
                        >
                        thanks for the help,
                        but the compiler won't run :-(
                        because it's missing some CYGWIN1.DLL ???

                        Stef

                        >Regards,
                        >Javi.
                        >
                        >
                        >--- In Jal_developers@yahoogroups.com, Rob Hamerling
                        ><r.hamerling@h...> wrote:
                        >
                        >
                        >>Hi Javi,
                        >>
                        >>Javier Martinez wrote:
                        >>
                        >>
                        >>
                        >>>; ********** variable mapping
                        >>>; 02:0 : ;
                        >>>; pcl * 0004:19 tstef.jal
                        >>>; 20:0 : ;
                        >>>; transfer_byte
                        >>>; transfer_bit
                        >>>
                        >>>
                        >>My OS/2 version of JAL-0.4.62 (IBM VAC 3.0) generates:
                        >>
                        >>; ********** variable mapping
                        >>; 02:0 : ;
                        >>; pcl * 0005:19 0000000000000000000000
                        >>; 20:0 : ;
                        >>; transfer_byte
                        >>; transfer_bit
                        >>
                        >>I truncated the line with the many '0'-chars. It is in reality 259
                        >>
                        >>
                        >chars
                        >
                        >
                        >>line, ending with: 0000.000000new2005022.653353E-129txt
                        >>I don't know what it means, but it looks like wrong string handling.
                        >>
                        >>When I compile it with my OS/2 version of JAL-0.4.62 (Watcom Open C
                        >>1.30) the compilation aborts prematurely (without generating hex or asm
                        >>files). I won't bother you with the error OS/2 codes ;-(
                        >>
                        >>Regards, Rob.
                        >>
                        >>--
                        >>Rob Hamerling, Vianen, NL phone +31-347-322822
                        >>homepage: http://www.robh.nl/
                        >>
                        >>
                        >
                        >
                        >
                        >
                        >
                        >
                        >
                        >Yahoo! Groups Links
                        >
                        >
                        >
                        >
                        >
                        >
                        >
                        >
                        >
                        >
                        >
                      • Javier Martinez
                        Hi Stef, DAM!! That s why I prefer MinGW rather than CygWin! I forget the dlls. I ll upload it tomorrow, but I prefer a binary executable compiled with other
                        Message 11 of 16 , Feb 14, 2005
                        • 0 Attachment
                          Hi Stef,

                          DAM!!

                          That's why I prefer MinGW rather than CygWin! I forget the dlls.

                          I'll upload it tomorrow, but I prefer a binary executable compiled
                          with other tool, like MSVC, BCC, etc. Anyone can be the windows version
                          manager?



                          Regards,
                          Javi.


                          El lun, 14-02-2005 a las 19:13 +0100, Stef Mientki escribió:
                          > hello Javi,
                          >
                          > japus10 wrote:
                          >
                          > >Hi Stef, Rob,
                          > >
                          > > You're in the right way, but rather the compiler seems to be the
                          > >configuration of each system.
                          > >
                          > > I've compiled again JAL with CygWin & GCC, now seems to work.
                          > >
                          > > Stef, please, test your files with this file:
                          > >http://groups.yahoo.com/group/Jal_developers/files/jal-0.4.62.exe
                          > >
                          > > ... and report if works OK or not (inside JALcc, etc).
                          > >
                          > >
                          > >
                          > thanks for the help,
                          > but the compiler won't run :-(
                          > because it's missing some CYGWIN1.DLL ???
                          >
                          > Stef
                        • Rob Hamerling
                          ... Javi, If you want I could try to build a W32 version with the Watcom compiler. Cannot be too difficult, I ve done it also for the Windoze version of my
                          Message 12 of 16 , Feb 14, 2005
                          • 0 Attachment
                            Javier Martinez wrote:

                            > That's why I prefer MinGW rather than CygWin! I forget the dlls.
                            >
                            > I'll upload it tomorrow, but I prefer a binary executable compiled
                            > with other tool, like MSVC, BCC, etc. Anyone can be the windows version
                            > manager?

                            Javi,

                            If you want I could try to build a W32 version with the Watcom compiler.
                            Cannot be too difficult, I've done it also for the Windoze version of my
                            XWisp2 program.

                            Regards, Rob.


                            --
                            Rob Hamerling, Vianen, NL phone +31-347-322822
                            homepage: http://www.robh.nl/
                          • Javier Martinez
                            Hi Rob, Well, let s try it. Surely will work fine. Regards, Javi.
                            Message 13 of 16 , Feb 14, 2005
                            • 0 Attachment
                              Hi Rob,

                              Well, let's try it. Surely will work fine.


                              Regards,
                              Javi.



                              El lun, 14-02-2005 a las 20:04 +0100, Rob Hamerling escribió:
                              >
                              >
                              > Javier Martinez wrote:
                              >
                              > > That's why I prefer MinGW rather than CygWin! I forget the dlls.
                              > >
                              > > I'll upload it tomorrow, but I prefer a binary executable
                              > compiled
                              > > with other tool, like MSVC, BCC, etc. Anyone can be the windows
                              > version
                              > > manager?
                              >
                              > Javi,
                              >
                              > If you want I could try to build a W32 version with the Watcom
                              > compiler.
                              > Cannot be too difficult, I've done it also for the Windoze version of
                              > my
                              > XWisp2 program.
                              >
                              > Regards, Rob.
                              >
                              >
                              > --
                              > Rob Hamerling, Vianen, NL phone +31-347-322822
                              > homepage: http://www.robh.nl/
                              >
                            • mgross
                              ... I know that I ve fallen off the planet on JAL dev stuff, but I could build the bits using my MSVC installation. However; if you are using JAL under Cygwin,
                              Message 14 of 16 , Feb 14, 2005
                              • 0 Attachment
                                On Mon, 2005-02-14 at 20:04 +0100, Rob Hamerling wrote:
                                > Javier Martinez wrote:
                                >
                                > > That's why I prefer MinGW rather than CygWin! I forget the dlls.
                                > >
                                > > I'll upload it tomorrow, but I prefer a binary executable
                                > compiled
                                > > with other tool, like MSVC, BCC, etc. Anyone can be the windows
                                > version
                                > > manager?
                                >
                                > Javi,
                                >
                                > If you want I could try to build a W32 version with the Watcom
                                > compiler.
                                > Cannot be too difficult, I've done it also for the Windoze version of
                                > my
                                > XWisp2 program.
                                >
                                > Regards, Rob.
                                >
                                I know that I've fallen off the planet on JAL dev stuff, but I could
                                build the bits using my MSVC installation.

                                However; if you are using JAL under Cygwin, I think you are better off
                                building the JAL from source and doing the "make install".

                                I'm pretty sure I can still do releases.

                                --mgross
                              • japus10
                                Hi Mark, The *problem* with Cygwin is that JAL needs the refered library (cygwin1.dll) to work. In MinGW this seems to be linked inside the executable. CygWin
                                Message 15 of 16 , Feb 14, 2005
                                • 0 Attachment
                                  Hi Mark,

                                  The *problem* with Cygwin is that JAL needs the refered library
                                  (cygwin1.dll) to work. In MinGW this seems to be linked inside the
                                  executable.

                                  CygWin it's a good choice for me since make, automake, autoconf,
                                  etc are available too; but it's not so good that a *normal* user must
                                  keep in path a 1.1MB file (this remember me the VB, one_dll/version).


                                  I'll be very grateful if you builds JAL with MSVC, I'll make the
                                  package.


                                  Regads,
                                  Javi.



                                  --- In Jal_developers@yahoogroups.com, mgross <mark@t...> wrote:
                                  > On Mon, 2005-02-14 at 20:04 +0100, Rob Hamerling wrote:
                                  > > Javier Martinez wrote:
                                  > >
                                  > > > That's why I prefer MinGW rather than CygWin! I forget the dlls.
                                  > > >
                                  > > > I'll upload it tomorrow, but I prefer a binary executable
                                  > > compiled
                                  > > > with other tool, like MSVC, BCC, etc. Anyone can be the windows
                                  > > version
                                  > > > manager?
                                  > >
                                  > > Javi,
                                  > >
                                  > > If you want I could try to build a W32 version with the Watcom
                                  > > compiler.
                                  > > Cannot be too difficult, I've done it also for the Windoze version of
                                  > > my
                                  > > XWisp2 program.
                                  > >
                                  > > Regards, Rob.
                                  > >
                                  > I know that I've fallen off the planet on JAL dev stuff, but I could
                                  > build the bits using my MSVC installation.
                                  >
                                  > However; if you are using JAL under Cygwin, I think you are better off
                                  > building the JAL from source and doing the "make install".
                                  >
                                  > I'm pretty sure I can still do releases.
                                  >
                                  > --mgross
                                • Rob Hamerling
                                  Hi Javi, [Rob] ... I tried last night and could build a W32 version of Jal.exe. However when I tried to compile Stef s bug-test JAL-program this compiler
                                  Message 16 of 16 , Feb 15, 2005
                                  • 0 Attachment
                                    Hi Javi,

                                    [Rob]
                                    >>If you want I could try to build a W32 version with the Watcom
                                    >>compiler. Cannot be too difficult, I've done it also for the
                                    >>Windoze version of my XWisp2 program.

                                    Javier Martinez wrote:
                                    >
                                    > Well, let's try it. Surely will work fine.
                                    >

                                    I tried last night and could build a W32 version of Jal.exe. However
                                    when I tried to compile Stef's bug-test JAL-program this compiler
                                    aborted! Don't know why and I don't have time to look at it today...

                                    Regards, Rob.


                                    --
                                    Rob Hamerling, Vianen, NL phone +31-347-322822
                                    homepage: http://www.robh.nl/
                                  Your message has been successfully submitted and would be delivered to recipients shortly.