Loading ...
Sorry, an error occurred while loading the content.
 

Re: Problem with Jaybird 2.2 or 2.1 and Firebird 2.5 beta 1

Expand Messages
  • Peter Welch
    Mark, That helped clear things up. Thank you. Still nothing about 64 bit though. Here s the way I call Jaybird in Rhapsody Interface Engine:
    Message 1 of 8 , Aug 3, 2009
      Mark,

      That helped clear things up. Thank you. Still nothing about 64 bit though.

      Here's the way I call Jaybird in Rhapsody Interface Engine:

      <driver>org.firebirdsql.jdbc.FBDriver</driver>
      <url>jdbc:firebirdsql:122.22.3.2/3050:/SAN/databases/ADT.fdb</url>

      Does anything above explain the failure with Firebird 2.5 beta 1?

      --- In Firebird-Java@yahoogroups.com, Mark Rotteveel <Avalanche1979@...> wrote:
      >
      > Peter Welch wrote:
      > > Adriano,
      > >
      > > Thank you for your reply. Unfortunately, I don't understand your questions. I didn't know I had a choice of drivers. What I've been doing is attaching the Jaybird-full-2.1.6.jar file (for JDK 1.4) to the Rhapsody Database Communication Points. I tried Jaybird 2.2 with the same result.
      > >
      > > There is no reference to 64 bit in any of the downloads from the Wiki, nor native versus java -- except that the early Jaybird 1.0 was pure java.
      > >
      > > Pete
      >
      > See the DriverExample.java in the examples folder for the various
      > connection URLs. Most likely you are using the type 4 (pure Java) driver.
      >
      > --
      > Mark Rotteveel
      >
    • Roman Rokytskyy
      ... Pure-Java version is of course 64-bit compatible - the wire protocol is platform independent. Roman
      Message 2 of 8 , Aug 3, 2009
        > That helped clear things up. Thank you. Still nothing about 64 bit though.

        Pure-Java version is of course 64-bit compatible - the wire protocol is
        platform independent.

        Roman
      Your message has been successfully submitted and would be delivered to recipients shortly.