Loading ...
Sorry, an error occurred while loading the content.

Re: [Firebird-Java] connection rejected by remote interface

Expand Messages
  • Steven Jardine
    Yeah, thanks. Right after I sent my last email I saw that setting. I also added the cps values. Thanks! Steve Here is my firebird services file if anyone
    Message 1 of 17 , May 3, 2007
    View Source
    • 0 Attachment
      Yeah, thanks. Right after I sent my last email I saw that setting. I
      also added the cps values. Thanks!

      Steve

      Here is my firebird services file if anyone cares:
      service gds_db
      {
      disable = no
      flags = REUSE KEEPALIVE NOLIBWRAP NODELAY
      socket_type = stream
      wait = no
      user = root
      server = /opt/firebird/bin/fb_inet_server
      instances = UNLIMITED
      per_source = UNLIMITED
      cps = 200 5
      }

      Steve Wiser wrote:
      > If you are expecting a lot of connections to come in at one time you
      > should also look at modifying the cps values in your xinetd.conf file.
      >
      > -steve
      >
      > Steven Jardine wrote:
      >
      >> Hey Roman,
      >>
      >> Thanks for the quick reply! You are always a big help.
      >>
      >>> Do you see something in FB's log? What about reducing number of
      >>> connections in the pools (in case you have some limitations in your
      >>> xinetd configuration)?
      >>>
      >> I missed the "xinetd[3276]: FAIL: gds_db per_source_limit
      >> from=127.0.0.1" messages in the log file. Dumb huh?
      >>
      >> Anyway I added "instances = UNLIMITED" and "per_source = UNLIMITED" to
      >> the firebird xinetd service file and everything is working now. Thanks
      >> again for pointing me in the right direction.
      >>
      >> Steve
      >>
      >>
      >>
      >
      >
      >
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
    • ferry_new2004
      Excuse me, I am also interested in this topic. Last time, my java program also could not get connection from firebird. I take this conclusion because after I
      Message 2 of 17 , Aug 6, 2007
      View Source
      • 0 Attachment
        Excuse me, I am also interested in this topic.
        Last time, my java program also could not get connection from
        firebird. I take this conclusion because after I restarted the linux
        firebird server machine, the java program run properly.

        No error message from java program but it just stop giving any
        response (print out next message is stopped due to process in getting
        connection from firebird).

        I use firebird 2.0 and JDK 1.5.06 (hibernate).


        From firebird log file, it is written :

        trial.union.fam (Server) Mon Aug 6 16:05:36 2007
        INET/inet_error: read errno = 104


        trial.union.fam (Server) Mon Aug 6 16:42:24 2007
        INET/inet_error: read errno = 104




        Are there any way to detect active session?
        or how to kill hang session database session ?
        How to enlarge number firebird database connection allowed ?
        Is the default configuration file (after installing firebird) the best
        configuration ? Is there any attribute of firebird configuration file
        (firebird.conf) to be modified if we use firebird in a heavy and
        numerous connection and Local Area Network connection (not WAN)?


        I don't understand about :
        > Here is my firebird services file if anyone cares:
        > service gds_db
        > {
        > disable = no
        > flags = REUSE KEEPALIVE NOLIBWRAP NODELAY
        > socket_type = stream
        > wait = no
        > user = root
        > server = /opt/firebird/bin/fb_inet_server
        > instances = UNLIMITED
        > per_source = UNLIMITED
        > cps = 200 5
        > }

        How to change the values ? I tried to find the configuration above in
        firebird files, but i didn't find it.



        Thank you very much.


        Regards,
        Ferry


        --- In Firebird-Java@yahoogroups.com, Steven Jardine <steve@...> wrote:
        >
        > Yeah, thanks. Right after I sent my last email I saw that setting. I
        > also added the cps values. Thanks!
        >
        > Steve
        >
        > Here is my firebird services file if anyone cares:
        > service gds_db
        > {
        > disable = no
        > flags = REUSE KEEPALIVE NOLIBWRAP NODELAY
        > socket_type = stream
        > wait = no
        > user = root
        > server = /opt/firebird/bin/fb_inet_server
        > instances = UNLIMITED
        > per_source = UNLIMITED
        > cps = 200 5
        > }
        >
        > Steve Wiser wrote:
        > > If you are expecting a lot of connections to come in at one time you
        > > should also look at modifying the cps values in your xinetd.conf file.
        > >
        > > -steve
        > >
        > > Steven Jardine wrote:
        > >
        > >> Hey Roman,
        > >>
        > >> Thanks for the quick reply! You are always a big help.
        > >>
        > >>> Do you see something in FB's log? What about reducing number of
        > >>> connections in the pools (in case you have some limitations in your
        > >>> xinetd configuration)?
        > >>>
        > >> I missed the "xinetd[3276]: FAIL: gds_db per_source_limit
        > >> from=127.0.0.1" messages in the log file. Dumb huh?
        > >>
        > >> Anyway I added "instances = UNLIMITED" and "per_source =
        UNLIMITED" to
        > >> the firebird xinetd service file and everything is working now.
        Thanks
        > >> again for pointing me in the right direction.
        > >>
        > >> Steve
        > >>
        > >>
        > >>
        > >
        > >
        > >
        > >
        > > Yahoo! Groups Links
        > >
        > >
        > >
        > >
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.