Loading ...
Sorry, an error occurred while loading the content.

Re: [FT897] NEED HELP WITH DEAD fT 897

Expand Messages
  • Sean Clark
    Hi Steve, Just a shot in the dark here but...... Do any LED s work on the front when you turn it on?  Or is it just the LCD display? If the DSP LED is not
    Message 1 of 14 , Nov 17, 2012
    • 0 Attachment
      Hi Steve,

      Just a shot in the dark here but......

      Do any LED's work on the front when you turn it on?  Or is it just the LCD display?

      If the DSP LED is not working then check the panel unit at TP4017 for 8v.

      If you have 8v there then check TP4036 for 5v.  This is the 5v buss that feeds the LED's and display LCD as well as the main processor (and other components) on the panel unit..

      Don't forget to do the normal checks like making sure the panel unit has a good ground and all connectors are reseated.

      If you don't have the service manual you will need it.

      Good Luck ~ N9ATV

      --- On Fri, 11/16/12, w4yj1948 <sefritts@...> wrote:
















       









      HELLO ALL,



      My FT897 has stopped working. The display is totally dead. No display at all. Yet is receieves and it also seems to transmit. Any ideas before I send it back to Yaesu?



      Thank you for any help



      Steve W4YJ

















      [Non-text portions of this message have been removed]
    • Michael Lavoie
      I just contacted Yaesu to see how much it would cost to get my 897 realigned. They told me it is $35 for an estimate and $70 per hour plus any parts the $35
      Message 2 of 14 , Nov 20, 2012
      • 0 Attachment
        I just contacted Yaesu to see how much it would cost to get my 897
        realigned. They told me it is $35 for an estimate and $70 per hour plus any
        parts the $35 estimate fee is waived if the repair is approved. It has to
        be shipped to Cypress, CA.

        73 N1AMD Mike
        On Nov 20, 2012 12:55 PM, "William" <wabarron@...> wrote:

        > **
        >
        >
        > Did you previously set it up to operate with Ham radio Deluxe?
        > If so, you might be able to connect with that software and see the screen
        > and control the menus....
        >
        > But it sounds like a trip to the factory .....
        >
        > 73,
        > Bill W1WAB
        >
        > --- In FT897@yahoogroups.com, "w4yj1948" <sefritts@...> wrote:
        > >
        > > HELLO ALL,
        > >
        > > My FT897 has stopped working. The display is totally dead. No display at
        > all. Yet is receieves and it also seems to transmit. Any ideas before I
        > send it back to Yaesu?
        > >
        > > Thank you for any help
        > >
        > > Steve W4YJ
        > >
        >
        >
        >


        [Non-text portions of this message have been removed]
      • w4yj1948
        Success!!! THANK YOU to all who wrote me and helped. Frank, m0els suggested the idea of holding in the function key until it beeped twice and then counting 41
        Message 3 of 14 , Nov 20, 2012
        • 0 Attachment
          Success!!! THANK YOU to all who wrote me and helped. Frank, m0els suggested the idea of holding in the function key until it beeped twice and then counting 41 clicks to menu 42 and adjusting the contrast. I was then able to see the display even tho it was dim and in black and white. I then went to the MODE setting and turned it on!
          All is well now! Thank you to ALL who wrote and helped! I did not think about doing a reset as someone else suggested and also using HRD.
          Again thank you to all!

          Steve W4YJ

          --- In FT897@yahoogroups.com, Davekh <davekh@...> wrote:
          >
          > Try
          > One or both of these from the manual:
          >
          > Power-up pressing
          > [F] + POWER on:
          > Resets all menu settings (except the following menu items) to their
          > factory-default values.
          >
          > or
          > [HOME] + POWER on: CPU master reset for all memories and menu
          > settings.
          >
          >
          > Might bring it back - you might have got the contract set to zero - so
          > the top one might do it - if not try the second one.
          >
          > good luck
          > Dave H G0CER
          >
          >
          >
          > On Tue, 20 Nov 2012 13:45:20 -0000, George wrote:
          > > Hmmmm
          > > and what about to use HRD.....?
          > > G.
          > >
          > > --- In FT897@yahoogroups.com, "w4yj1948" <sefritts@> wrote:
          > >>
          > >>
          > >> How can I change the backlight when I can not even see how to get to
          > >> the menu to change it??
          > >>
          > >> Steve W4YJ
          > >> --- In FT897@yahoogroups.com, "wa9fvp" <willcoele@> wrote:
          > >> >
          > >> >
          > >> > Sounds like the backlight is dead. Did you try changing the
          > >> backlight settings?
          > >> > --- In FT897@yahoogroups.com, "w4yj1948" <sefritts@> wrote:
          > >> > >
          > >> > > HELLO ALL,
          > >> > >
          > >> > > My FT897 has stopped working. The display is totally dead. No
          > >> display at all. Yet is receieves and it also seems to transmit. Any
          > >> ideas before I send it back to Yaesu?
          > >> > >
          > >> > > Thank you for any help
          > >> > >
          > >> > > Steve W4YJ
          > >> > >
          > >> >
          > >>
          > >
          > >
          > >
          > >
          > > ------------------------------------
          > >
          > > Yahoo! Groups Links
          > >
          > >
          > >
          >
        • wa9fvp
          The 897 has a power on/off circuit that s somewhat complicated. It s designed to completely remove power from the battery when the radio is turned off. The
          Message 4 of 14 , Nov 21, 2012
          • 0 Attachment
            The 897 has a power on/off circuit that's somewhat complicated. It's designed to completely remove power from the battery when the radio is turned off. The power switch monetarily applies power to the power relay that in turn powers the main CPU. Once the CPU is up and running, it keeps the power relay engaged until the power switch is pressed again. Then the power relay is turned off.

            Just about every 987 that I repair, has a problem in then power on/off circuit. Either diode is damaged or the transistor that powers the power relay is bad. The power relay circuits are on the RF power amplifier board. I even found damaged components near the CPU power on/off circuits on the main board.

            Jack WA9FVP
            Willco Electronics.


            --- In FT897@yahoogroups.com, Michael Lavoie <bronsens@...> wrote:
            >
            > I just contacted Yaesu to see how much it would cost to get my 897
            > realigned. They told me it is $35 for an estimate and $70 per hour plus any
            > parts the $35 estimate fee is waived if the repair is approved. It has to
            > be shipped to Cypress, CA.
            >
            > 73 N1AMD Mike
            > On Nov 20, 2012 12:55 PM, "William" <wabarron@...> wrote:
            >
            > > **
            > >
            > >
            > > Did you previously set it up to operate with Ham radio Deluxe?
            > > If so, you might be able to connect with that software and see the screen
            > > and control the menus....
            > >
            > > But it sounds like a trip to the factory .....
            > >
            > > 73,
            > > Bill W1WAB
            > >
            > > --- In FT897@yahoogroups.com, "w4yj1948" <sefritts@> wrote:
            > > >
            > > > HELLO ALL,
            > > >
            > > > My FT897 has stopped working. The display is totally dead. No display at
            > > all. Yet is receieves and it also seems to transmit. Any ideas before I
            > > send it back to Yaesu?
            > > >
            > > > Thank you for any help
            > > >
            > > > Steve W4YJ
            > > >
            > >
            > >
            > >
            >
            >
            > [Non-text portions of this message have been removed]
            >
          • John Randall
            The actual problem was that his radio s menu 42 and 43 was switched off, so his radio appeared to be dead....ie no display, he could not see the display to
            Message 5 of 14 , Nov 22, 2012
            • 0 Attachment
              The actual problem was that his radio's menu 42 and 43 was switched off, so his radio appeared to be dead....ie no display, he could not see the display to make these changes.

              I merely gave him some instructions as follows to switch them one again.

              1) press and hold function key till it beeps twice.
              2) rotate mem/vfo knob untill you hear a beep, this is menu 001
              3) rotate mem/vfo knob 41 clicks to the right, this is menu 042 contrast
              4) rotate vfo to change contrast
              5) if no change then go one more click to the right which is menu 043 intensity, rotate vfo to change this.

              This has got his rig up and running again.

              73
              John


              [Non-text portions of this message have been removed]
            • Hank Lambert
              That saved him about $75.00. My Web site has resources for the 857D and 897D. I am going to add a troubleshooting section on each and this will be the first
              Message 6 of 14 , Nov 22, 2012
              • 0 Attachment
                That saved him about $75.00. My Web site has resources for the 857D and
                897D. I am going to add a troubleshooting section on each and this will be
                the first tip I add.



                One question, would a complete system reset have fixed this?



                73,





                Hank Lambert

                KB4MTO/TA5ZC

                hank@...

                kb4mto@...

                www.hanklambert.com

                PGP Key: 0x9DFFC21E



                Years ago, many hams used to work a lot of DX until they got their hands on
                an SWR meter and found out they couldn't.







                From: FT897@yahoogroups.com [mailto:FT897@yahoogroups.com] On Behalf Of John
                Randall
                Sent: Thursday, November 22, 2012 5:07 AM
                To: FT897@yahoogroups.com
                Subject: [FT897] Re: NEED HELP WITH DEAD fT 897





                The actual problem was that his radio's menu 42 and 43 was switched off, so
                his radio appeared to be dead....ie no display, he could not see the display
                to make these changes.

                I merely gave him some instructions as follows to switch them one again.

                1) press and hold function key till it beeps twice.
                2) rotate mem/vfo knob untill you hear a beep, this is menu 001
                3) rotate mem/vfo knob 41 clicks to the right, this is menu 042 contrast
                4) rotate vfo to change contrast
                5) if no change then go one more click to the right which is menu 043
                intensity, rotate vfo to change this.

                This has got his rig up and running again.

                73
                John






                [Non-text portions of this message have been removed]
              • David Okrent
                I recently had my display go blank. I sent ot in and it was a cold solder joint, not an unknown problem. Repair and alignment with shipping, about $100. Home
                Message 7 of 14 , Nov 22, 2012
                • 0 Attachment
                  I recently had my display go blank. I sent ot in and it was a cold solder
                  joint, not an unknown problem. Repair and alignment with shipping, about
                  $100.

                  Home Email: dokrent@...
                  W7DAO
                Your message has been successfully submitted and would be delivered to recipients shortly.