Loading ...
Sorry, an error occurred while loading the content.

Re: TABLEXLS error

Expand Messages
  • Luis_Rodriguez_98
    Additional info: Found it just happens when trying to generate a .xlsx. A .xls in the output works ok. We are on V5R3. Thanks in advance, Luis
    Message 1 of 13 , May 9, 2013
    • 0 Attachment
      Additional info:

      Found it just happens when trying to generate a .xlsx. A .xls in the output works ok.
      We are on V5R3.

      Thanks in advance,

      Luis
      --- In Easy400Group@yahoogroups.com, "Luis_Rodriguez_98" <luis_rodriguez_98@...> wrote:
      >
      > Sorry, forgot the command I'm using:
      >
      > TABLEXLS FROMFILE(mylib/myfile)
      > TOXLS('/home/temp/myexcel.xlsx')
      > PRTHDR(*DFT *NO)
      > PRTORIENT(*LANDSCAPE)
      > PRTSCALE(75)
      > HDGCOLOR(GOLD)
      > DOWNLOAD(*NO)
      >
      >
      > --- In Easy400Group@yahoogroups.com, "Luis_Rodriguez_98" <luis_rodriguez_98@> wrote:
      > >
      > > Hi,
      > >
      > > Trying to run TABLEXLS. Keep getting the following Java error:
      > >
      > > FATAL ERROR in native method: Wrong method ID used to invoke a Java method
      > > java.lang.Throwable
      > >
      > > DSPERRS gives:
      > > Program status for error dated 2013-05-09-15.29.26
      > >
      > > Procedure name: XLSXGEN
      > > Program containing procedure: XLSXGEN
      > > Module containing procedure: XLSXGEN
      > > RPG IV src statement: 00257200
      > > RPG IV routine: getPrint
      > >
      > > Enviroment variables are:
      > > QIBM_RPG_JAVA_PROPERTIES
      > > '-Djava.version=1.5;-Djava.awt.headless=true;-Dos400.awt.native=true;'
      > >
      > > CLASSPATH
      > > '/hssfcgi/java/dom4j/dom4j-1.6.1.jar:/hssfcgi/java/
      > > poi3.6/poi-ooxml-schemas-3.6-20091214.jar:/hssfcgi/java/poi3.6/poi-ooxml-3.6-200
      > > 91214.jar:/hssfcgi/java/poi3.6/poi-3.6-20091214.jar:/hssfcgi/java/xlparse3.6/xlp
      > > arse.jar:/hssfcgi/java/xmlbeans/jsr173_1.0_api.jar:/hssfcgi/java/xmlbeans/xbean.
      > > jar'
      > >
      > > Table has only 25 rows...
      > >
      > > Any ideas?
      > >
      > > Thanks,
      > >
      > > Luis Rodriguez
      > >
      >
    • Giovanni B. Perotti
      Extension .XLSX is not supported on V5R3. You need V5R4 or subsequent. Did you read HSSFCGI prerequisites? Get to page
      Message 2 of 13 , May 9, 2013
      • 0 Attachment

        Extension .XLSX is not supported on V5R3. You need V5R4 or subsequent.

        Did you read HSSFCGI prerequisites?

        Get to page http://www.easy400.net/hssfcgi/html/page1.htm#2

        Thank you!

         

        Giovanni B. Perotti

        www.easy400.net - Free WEB utilities for IBM System i 

        Contribute to site Easy400.net: http://www.easy400.net/easy400p/contribute.html

         

         

         

        Da: Easy400Group@yahoogroups.com [mailto:Easy400Group@yahoogroups.com] Per conto di Luis_Rodriguez_98
        Inviato: giovedì 9 maggio 2013 22:41
        A: Easy400Group@yahoogroups.com
        Oggetto: [Easy400Group] Re: TABLEXLS error

         

         


        Additional info:

        Found it just happens when trying to generate a .xlsx. A .xls in the output works ok.
        We are on V5R3.

        Thanks in advance,

        Luis

        --- In Easy400Group@yahoogroups.com, "Luis_Rodriguez_98" <luis_rodriguez_98@...> wrote:
        >
        > Sorry, forgot the command I'm using:
        >
        > TABLEXLS FROMFILE(mylib/myfile)
        > TOXLS('/home/temp/myexcel.xlsx')
        > PRTHDR(*DFT *NO)
        > PRTORIENT(*LANDSCAPE)
        > PRTSCALE(75)
        > HDGCOLOR(GOLD)
        > DOWNLOAD(*NO)
        >
        >
        > --- In Easy400Group@yahoogroups.com, "Luis_Rodriguez_98" <luis_rodriguez_98@> wrote:
        > >
        > > Hi,
        > >
        > > Trying to run TABLEXLS. Keep getting the following Java error:
        > >
        > > FATAL ERROR in native method: Wrong method ID used to invoke a Java method
        > > java.lang.Throwable
        > >
        > > DSPERRS gives:
        > > Program status for error dated 2013-05-09-15.29.26
        > >
        > > Procedure name: XLSXGEN
        > > Program containing procedure: XLSXGEN
        > > Module containing procedure: XLSXGEN
        > > RPG IV src statement: 00257200
        > > RPG IV routine: getPrint
        > >
        > > Enviroment variables are:
        > > QIBM_RPG_JAVA_PROPERTIES
        > > '-Djava.version=1.5;-Djava.awt.headless=true;-Dos400.awt.native=true;'
        > >
        > > CLASSPATH
        > > '/hssfcgi/java/dom4j/dom4j-1.6.1.jar:/hssfcgi/java/
        > > poi3.6/poi-ooxml-schemas-3.6-20091214.jar:/hssfcgi/java/poi3.6/poi-ooxml-3.6-200
        > > 91214.jar:/hssfcgi/java/poi3.6/poi-3.6-20091214.jar:/hssfcgi/java/xlparse3.6/xlp
        > > arse.jar:/hssfcgi/java/xmlbeans/jsr173_1.0_api.jar:/hssfcgi/java/xmlbeans/xbean.
        > > jar'
        > >
        > > Table has only 25 rows...
        > >
        > > Any ideas?
        > >
        > > Thanks,
        > >
        > > Luis Rodriguez
        > >
        >

      • Luis_Rodriguez_98
        Giovanni, My apologies. I did not read the prerequisites the last time I updated the software. I know that .xlsx was allowed in an older version (we are
        Message 3 of 13 , May 10, 2013
        • 0 Attachment
          Giovanni,

          My apologies. I did not read the prerequisites the last time I updated the software. I know that .xlsx was allowed in an older version (we are running Java 1.5 in our V5R3 box). In fact, about a year ago I sent you a mail regarding the use of *LANDSCAPE in .xlsx, so at least at the time I was generating that kind of Excel files.

          Sigh... I know we should be more current in our OS version but, sometimes, we have to do what we can with the cards management deals us...

          Thanks again for your help.

          Regards,
          Luis Rodriguez


          --- In Easy400Group@yahoogroups.com, "Giovanni B. Perotti" <gb_perotti@...> wrote:
          >
          > Extension .XLSX is not supported on V5R3. You need V5R4 or subsequent.
          >
          > Did you read HSSFCGI prerequisites?
          >
          > Get to page http://www.easy400.net/hssfcgi/html/page1.htm#2
          >
          > Thank you!
          >
          >
          >
          > Giovanni B. Perotti
          >
          > <http://www.easy400.net/> www.easy400.net - Free WEB utilities for IBM
          > System i
          >
          > Contribute to site Easy400.net:
          > http://www.easy400.net/easy400p/contribute.html
          >
          >
          >
          >
          >
          >
          >
          > Da: Easy400Group@yahoogroups.com [mailto:Easy400Group@yahoogroups.com] Per
          > conto di Luis_Rodriguez_98
          > Inviato: giovedì 9 maggio 2013 22:41
          > A: Easy400Group@yahoogroups.com
          > Oggetto: [Easy400Group] Re: TABLEXLS error
          >
          >
          >
          >
          >
          >
          > Additional info:
          >
          > Found it just happens when trying to generate a .xlsx. A .xls in the output
          > works ok.
          > We are on V5R3.
          >
          > Thanks in advance,
          >
          > Luis
          > --- In Easy400Group@yahoogroups.com <mailto:Easy400Group%40yahoogroups.com>
          > , "Luis_Rodriguez_98" <luis_rodriguez_98@> wrote:
          > >
          > > Sorry, forgot the command I'm using:
          > >
          > > TABLEXLS FROMFILE(mylib/myfile)
          > > TOXLS('/home/temp/myexcel.xlsx')
          > > PRTHDR(*DFT *NO)
          > > PRTORIENT(*LANDSCAPE)
          > > PRTSCALE(75)
          > > HDGCOLOR(GOLD)
          > > DOWNLOAD(*NO)
          > >
          > >
          > > --- In Easy400Group@yahoogroups.com
          > <mailto:Easy400Group%40yahoogroups.com> , "Luis_Rodriguez_98"
          > <luis_rodriguez_98@> wrote:
          > > >
          > > > Hi,
          > > >
          > > > Trying to run TABLEXLS. Keep getting the following Java error:
          > > >
          > > > FATAL ERROR in native method: Wrong method ID used to invoke a Java
          > method
          > > > java.lang.Throwable
          > > >
          > > > DSPERRS gives:
          > > > Program status for error dated 2013-05-09-15.29.26
          > > >
          > > > Procedure name: XLSXGEN
          > > > Program containing procedure: XLSXGEN
          > > > Module containing procedure: XLSXGEN
          > > > RPG IV src statement: 00257200
          > > > RPG IV routine: getPrint
          > > >
          > > > Enviroment variables are:
          > > > QIBM_RPG_JAVA_PROPERTIES
          > > > '-Djava.version=1.5;-Djava.awt.headless=true;-Dos400.awt.native=true;'
          > > >
          > > > CLASSPATH
          > > > '/hssfcgi/java/dom4j/dom4j-1.6.1.jar:/hssfcgi/java/
          > > >
          > poi3.6/poi-ooxml-schemas-3.6-20091214.jar:/hssfcgi/java/poi3.6/poi-ooxml-3.6
          > -200
          > > >
          > 91214.jar:/hssfcgi/java/poi3.6/poi-3.6-20091214.jar:/hssfcgi/java/xlparse3.6
          > /xlp
          > > >
          > arse.jar:/hssfcgi/java/xmlbeans/jsr173_1.0_api.jar:/hssfcgi/java/xmlbeans/xb
          > ean.
          > > > jar'
          > > >
          > > > Table has only 25 rows...
          > > >
          > > > Any ideas?
          > > >
          > > > Thanks,
          > > >
          > > > Luis Rodriguez
          > > >
          > >
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.