Loading ...
Sorry, an error occurred while loading the content.

Re: Question about Reusable Block

Expand Messages
  • wantrey
    It seemed to be a problem with non common properties on the schematics. Some symbols got double properties one property was shown as COMMON property - the
    Message 1 of 3 , Jul 13, 2012
    View Source
    • 0 Attachment
      It seemed to be a problem with non common properties on the schematics. Some symbols got double properties one property was shown as COMMON property - the other (same name) was shown as non common.

      Our local sales support engineer found it out after a week. I made a SR for double properties. Till now no one can explain how thes double attributes come into the schematic. Since I did only "PACKAGING".

      The common property file in the Library Manager stayed the same since over a year now. So these attributs are well defined.

      In the meanwhile we bought the reusable block license.

      Wolfgagn

      --- In DxDesigner_Users@yahoogroups.com, "robertdavies62" <robertdavies62@...> wrote:
      >
      >
      > This is probably an issue with the block name not matching the schematic name, in the reuse flow the block name and schematic name need to be the same otherwise it can't find the schematic to instantiate. For this particular case we are improving the error message to clearly indicate the issue. If on the other hand this is not the problem then you should log the issue with your Customer Support representative.
      > Rob.
      > PMM DxDesigner,
      > Mentor Graphics
      >
      > --- In DxDesigner_Users@yahoogroups.com, "wantrey" <wolfgang.antrey@> wrote:
      > >
      > > We had a test license for the Reusable block feature because we want to buy this option.
      > >
      > > I used several existing designs to make them several reusable blocks (logic only and logic physical).
      > >
      > > Very small designs worked pretty good.
      > > But our main goal to make a reusable block out of a CPU DSP block did not work at all.
      > > We have drawn a complete design and tried a LOGIC ONLY Reusable block.
      > > The Design packaged under DxDesigner before we put it into the library - a copy of the design could also be transferred into the Expedition without any problem.
      > >
      > > In an empty new design we tried to add the reusable block. We only got following error message:
      > > >Can't instantiate Reuse Block: Attribute does not exists, or has
      > > >different value (Property not found) General error. This re-usable
      > > >block cannot be instantiated into the design. Because: "Can not copy
      > > >Reuse Block definition"
      > >
      > > We got in touch with our sales manager - till now we did not get any hint what this failure message is about.
      > >
      > > Some problems have been identified in the schematic - like double properties (now a SR & DR). Also the onSheet connectors do not have names - but this is not a problem - since they do not work for hirarchical designs ....
      > >
      > > Does anyone use the reusable block license.
      > > Does anyone have some hints?
      > > Wolfgang
      > >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.