Loading ...
Sorry, an error occurred while loading the content.

Re: dstar.exe to dvtool - no audio

Expand Messages
  • Robin Cutshaw
    ... Hi Rick. What O/S are you running? You said 2nd USB headset? You have two on the system? Did you change the audio output in DVTool? You might have to
    Message 1 of 13 , Feb 29, 2008
    • 0 Attachment
      --- In DVDongle@yahoogroups.com, "rick.wakatori" <rickn@...> wrote:
      >
      > HI Philip and the others,
      > I am feeling the same difficulty that callsign are
      > displayed but no voice come to 2nd USB headphone.
      > I could not connect with any gateway so far.
      >
      > I need a help to comlete this work.
      > Rick, 7L1RLL in City of Kawasaki, Japan.
      > Photo: See http:www.qrz.com (callsign search)
      >

      Hi Rick. What O/S are you running? You said 2nd USB headset? You
      have two on the system? Did you change the audio output in DVTool?

      You might have to go into the O/S and make the 2nd USB headset your
      default audio output device. If you can get sounds from the computer
      to the 2nd USB headset, you should be able to get audio from DVTool
      there as well.

      73,
      Robin
      AA4RC
    • Philip Robinson
      Paul, I did discover that I am getting audio on the first transmission but not on follow on transmissions. I guess before I was hitting the PTT momentarily to
      Message 2 of 13 , Mar 2, 2008
      • 0 Attachment
        Paul,

        I did discover that I am getting audio on the first transmission but
        not on follow on transmissions. I guess before I was hitting the PTT
        momentarily to make sure dstar.exe was working. I see in the
        dvtool.txt document that it has noted that "stream complete" on the
        first transmission but if I send another transmission I do not here
        the audio and I do not get the "stream complete". Dstar.exe works
        just the same either way displaying the call sign information. I do
        not see any indication from dstar.exe that it even knows when audio
        is present. If I shut down dstar.exe, change ports, and reconnect
        back up it will pass the first audio transmission but not second and
        on. I cannot reuse the previous ports until I shut down that command
        prompt (dos shell) and open a new one. Then I can reuse previous
        ports. I have moved dstar.exe to a different computer still same
        results as above.

        Any ideas?

        Thanks,

        Philip
        KB5ASY
      • rick.wakatori
        HI Phillip and the others, I am using DV-Dongle under Windows XP (SP2) with 1st-sound card and 2nd sound card. Radio output is connected to mic-in jack of 1st
        Message 3 of 13 , Mar 3, 2008
        • 0 Attachment
          HI Phillip and the others,

          I am using DV-Dongle under Windows XP (SP2) with 1st-sound card
          and 2nd sound card.

          Radio output is connected to mic-in jack of 1st sound card and
          operation mode is listen to peer-to-peer. But the port 6116 can not
          be assigned because of already used port.

          The dstar.exe reports some listening callsigns but no audio come
          up. DV-Dongle looks in activate mode during the operation.

          My 2nd-headset works well with DV-Dongle recording and play back.
          I have tried all combinations between all audio devices.

          I assume that a problem may be existing in the port assignment
          logic among Windows XP, Dongle-tools and dstar.exe.
          Or my over estimation may be existed on the functionality of the
          softwares.

          Rick, 7L1RLL, City of Kawasaki, Japan.

          --- In DVDongle@yahoogroups.com, "Robin Cutshaw" <aa4rc@...> wrote:
          >
          > --- In DVDongle@yahoogroups.com, "rick.wakatori" <rickn@> wrote:
          > >
          > > HI Philip and the others,
          > > I am feeling the same difficulty that callsign are
          > > displayed but no voice come to 2nd USB headphone.
          > > I could not connect with any gateway so far.
          > >
          > > I need a help to comlete this work.
          > > Rick, 7L1RLL in City of Kawasaki, Japan.
          > > Photo: See http:www.qrz.com (callsign search)
          > >
          >
          > Hi Rick. What O/S are you running? You said 2nd USB headset?
          You
          > have two on the system? Did you change the audio output in DVTool?
          >
          > You might have to go into the O/S and make the 2nd USB headset
          your
          > default audio output device. If you can get sounds from the
          computer
          > to the 2nd USB headset, you should be able to get audio from
          DVTool
          > there as well.
          >
          > 73,
          > Robin
          > AA4RC
          >
        • Philip Robinson
          Rick, I had better data decoding using the line in of the sound card than using the mic input but it sounds like you are decoding just fine. I would
          Message 4 of 13 , Mar 4, 2008
          • 0 Attachment
            Rick,

            I had better data decoding using the "line in" of the sound card
            than using the "mic" input but it sounds like you are decoding just
            fine. I would suggest trying a different port such as 6117 or higher
            if you have not already do so. Dstar.exe will default to 6116 but
            can be forced to what ever port you like. I still have not got past
            the first audio transmission limit and also not being able to reuse
            the same port in the same dos session. Dstar.exe will not give any
            indication of audio present. You can look at the dvtool.txt file in
            the folder that contains dvtool software and see call sign info that
            is also shown in dstar.exe. In that same file, dvtool.txt, after my
            first audio transmission it will say stream complete when it passes
            audio, but it still only passes on the first transmission.

            I'm not having any issues with connecting to gateways. I use 2 sound
            cards as well. Just make sure you select your sounds card with the
            headphones in the dvtool software at the top of the dvtool window.

            I'm looking forward to seeing if you can get the RF to dvdongle
            audio to working.

            Philip
            KB5ASY
          • rick.wakatori
            I have the same problem with you on the dstar.exe and DV-Tool. UDP Login 127.0.0.1:23813 - Added to client table(this varies by each connection even Peer to
            Message 5 of 13 , Mar 13, 2008
            • 0 Attachment
              I have the same problem with you on the dstar.exe and DV-Tool.
              UDP Login 127.0.0.1:23813 - Added to client table(this varies by
              each connection even Peer to Peer Port 6116 from DV-Tool.

              The dstar.exe reports Flags(00),Destination(DIRECT),Departure
              (DIRECT), Companion(CQCQCQ) and Stn.Callsign(7L1RLL C / 430).

              Audio sound from the speaker is same as speaker sound 'Gya Gha' of
              FT-100,FM mode, even if RF was sent by ID-91(same as ID-91AD except
              frequency range).

              Security does not protect port 6116 on the computer at the moment.
              DV-Dongle indicates to working (both red and blue LED lit).
              AMBE/Audio Loopback works well separately.

              Rick, 7L1RLL
              City of Kawasaki, Japan

              --- In DVDongle@yahoogroups.com, "Philip Robinson" <kb5asy@...>
              wrote:
              >
              > I'm having trouble getting audio to dvtool from dstar.exe.
              >
              > I have dstar.exe decoding the data from RF and I have the dv
              dongle
              > with dvtool working but when I try to pass data through 127.0.0.1
              port
              > 6116 I get no audio. I do get the message that dvtool has attached
              to
              > a specific port in dstar.exe. I have tried it on xp pro and vista.
              > They work fine separately but not together to pass audio.
              >
              > Any ideas?
              >
              > Thanks,
              >
              > Philip
              > KB5ASY
              >
            • rick.wakatori
              HI Philip, This computer has only one jack for both line-in and mic-in. Difference between mic-in and line-in is only amplitude selection (20dB up). DV-Tool
              Message 6 of 13 , Mar 14, 2008
              • 0 Attachment
                HI Philip,

                This computer has only one jack for both line-in and mic-in.
                Difference between mic-in and line-in is only amplitude selection
                (20dB up). DV-Tool can decode RF received data stream such
                callsign to display at assigned area.

                I have tried to switch the port 6116 to the others, but 6117
                could not be connected. Because I assigned port 6116 only
                for Peer to Peer connection at Windows firewal.

                Built-in audio speaker generates strong noise while D-STAR RF
                received.
                Blue LED and Red LED are lit during the operation.

                It seems that assignment of audio devices is incorrect or
                the output of DV-Dongle can not be specifyed to correct audio device
                (such 2nd USB headphone).

                I have still a difficulty to listning any human voice with DV-Dongle
                except loopback testing.

                Rick, 7L1RLL
                City of Kawasaki, Japan

                --- In DVDongle@yahoogroups.com, "Philip Robinson" <kb5asy@...> wrote:
                >
                > Rick,
                >
                > I had better data decoding using the "line in" of the sound card
                > than using the "mic" input but it sounds like you are decoding just
                > fine. I would suggest trying a different port such as 6117 or
                higher
                > if you have not already do so. Dstar.exe will default to 6116 but
                > can be forced to what ever port you like. I still have not got past
                > the first audio transmission limit and also not being able to reuse
                > the same port in the same dos session. Dstar.exe will not give any
                > indication of audio present. You can look at the dvtool.txt file in
                > the folder that contains dvtool software and see call sign info
                that
                > is also shown in dstar.exe. In that same file, dvtool.txt, after my
                > first audio transmission it will say stream complete when it passes
                > audio, but it still only passes on the first transmission.
                >
                > I'm not having any issues with connecting to gateways. I use 2
                sound
                > cards as well. Just make sure you select your sounds card with the
                > headphones in the dvtool software at the top of the dvtool window.
                >
                > I'm looking forward to seeing if you can get the RF to dvdongle
                > audio to working.
                >
                > Philip
                > KB5ASY
                >
              Your message has been successfully submitted and would be delivered to recipients shortly.