Loading ...
Sorry, an error occurred while loading the content.
 

[Czechlist] COMP: language setting in MS Office

Expand Messages
  • Jirka Bolech
    Hi there, Perhaps someone has quick advice on the following: when I highlight all text in a text box in a Microsoft PowerPoint 2007 document, set the language
    Message 1 of 7 , Nov 29 12:46 AM
      Hi there,

      Perhaps someone has quick advice on the following: when I highlight all
      text in a text box in a Microsoft PowerPoint 2007 document, set the
      language to different from Office 2007 default document edit language,
      the language setting switches over to the latter (default) at the
      pointer position when I start typing anywhere in the box. I think this
      happens in Word too. Setting the edit language for the entire document
      might help but I don't know how to do that in PowerPoint. Changing the
      Office default edit language doesn't help either (to my surprise), so it
      must be something to deal with within the document. This may actually
      mean that my initial description isn't completely right in referring to
      the Office default edit language. It really may be a different language
      setting.

      Any hints appreciated. Thanks...

      Jirka Bolech

      _______________________________________________
      Czechlist mailing list
      Czechlist@...
      http://www.czechlist.org/cgi-bin/mailman/listinfo/czechlist
    • Josef Hlavac
      Hi Jirka, how about your keyboard layout / language settings in Windows? Word (and I believe other Office apps as well) assume that if you type something using
      Message 2 of 7 , Nov 29 1:07 AM
        Hi Jirka,

        how about your keyboard layout / language settings in Windows? Word (and
        I believe other Office apps as well) assume that if you type something
        using a Czech keyboard layout, it is in Czech...

        (Well, to be more precise, the language and keyboard layout are separate
        settings, you can easily pair English language with Japanese keyboard
        for instance, and the language is what matters. But you get my point I
        hope.)

        Josef


        On 29.11.2011 9:46, Jirka Bolech wrote:
        > Hi there,
        >
        > Perhaps someone has quick advice on the following: when I highlight
        > all text in a text box in a Microsoft PowerPoint 2007 document, set
        > the language to different from Office 2007 default document edit
        > language, the language setting switches over to the latter (default)
        > at the pointer position when I start typing anywhere in the box. I
        > think this happens in Word too. Setting the edit language for the
        > entire document might help but I don't know how to do that in
        > PowerPoint. Changing the Office default edit language doesn't help
        > either (to my surprise), so it must be something to deal with within
        > the document. This may actually mean that my initial description isn't
        > completely right in referring to the Office default edit language. It
        > really may be a different language setting.
        >
        > Any hints appreciated. Thanks...
        >
        > Jirka Bolech
        >
        > _______________________________________________
        > Czechlist mailing list
        > Czechlist@...
        > http://www.czechlist.org/cgi-bin/mailman/listinfo/czechlist

        _______________________________________________
        Czechlist mailing list
        Czechlist@...
        http://www.czechlist.org/cgi-bin/mailman/listinfo/czechlist
      • Jirka Bolech
        A bit of an additional comment: I could overcome the language setting annoyance by using a tag editor, which is a desirable mode of work anyway, but the
        Message 3 of 7 , Nov 29 1:07 AM
          A bit of an additional comment: I could overcome the language setting
          annoyance by using a tag editor, which is a desirable mode of work
          anyway, but the document has so many tags in it where apparently there
          is no complex formatting (within text in the same font) that I found
          this way, and still find it, even more annoying. The only fix I see to
          that is manually removing all formatting (the button at the top right
          corner of the font setting group of buttons in Office 2007) and
          reformatting to what it should be box by box or slide by slide at best.
          I use CodeZapper for Word documents to get rid of such superfluous tags
          but there ain't such an animal for PowerPoint. Again, if someone has a
          solution, I'm sure everyone on the list will prick their ears to hear it...

          Jirka Bolech

          _______________________________________________
          Czechlist mailing list
          Czechlist@...
          http://www.czechlist.org/cgi-bin/mailman/listinfo/czechlist
        • Jirka Bolech
          Hey Josef, Yeees. How simple! I ve just switched the keyboard and the language follows. Great thanks. Now I feel stupid I didn t think of this... Jirka Bolech
          Message 4 of 7 , Nov 29 1:14 AM
            Hey Josef,

            Yeees. How simple! I've just switched the keyboard and the language
            follows. Great thanks. Now I feel stupid I didn't think of this...

            Jirka Bolech


            _______________________________________________
            Czechlist mailing list
            Czechlist@...
            http://www.czechlist.org/cgi-bin/mailman/listinfo/czechlist
          • Jirka Bolech
            Now that Josef has solved my language setting problem, my other query should deserve a new thread: A document has so many tags in it where apparently there is
            Message 5 of 7 , Nov 29 1:18 AM
              Now that Josef has solved my language setting problem, my other query
              should deserve a new thread:

              A document has so many tags in it where apparently there is no complex
              formatting (within text in the same font) that I find using a tag editor
              very annoying. The only fix I see to that is manually removing all
              formatting (the button at the top right corner of the font setting group
              of buttons in Office 2007) and reformatting to what it should be box by
              box or slide by slide at best. I use CodeZapper for Word documents to
              get rid of such superfluous tags but there ain't such an animal for
              PowerPoint. If someone has a solution, I'm sure everyone on the list
              will prick their ears to hear it...

              Jirka Bolech

              _______________________________________________
              Czechlist mailing list
              Czechlist@...
              http://www.czechlist.org/cgi-bin/mailman/listinfo/czechlist
            • James Kirchner
              You can change the default language of a whole PowerPoint presentation by clicking into the outline view (I think that s what it s called; it s where you have
              Message 6 of 7 , Nov 29 3:41 AM
                You can change the default language of a whole PowerPoint presentation by clicking into the outline view (I think that's what it's called; it's where you have only the text of the presentation over to the left), selecting all and then resetting the language. At least that always works for me.

                Jamie

                On Nov 29, 2011, at 3:46 AM, Jirka Bolech wrote:

                > Hi there,
                >
                > Perhaps someone has quick advice on the following: when I highlight all text in a text box in a Microsoft PowerPoint 2007 document, set the language to different from Office 2007 default document edit language, the language setting switches over to the latter (default) at the pointer position when I start typing anywhere in the box. I think this happens in Word too. Setting the edit language for the entire document might help but I don't know how to do that in PowerPoint. Changing the Office default edit language doesn't help either (to my surprise), so it must be something to deal with within the document. This may actually mean that my initial description isn't completely right in referring to the Office default edit language. It really may be a different language setting.
                >
                > Any hints appreciated. Thanks...
                >
                > Jirka Bolech
                >
                > _______________________________________________
                > Czechlist mailing list
                > Czechlist@...
                > http://www.czechlist.org/cgi-bin/mailman/listinfo/czechlist


                _______________________________________________
                Czechlist mailing list
                Czechlist@...
                http://www.czechlist.org/cgi-bin/mailman/listinfo/czechlist
              • Jirka Bolech
                Thanks Josef and Jamie, Obviously, Josef s advice was what I needed. I ve also tried your hint, Jamie, but I don t think it worked for me. I was able to carry
                Message 7 of 7 , Nov 29 12:40 PM
                  Thanks Josef and Jamie,

                  Obviously, Josef's advice was what I needed. I've also tried your hint,
                  Jamie, but I don't think it worked for me. I was able to carry out each
                  step but to no avail: there are still different language settings
                  throughout the document.

                  The main lesson thus goes: the language of text you're typing follows
                  the keyboard language selection as of the cursor position in Microsoft
                  Office 2007 applications...

                  Jirka Bolech


                  _______________________________________________
                  Czechlist mailing list
                  Czechlist@...
                  http://www.czechlist.org/cgi-bin/mailman/listinfo/czechlist
                Your message has been successfully submitted and would be delivered to recipients shortly.