Loading ...
Sorry, an error occurred while loading the content.

Re: =CROSLEY= Hot Shot Water Temp Bulb

Expand Messages
  • Peter Berard
    Hello Ron You have experianced what most of us Cros Threaded nuts have . The housing the temp bulb lives in is aluminum, steel or iron and creates a chemical
    Message 1 of 2 , Jul 7, 2010
    View Source
    • 0 Attachment
      Hello Ron
        You have experianced what most of us Cros Threaded nuts have .  The housing the temp bulb lives in is aluminum, steel or iron and creates a chemical reaction with the copper or brass of the temp bulb. Unlike alloys do an act known as electrolysis.  Unlike metals seem to want to destroy one another when immersed in water. They make a corrosion that builds up and welds them together.
       
        I spent the better half of a day trying to save my temp gage in my 48 Crosley truck, all the while knowing the results it I broke the continuity of the bulb and gage.     I failed.
       
        The capillary tube is filled with a predetermined amount of liquid, (smells like denatured alcohol or somethin similar to white lightnin') that expands with the increasing temp of what the bulb it is held in. This puts pressure on a diaphragm or similar device that mechanically causes the temp gage needle to move relative to the device being measured. 
       
         So, once the capillary tube is severed and this premeasured stuff has escaped it's confines, it'll take an instrument specialist to refill and calibrate the gage. 
       
       There are many companies who can do this for you, but it is at a cost.  Call a few you can find on line.................pete
       
        PS......I temporarily installed a NAPA gage that likely cost half as much as doing it the right way.   Bit my own self on the butt.
       
       
      ----- Original Message -----
      From: rcjanes
      Sent: Monday, July 05, 2010 8:56 PM
      Subject: =CROSLEY= Hot Shot Water Temp Bulb

       

      I'm restoring my 1950 HotShot. When I disconnected the tube that goes from the block to the temp gauge, the little bulb at the end broke off and stayed in the block. I was finally able to get it out, but can't reconnect it to the tube. Can I get a new bulb and tube, or do I have to get the temp reading from another location? Any advice would be appreciated.

      Thanks,

      Ron

    Your message has been successfully submitted and would be delivered to recipients shortly.