Loading ...
Sorry, an error occurred while loading the content.

3562Re: Running hot

Expand Messages
  • butch46988
    May 19 6:35 PM
    • 0 Attachment
      Steve,

      Yes we have them in stock.

      Butch and Fonda Williams, Service Motors Inc., 1-574-664-3313, www.servicemotors.net

      --- In Crosley@yahoogroups.com, Steve Carroll <steve@...> wrote:
      >
      > Now that's interesting! I don't remember any shrouds at all. The car is over at mr remote garage, so I can't pop out right now and check. Do you guys sell them?
      > Steve
      >
      > Via iPad
      >
      > On May 19, 2013, at 8:24 PM, "butch46988" <butch@...> wrote:
      >
      > > Has the car got the radiators shrouds (two pieces if cardboard, one on each side of the radiator) installed?
      > >
      > > These are a MUST to keep all of the air going through the radiator, rather than around it.
      > >
      > > Butch and Fonda Williams, Service Motors Inc., 1-574-664-3313, www.servicemotors.net
      > >
      > > --- In Crosley@yahoogroups.com, Steve Carroll <steve@> wrote:
      > > >
      > > > Hi Kenneth,
      > > > The engine did sit for a while in the 60s- 70s, but for the past 15 years or so it has been driven some. Not a lot or for and distance. I'm sure I've put more miles on it the last 2 months than its seen in the lat 10 years.
      > > >
      > > > I haven't checked the timing, but the previous owner said he had. It starts and runs great. I suppose I should check it.
      > > >
      > > >
      > > >
      > > > Via iPad
      > > >
      > > > On May 19, 2013, at 3:41 PM, Kenneth Cahill <kcahill@> wrote:
      > > >
      > > > > If this is an engine that has been sitting a long time, the water jacket of the block could also be full of rust and other crud. The radiator could be blocked with crud. The timing could be off, too.
      > > > > Crosley's offer you many choices.
      > > > >
      > > > > Sent from my iPhone
      > > > >
      > > > > On May 19, 2013, at 6:38 AM, "Peter Berard" <berard_m@> wrote:
      > > > >
      > > > >>
      > > > >> Insure the water pump is turning, i.e. belt properly tensioned and the rubber coupling behind the generator in good shape.
      > > > >>
      > > > >> I'd check the thermostat first.
      > > > >> Remove and place it in water. Using a thermometer, gradually increase the temp on the stove till ya reach the temp stamped on the stat. It should open fully by the time it reaches that temp, Usually around 160 or so degrees on Crosley stats.
      > > > >> If this is a sudden change, I doubt the radiator is at fault...................p
      > > > >> ----- Original Messsge -----
      > > > >> From: Steve Carroll
      > > > >> To: Crosley@yahoogroups.com
      > > > >> Sent: Saturday, May 18, 2013 3:22 PM
      > > > >> Subject: =CROSLEY CAR OWNERS CLUB= Running hot
      > > > >>
      > > > >>
      > > > >> Went to a car show today. Temps high-mid 80's. maybe 5-20 min drive. Temp went way up. To the H in Hot. Topped off radiator, but did the same on way home. Never went over 3/4 mark before. Where should begin looking? Is this common?
      > > > >>
      > > > >> Steve Carroll
      > > > >> 1947 Crosley Station Wagon
      > > > >> CiBRA engine
      > > > >>
      > > > >> Via iPad
      > > > >>
      > > > >
      > > > >
      > > >
      > >
      > >
      >
    • Show all 14 messages in this topic