Loading ...
Sorry, an error occurred while loading the content.

Job's ODATE past working date

Expand Messages
  • Cezar Serban
    I have a scheduling group of jobs that did not execute for yesterday s ODATE due to a missing condition, but still remain in the AJF for today. However, when I
    Message 1 of 4 , Jun 2, 2009
    • 0 Attachment
      I have a scheduling group of jobs that did not execute for yesterday's ODATE due to a missing condition, but still remain in the AJF for today. However,  when I do a 'Why' on any of the jobs, I see the following message:

      Performing 'why' on the group entity....
      "Job's Odate is earlier than the CONTROL-M working date for the relevant timezone. Job will not run."

      How can I configure the jobs so that they can still run even though their ODATE has passed? ....

      Thanks,
      -Cezar
    • Aruneesh Salhotra
      You need to enable RETRO checkbox in the scheduling tab. Sent by GoodLink (www.good.com) ... From: Cezar Serban [mailto:afroromanian@gmail.com] Sent:
      Message 2 of 4 , Jun 2, 2009
      • 0 Attachment
        You need to enable RETRO checkbox in the scheduling tab.


        Sent by GoodLink (www.good.com)


        -----Original Message-----
        From: Cezar Serban [mailto:afroromanian@...]
        Sent: Tuesday, June 02, 2009 10:01 AM Eastern Standard Time
        To: Control-X@yahoogroups.com
        Subject: [Control-X] Job's ODATE past working date



        I have a scheduling group of jobs that did not execute for yesterday's ODATE due to a missing condition, but still remain in the AJF for today. However, when I do a 'Why' on any of the jobs, I see the following message:

        Performing 'why' on the group entity....
        "Job's Odate is earlier than the CONTROL-M working date for the relevant timezone. Job will not run."

        How can I configure the jobs so that they can still run even though their ODATE has passed? ....

        Thanks,
        -Cezar
      • markssf
        Hi guys, Retro is really designed for when you switch off the CTM Server and you want missed jobs to be retrospectively ordered when New Day Processing
        Message 3 of 4 , Jun 2, 2009
        • 0 Attachment
          Hi guys,
          Retro is really designed for when you switch off the CTM Server and you want "missed" jobs to be retrospectively ordered when New Day Processing occurs at a later date. Conditions are usually run with date stamps attached (DDMM) and can be processed thus -

          ODAT. i.e. the job's original scheduling date.
          PREV i.e. the job's previous scheduling date.
          NEXT i.e. the job's next scheduling date.
          **** (or $$$$) Any scheduling date regardless.
          STAT i.e. STATIC or not date-dependent.

          STAT would be a good choice if you simply don't care about dates. The message you are getting does mention timezones - are you actively using the timezone parm?

          Mark.

          --- In Control-X@yahoogroups.com, Aruneesh Salhotra <asalhotra@...> wrote:
          >
          > You need to enable RETRO checkbox in the scheduling tab.
          >
          >
          > Sent by GoodLink (www.good.com)
          >
          >
          > -----Original Message-----
          > From: Cezar Serban [mailto:afroromanian@...]
          > Sent: Tuesday, June 02, 2009 10:01 AM Eastern Standard Time
          > To: Control-X@yahoogroups.com
          > Subject: [Control-X] Job's ODATE past working date
          >
          >
          >
          > I have a scheduling group of jobs that did not execute for yesterday's ODATE due to a missing condition, but still remain in the AJF for today. However, when I do a 'Why' on any of the jobs, I see the following message:
          >
          > Performing 'why' on the group entity....
          > "Job's Odate is earlier than the CONTROL-M working date for the relevant timezone. Job will not run."
          >
          > How can I configure the jobs so that they can still run even though their ODATE has passed? ....
          >
          > Thanks,
          > -Cezar
          >
        • Cezar Serban
          I am not using the timezone parameter. The first job in the scheduling table is in fact dependent on PREV of the last job s out condition indicating it should
          Message 4 of 4 , Jun 2, 2009
          • 0 Attachment
            I am not using the timezone parameter.

            The first job in the scheduling table is in fact dependent on PREV of the last job's out condition indicating it should only run in order. However, I also want to just be able to order and run jobs for ODATE values in the past in an ad-hoc way.  In the example I have, I don't think I'll even be able to order the jobs for a prior ODATE before the current Control-M working date. What would be the easiest way to fix this for ALL the jobs in my scheduling table ?

            On Tue, Jun 2, 2009 at 10:53 AM, markssf <mark@...> wrote:


            Hi guys,
            Retro is really designed for when you switch off the CTM Server and you want "missed" jobs to be retrospectively ordered when New Day Processing occurs at a later date. Conditions are usually run with date stamps attached (DDMM) and can be processed thus -

            ODAT. i.e. the job's original scheduling date.
            PREV i.e. the job's previous scheduling date.
            NEXT i.e. the job's next scheduling date.
            **** (or $$$$) Any scheduling date regardless.
            STAT i.e. STATIC or not date-dependent.

            STAT would be a good choice if you simply don't care about dates. The message you are getting does mention timezones - are you actively using the timezone parm?

            Mark.



            --- In Control-X@yahoogroups.com, Aruneesh Salhotra <asalhotra@...> wrote:
            >
            > You need to enable RETRO checkbox in the scheduling tab.
            >
            >
            > Sent by GoodLink (www.good.com)
            >
            >
            > -----Original Message-----
            > From: Cezar Serban [mailto:afroromanian@...]
            > Sent: Tuesday, June 02, 2009 10:01 AM Eastern Standard Time
            > To: Control-X@yahoogroups.com
            > Subject: [Control-X] Job's ODATE past working date
            >
            >
            >
            > I have a scheduling group of jobs that did not execute for yesterday's ODATE due to a missing condition, but still remain in the AJF for today. However, when I do a 'Why' on any of the jobs, I see the following message:
            >
            > Performing 'why' on the group entity....
            > "Job's Odate is earlier than the CONTROL-M working date for the relevant timezone. Job will not run."
            >
            > How can I configure the jobs so that they can still run even though their ODATE has passed? ....
            >
            > Thanks,
            > -Cezar
            >


          Your message has been successfully submitted and would be delivered to recipients shortly.